<!DOCTYPE html>
<!--[if lt IE 7]><html lang="en" class="no-js lt-ie9 lt-ie8 lt-ie7" prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb# article: http://ogp.me/ns/article# video: http://ogp.me/ns/video#
profile: http://ogp.me/ns/profile#"><![endif]-->
<!--[if IE 7]><html lang="en" class="no-js lt-ie9 lt-ie8" prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb# article: http://ogp.me/ns/article# video: http://ogp.me/ns/video#
profile: http://ogp.me/ns/profile#"><![endif]-->
<!--[if IE 8]><html lang="en" class="no-js lt-ie9" prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb# article: http://ogp.me/ns/article# video: http://ogp.me/ns/video#
profile: http://ogp.me/ns/profile#"><![endif]-->
<!--[if IE 9]><html lang="en" class="no-js ie9" prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb# article: http://ogp.me/ns/article# video: http://ogp.me/ns/video#
profile: http://ogp.me/ns/profile#" ><![endif]-->
<!--[if gt IE 8]><!--><html class="no-js" lang="en" dir="ltr">
<head>

<script src="/cdn-cgi/apps/head/cf_9l7RKgDs4MbXIY5TRYBrR1cs.js"></script><script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-KBT24PQ');</script>

<meta charset="UTF-8">
<link rel="apple-touch-icon" sizes="180x180" href="/resource/crblob/654062/401e0e1f2272bebbbcd23456403002c4/apple-touch-icon-png-data.png">
<link rel="icon" type="image/png" sizes="32x32" href="/resource/crblob/654080/663580258f749228316ee276e0f3cd6c/favicon-32x32-png-data.png">
<link rel="icon" type="image/png" sizes="16x16" href="/resource/crblob/654078/daa211aeb0ce3157f0075e45c26364bf/favicon-16x16-png-data.png">
<link rel="manifest" href="/site.webmanifest">
<link rel="mask-icon" href="/resource/crblob/654108/050c2c369f7ecebd815fb78f4057e9af/safari-pinned-tab-svg-data.svg" color="#5bbad5">
<link rel="shortcut icon" type="image/x-icon" href="/resource/crblob/654082/6813c1d688e9fadd7b8f7189a6e5179f/favicon-ico-data.ico">
<meta name="msapplication-TileColor" content="#da532c">
<title>&#39;The Greedy Barbarian&#39; is more Idi Amin than Museveni - The East African</title>
<meta name="keywords" content="Ugandan President Yoweri Museveni,Kakwenza Rukirabashaija,Muhoozi Kainerubaga, Commander of Uganda’s Land Forces, Constitutional rights,Ugandan CID,Boxing Day,The Greedy Barbarian ,PEN International Writer of Courage in 2021,Tsitsi Dangaremba ">
<meta name="viewport" content="width=device-width, initial-scale=1">
<meta name="robots" content="index, follow" />
<meta name="viewport" content="width=device-width,initial-scale=1.0,user-scalable=0">
<script type="application/ld+json">
{
"@context": "https://schema.org",
"@type": "NewsArticle",
"mainEntityOfPage": {
"@type": "WebPage",
"@id": "https://www.theeastafrican.co.ke/tea/magazine/the-greedy-barbarian-more-idi-amin-than-museveni-3689390"
},
"name": "&apos;The Greedy Barbarian&apos; is more Idi Amin than Museveni",
"headline": "&apos;The Greedy Barbarian&apos; is more Idi Amin than Museveni",
"description": "<p>The first time Ugandan police arrested Rukirabashajia was in April of 2020, just after Covid-19 had struck Uganda’s shores. <\/p>",
"image": {"@type": "ImageObject", "url": "https://www.theeastafrican.co.ke/resource/blob/3689406/e80ebd807411f4cc652364cbb1da6280/the-greedy-barbarian-data.jpg", "height": 391, "width": 696 },
"datePublished": "2022-01-21T09:45:00Z",
"dateModified": "2022-01-21T09:57:22Z",
"author": [
{ "@type": "Person",
"name": "TONY MOCHAMA",
"url": "https://www.theeastafrican.co.ke/tea/author-profiles/tony-mochama-3689394"
}
],
"publisher": {
"@type": "Organization",
"name": "The East African",
"logo": {
"@type": "ImageObject",
"url": "https://www.theeastafrican.co.ke/resource/crblob/654080/663580258f749228316ee276e0f3cd6c/favicon-32x32-png-data.png",
"width":40,
"height":29
}
}
}
</script>
<script type="application/ld+json">
{
"@context": "http://schema.org",
"@type": "BreadcrumbList",
"itemListElement": [
{
"@type": "ListItem",
"position": 1,
"name": "Home",
"item": "https://www.theeastafrican.co.ke/tea"
}
,
{
"@type": "ListItem",
"position": 2,
"name": "Magazine",
"item": "https://www.theeastafrican.co.ke/tea/magazine"
}
]
}
</script>
<meta name="description" content="
The first time Ugandan police arrested Rukirabashajia was in April of 2020, just after Covid-19 had struck Uganda’s shores. ">
<meta property="og:site_name" content="The East African" />
<meta property="og:type" content="article" />
<meta property="fb:app_id" content="174023979648743" />
<meta property="og:title" content="&#39;The Greedy Barbarian&#39; is more Idi Amin than Museveni" />
<meta property="og:url" content="https://www.theeastafrican.co.ke/tea/magazine/the-greedy-barbarian-more-idi-amin-than-museveni-3689390" />
<meta property="og:description" content="
The first time Ugandan police arrested Rukirabashajia was in April of 2020, just after Covid-19 had struck Uganda’s shores. " />
<meta property="og:locale" content="en" />
<meta property="og:locale:alternate" content="en_US" />
<meta property="og:article:published_time" content="2022-01-21 12:57:22" />
<meta property="og:image" content="https://www.theeastafrican.co.ke/resource/blob/3689406/e80ebd807411f4cc652364cbb1da6280/the-greedy-barbarian-data.jpg">
<meta name="twitter:card" content="summary_large_image">
<meta name="twitter:site" content="@The_EastAfrican">
<meta name="twitter:title" content="&#39;The Greedy Barbarian&#39; is more Idi Amin than Museveni">
<meta name="twitter:description" content="
The first time Ugandan police arrested Rukirabashajia was in April of 2020, just after Covid-19 had struck Uganda’s shores. ">
<meta name="twitter:image" content="https://www.theeastafrican.co.ke/resource/blob/3689406/e80ebd807411f4cc652364cbb1da6280/the-greedy-barbarian-data.jpg"> <meta charset="utf-8">
<link rel="canonical" href="https://www.theeastafrican.co.ke/tea/magazine/the-greedy-barbarian-more-idi-amin-than-museveni-3689390">
<meta name="google-site-verification" content="7PI23eF83yLrptihU4-C11bEaznAQl8mts5BfCS1W2U" />
<script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>
<script>
var googletag = googletag || {};
googletag.cmd = googletag.cmd || [];
</script>
<script>document.documentElement.className = document.documentElement.className.replace(/no-js/g, 'js');</script>
<link href="//cdnjs.cloudflare.com/ajax/libs/font-awesome/4.7.0/css/font-awesome.min.css" rel="stylesheet">
<link rel="stylesheet" href="//secure.widget.cloud.opta.net/v3/css/v3.core.opta-widgets.css">
<link rel="stylesheet" href="//secure.widget.cloud.opta.net/v3/css/v3.football.opta-widgets.css">
<link rel="amphtml" href="https://www.theeastafrican.co.ke/tea/magazine/the-greedy-barbarian-more-idi-amin-than-museveni-3689390?view=htmlamp">
<script type="text/javascript">
window._taboola = window._taboola || [];
_taboola.push({article:'auto'});
!function (e, f, u, i) {
if (!document.getElementById(i)){
e.async = 1;
e.src = u;
e.id = i;
f.parentNode.insertBefore(e, f);
}
}(document.createElement('script'),
document.getElementsByTagName('script')[0],
'//cdn.taboola.com/libtrc/nationmediagroup-dailynation/loader.js',
'tb_loader_script');
if(window.performance && typeof window.performance.mark == 'function')
{window.performance.mark('tbl_ic');}
</script>
<link href="/resource/themes/east-african/css/east-african-654262-131.css" rel="stylesheet">
<script type="text/javascript"> function GaAccountData(webPropertyId, domainName) {
this.webPropertyId = webPropertyId;
this.domainName = domainName;
}
function GaPageviewData(contentId, contentType, navigationPath, pageUrl, authors, pubDate, tags, queryParameter, query, userSegments, disableAdFeaturesPlugin) {
this.contentId = contentId;
this.contentType = contentType;
this.navigationPath = navigationPath;
this.pageUrl = pageUrl;
this.authors = authors;
this.pubDate = pubDate;
this.tags = tags;
this.queryParameter = queryParameter;
this.query = query;
this.userSegments = userSegments;
this.disableAdvertisingFeaturesPlugin = typeof disableAdFeaturesPlugin !== 'undefined' ? disableAdFeaturesPlugin : false;
}
function GaEventData(category, action, name, value) {
this.category = category;
this.action = action;
this.name = name;
this.value = value;
}
function gaTrackPageview(ga, gaAccountData, gaPageviewData, trackerName) {
var t = _gaTrackerPrefix(trackerName);
//set Account
if (trackerName && trackerName.length > 0) {
ga('create', gaAccountData.webPropertyId, gaAccountData.domainName, {'name': trackerName});
} else {
ga('create', gaAccountData.webPropertyId, gaAccountData.domainName);
}
ga(t.concat('set'), 'anonymizeIp', true);
if (!gaPageviewData.disableAdvertisingFeaturesPlugin) {
ga(t.concat('require'), 'displayfeatures');
}
//set custom vars
ga(t.concat('set'), 'dimension1', gaPageviewData.contentId);
ga(t.concat('set'), 'dimension2', gaPageviewData.contentType);
ga(t.concat('set'), 'dimension3', gaPageviewData.navigationPath);
ga(t.concat('set'), 'dimension4', gaPageviewData.userSegments);
ga(t.concat('set'), 'dimension5', gaPageviewData.authors);
ga(t.concat('set'), 'dimension6', gaPageviewData.pubDate);
ga(t.concat('set'), 'dimension7', gaPageviewData.tags);
// if a search was performed on the website, retain the search query
var query = "";
if (gaPageviewData.query && gaPageviewData.queryParameter) {
query = "?" + gaPageviewData.queryParameter + "=" + encodeURIComponent(gaPageviewData.query);
}
//send page view
ga(t.concat('send'), 'pageview', gaPageviewData.pageUrl + query);
}
function gaTrackEvent(ga, gaAccountData, gaPageviewData, gaEventData, trackerName) {
var t = _gaTrackerPrefix(trackerName);
//set Account
if (trackerName && trackerName.length > 0) {
ga('create', gaAccountData.webPropertyId, gaAccountData.domainName, {'name': trackerName});
} else {
ga('create', gaAccountData.webPropertyId, gaAccountData.domainName);
}
ga(t.concat('set'), 'anonymizeIp', true);
if (!gaPageviewData.disableAdvertisingFeaturesPlugin) {
ga(t.concat('require'), 'displayfeatures');
}
//set custom vars
ga(t.concat('set'), 'dimension1', gaPageviewData.contentId);
ga(t.concat('set'), 'dimension2', gaPageviewData.contentType);
ga(t.concat('set'), 'dimension3', gaPageviewData.navigationPath);
ga(t.concat('set'), 'dimension4', gaPageviewData.userSegments);
ga(t.concat('set'), 'dimension5', gaPageviewData.authors);
ga(t.concat('set'), 'dimension6', gaPageviewData.pubDate);
ga(t.concat('set'), 'dimension7', gaPageviewData.tags);
//sent event
ga(t.concat('send'), 'event', gaEventData.category, gaEventData.action, gaEventData.name, gaEventData.value);
}
function _gaTrackerPrefix(trackerName) {
return (trackerName && trackerName.length > 0)
? trackerName.concat('.')
: '';
}
(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
})(window,document,'script','//www.google-analytics.com/analytics.js','ga');
var gaAccountData = new GaAccountData("UA-1030601-5", "www.theeastafrican.co.ke");
var gaPageData = new GaPageviewData(
"3689390",
"CMArticle",
"1289142_1289152",
"/tea/magazine/the-greedy-barbarian-more-idi-amin-than-museveni-3689390",
"TONY MOCHAMA",
"21-01-2022",
"",
false
);
gaTrackPageview(ga, gaAccountData, gaPageData);
</script> <script async src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
<script async src='/cdn-cgi/bm/cv/669835187/api.js'></script></head><body id="top" style="zoom:1;">

<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-KBT24PQ"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>

<nav class="navbar navbar-default full-width">
<div class="container justify-content-between justify-content-md-start">
<div class="navbar-header">
<a href="/tea" class="logo"></a>
</div>
<ul id="panel" class="nav navbar-nav d-md-none">
<li><a href="/tea/news">News</a></li>
<li><a href="/tea/business">Business</a></li>
<li><a href="/tea/oped">Opinion</a></li>
<li><a href="/tea/science-health">Science &amp; Health</a></li>
<li><a href="/tea/magazine">Magazine</a></li>
<li><a href="/tea/sports">Sports</a></li>
<li><a href="/tea/rest-of-africa">Rest of Africa</a></li>
<li><a href="/tea/kusi-ideas">KUSI IDEAS</a></li>
</ul>
<ul class="nav navbar-nav d-none d-md-block pl-lg-3">
<li>
<a href="/tea/news">News</a>
<div class="mega-menu">
<div class="row no-gutters">
<div class="col-3">
<a href="/tea/news/east-africa">East Africa</a>
<a href="/tea/news/rest-of-africa">Rest of Africa</a>
<a href="/tea/news/world">World</a>
</div>
<div class="col-8 offset-1">
<h4>Latest News</h4>
<div class="row no-gutters">
<div class="col-6">
<div class="story-teaser tiny-teaser">
<a href="/tea/news/east-africa/police-to-ease-traffic-along-the-webuye-malaba-highway-3689644"><i class="fa fa-caret-right" aria-hidden="true"></i> Police swing into action to ease traffic along the Webuye-Malaba Highway</a>
</div>
<div class="story-teaser tiny-teaser">
<a href="/tea/rest-of-africa/al-shabab-leader-arrested-in-mozambique-3688424"><i class="fa fa-caret-right" aria-hidden="true"></i> Al-Shabaab leader arrested in Mozambique</a>
</div>
</div>
<div class="col-6">
<div class="story-teaser tiny-teaser">
<a href="/tea/news/east-africa/armed-conflict-climate-change-fan-africa-refugee-crisis-3689500"><i class="fa fa-caret-right" aria-hidden="true"></i> Armed conflict, climate change fan Africa’s refugee crisis</a>
</div>
<div class="story-teaser tiny-teaser">
<a href="/tea/news/east-africa/female-migrants-struggle-to-integrate-back-home-3689496"><i class="fa fa-caret-right" aria-hidden="true"></i> Female migrants struggle to integrate back home</a>
</div>
</div>
</div>
</div> </div>
</div>
</li>
<li>
<a href="/tea/business">Business</a>
<div class="mega-menu">
<div class="row no-gutters">
<div class="col-3">
</div>
<div class="col-8 offset-1">
<h4>Latest Business</h4>
<div class="row no-gutters">
<div class="col-6">
<div class="story-teaser tiny-teaser">
<a href="/tea/business/uganda-tanzania-resume-talks-over-non-tariff-barriers-3688438"><i class="fa fa-caret-right" aria-hidden="true"></i> Uganda, Tanzania resume talks over trade barriers</a>
</div>
<div class="story-teaser tiny-teaser">
<a href="/tea/business/uganda-tanzania-top-as-kenya-tourist-sources-3688022"><i class="fa fa-caret-right" aria-hidden="true"></i> US, Uganda, Tanzania top as Kenya’s tourist sources</a>
</div>
</div>
<div class="col-6">
<div class="story-teaser tiny-teaser">
<a href="/tea/business/world-mobile-zanzibar-wi-fi-project-3687362"><i class="fa fa-caret-right" aria-hidden="true"></i> World Mobile, Zanzibar launch free Wi-Fi connectivity project</a>
</div>
<div class="story-teaser tiny-teaser">
<a href="/tea/business/exim-plans-merger-with-first-national-3687262"><i class="fa fa-caret-right" aria-hidden="true"></i> Exim plans merger with First National</a>
</div>
</div>
</div>
</div> </div>
</div>
</li>
<li>
<a href="/tea/oped">Opinion</a>
<div class="mega-menu">
<div class="row no-gutters">
<div class="col-3">
</div>
<div class="col-8 offset-1">
<h4>Latest Opinion</h4>
<div class="row no-gutters">
<div class="col-6">
<div class="story-teaser tiny-teaser">
<a href="/tea/oped/comment/why-firms-must-evolve-along-with-customer-demand-3689482"><i class="fa fa-caret-right" aria-hidden="true"></i> Why firms must evolve along with customer demand for instant fixes</a>
</div>
<div class="story-teaser tiny-teaser">
<a href="/tea/oped/comment/our-social-media-is-a-melee-it-lacks-politeness-and-carefulness-3689478"><i class="fa fa-caret-right" aria-hidden="true"></i> Our social media is a melee as it lacks politeness and carefulness</a>
</div>
</div>
<div class="col-6">
<div class="story-teaser tiny-teaser">
<a href="/tea/oped/comment/why-do-rich-countries-borrow-poor-ones-it-s-abnormal-3688006"><i class="fa fa-caret-right" aria-hidden="true"></i> Why do rich countries borrow from poor ones? It’s abnormal!</a>
</div>
<div class="story-teaser tiny-teaser">
<a href="/tea/oped/comment/a-few-basic-dos-don-ts-to-learn-and-unlearn-in-post-magufuli-era-3687988"><i class="fa fa-caret-right" aria-hidden="true"></i> A few basic dos, don’ts to learn and unlearn in post-Magufuli era</a>
</div>
</div>
</div>
</div> </div>
</div>
</li>
<li>
<a href="/tea/science-health">Science &amp; Health</a>
<div class="mega-menu">
<div class="row no-gutters">
<div class="col-3">
</div>
<div class="col-8 offset-1">
<h4>Latest Science &amp; Health</h4>
<div class="row no-gutters">
<div class="col-6">
<div class="story-teaser tiny-teaser">
<a href="/tea/science-health/elephant-spawns-twins-in-rarely-observed-event-3689132"><i class="fa fa-caret-right" aria-hidden="true"></i> Elephant spawns twins in rarely observed event</a>
</div>
<div class="story-teaser tiny-teaser">
<a href="/tea/science-health/team-to-study-ea-rift-system-slow-break-up-3688084"><i class="fa fa-caret-right" aria-hidden="true"></i> Team to study EA Rift System&#39;s slow break-up</a>
</div>
</div>
<div class="col-6">
<div class="story-teaser tiny-teaser">
<a href="/tea/science-health/cholera-lassa-fever-kill-3-804-nigerians-3686850"><i class="fa fa-caret-right" aria-hidden="true"></i> Cholera, Lassa fever kill 3,804 Nigerians </a>
</div>
<div class="story-teaser tiny-teaser">
<a href="/tea/science-health/sti-spike-among-kenyan-teens-blamed-on-lockdown-3683582"><i class="fa fa-caret-right" aria-hidden="true"></i> STI spike among Kenyan teens blamed on lockdown</a>
</div>
</div>
</div>
</div> </div>
</div>
</li>
<li>
<a href="/tea/magazine">Magazine</a>
<div class="mega-menu">
<div class="row no-gutters">
<div class="col-3">
</div>
<div class="col-8 offset-1">
<h4>Latest Magazine</h4>
<div class="row no-gutters">
<div class="col-6">
<div class="story-teaser tiny-teaser">
<a href="/tea/magazine/fort-ternan-a-tunnel-to-kenya-s-mixed-colonial-past-3689516"><i class="fa fa-caret-right" aria-hidden="true"></i> Fort Ternan: A tunnel to Kenya&#39;s mixed colonial past</a>
</div>
<div class="story-teaser tiny-teaser">
<a href="/tea/magazine/the-greedy-barbarian-more-idi-amin-than-museveni-3689390"><i class="fa fa-caret-right" aria-hidden="true"></i> &#39;The Greedy Barbarian&#39; is more Idi Amin than Museveni</a>
</div>
</div>
<div class="col-6">
<div class="story-teaser tiny-teaser">
<a href="/tea/magazine/zanzibar-s-biubwa-amour-life-ideals-were-woke-radical-3689328"><i class="fa fa-caret-right" aria-hidden="true"></i> Zanzibar&#39;s Biubwa Amour life ideals were woke and radical </a>
</div>
<div class="story-teaser tiny-teaser">
<a href="/tea/magazine/kenyan-ugandan-creatives-win-global-recognition-3689304"><i class="fa fa-caret-right" aria-hidden="true"></i> Kenyan, Ugandan creatives win global recognition</a>
</div>
</div>
</div>
</div> </div>
</div>
</li>
<li>
<a href="/tea/sports">Sports</a>
<div class="mega-menu">
<div class="row no-gutters">
<div class="col-3">
</div>
<div class="col-8 offset-1">
<h4>Latest Sports</h4>
<div class="row no-gutters">
<div class="col-6">
<div class="story-teaser tiny-teaser">
<a href="/tea/sports/ironman-triathlon-launch-in-rwanda-3688276"><i class="fa fa-caret-right" aria-hidden="true"></i> Ironman 70.3 Triathlon launched in Rwanda as country prepares to host race in Rubavu</a>
</div>
<div class="story-teaser tiny-teaser">
<a href="/tea/sports/aboubakar-scores-cameroon-joined-by-burkina-faso-in-last-16-3685692"><i class="fa fa-caret-right" aria-hidden="true"></i> Aboubakar scores again as Cameroon joined by Burkina Faso in last 16</a>
</div>
</div>
<div class="col-6">
<div class="story-teaser tiny-teaser">
<a href="/tea/sports/cameroon-out-to-keep-unbeaten-record-against-cape-verde-3684760"><i class="fa fa-caret-right" aria-hidden="true"></i> Cameroon out to keep unbeaten record against Cape Verde</a>
</div>
<div class="story-teaser tiny-teaser">
<a href="/tea/sports/egypt-wait-for-salah-lift-off-after-poor-afcon-start-3682254"><i class="fa fa-caret-right" aria-hidden="true"></i> Egypt wait for Salah lift-off after poor start</a>
</div>
</div>
</div>
</div> </div>
</div>
</li>
<li>
<a href="/tea/rest-of-africa">Rest of Africa</a>
<div class="mega-menu">
<div class="row no-gutters">
<div class="col-3">
</div>
<div class="col-8 offset-1">
<h4>Latest Rest of Africa</h4>
<div class="row no-gutters">
<div class="col-6">
<div class="story-teaser tiny-teaser">
<a href="/tea/rest-of-africa/al-shabab-leader-arrested-in-mozambique-3688424"><i class="fa fa-caret-right" aria-hidden="true"></i> Al-Shabaab leader arrested in Mozambique</a>
</div>
<div class="story-teaser tiny-teaser">
<a href="/tea/rest-of-africa/17-killed-59-injured-by-explosion-in-western-ghana-3689210"><i class="fa fa-caret-right" aria-hidden="true"></i> 17 killed, 59 injured by explosion in western Ghana</a>
</div>
</div>
<div class="col-6">
<div class="story-teaser tiny-teaser">
<a href="/tea/rest-of-africa/us-pressure-on-zimbabwe-over-electoral-reforms-3689160"><i class="fa fa-caret-right" aria-hidden="true"></i> US pressures Zimbabwe to implement electoral reforms</a>
</div>
<div class="story-teaser tiny-teaser">
<a href="/tea/rest-of-africa/20-killed-in-stampede-at-religious-gathering-in-liberia-3689118"><i class="fa fa-caret-right" aria-hidden="true"></i> 20 killed in stampede at religious gathering in Liberia</a>
</div>
</div>
</div>
</div> </div>
</div>
</li>
<li>
<a href="/tea/kusi-ideas">KUSI IDEAS</a>
<div class="mega-menu">
<div class="row no-gutters">
<div class="col-3">
</div>
<div class="col-8 offset-1">
<h4>Latest KUSI IDEAS</h4>
<div class="row no-gutters">
<div class="col-6">
<div class="story-teaser tiny-teaser">
<a href="/tea/kusi-ideas/afcfta-on-track-to-lift-100-million-africans-out-of-poverty-3664440"><i class="fa fa-caret-right" aria-hidden="true"></i> AfCFTA on track to lift 100 million Africans out of poverty by 2035</a>
</div>
<div class="story-teaser tiny-teaser">
<a href="/tea/kusi-ideas/youth-and-creative-sector-banking-on-integration-3664378"><i class="fa fa-caret-right" aria-hidden="true"></i> Youth and creative sector banking on integration</a>
</div>
</div>
<div class="col-6">
<div class="story-teaser tiny-teaser">
<a href="/tea/kusi-ideas/targeting-specialist-markets-can-be-big-winner-3664432"><i class="fa fa-caret-right" aria-hidden="true"></i> Targeting specialist markets can be big winner</a>
</div>
<div class="story-teaser tiny-teaser">
<a href="/tea/kusi-ideas/water-management-tech-can-stave-off-effects-of-climate-change-3664418"><i class="fa fa-caret-right" aria-hidden="true"></i> Water management and technology can stave off worst effects of climate change</a>
</div>
</div>
</div>
</div> </div>
</div>
</li>
</ul>
<a class="btn-slide">
<i class="fa fa-bars d-block d-md-none" aria-hidden="true"></i>
</a>
<div class="search-form clearfix">
<form id="searchHeader" name="searchfrm" action="/service/search/tea/1446352" autocomplete="off" role="search">
<input name="query" type="search" placeholder="Search" minlength="3" required>
<input type="submit" name="" value="">
</form>
</div> </div>
</nav>
<div class="breaking-news">
<div class="container">
<div class="breaking-news-container" data-separator="|" data-fragments-link="/ajax/breaking-news/tea">
</div>
</div>
</div>
<article role="main" class="wrapper newsplex-article">
<section role="main" class="main-home artTop ">
<div class="container">
<div class="row">
<article class="main column">
<section class="ad noprint"> <span class="">Advertisement</span> <div class="ad">
<script>
var Url_Seg1=window.location.pathname.split( '/' )[1];
if(Url_Seg1==="sports"){ }else{
googletag.cmd.push(function() {
var leaderBoard = googletag.sizeMapping().
addSize([1024, 0], [728, 90]).
addSize([600, 0], [300, 250]).
addSize([800, 0], [728, 90]).
addSize([0, 0], [[320, 50], [320, 100], [300, 75], [300, 100], [300, 50], [300, 250]]).
build();
window.bk_dfp_integration = window.bk_dfp_integration || {}; window.bk_dfp_integration.functions = window.bk_dfp_integration.functions || {}; if(typeof bk_dfp_integration.functions.sendDfp === "function"){ bk_dfp_integration.functions.sendDfp(); }
googletag.defineSlot('/1010816/Z-DN-728x90-ArticleTop',[[320, 50], [320, 100], [300, 75], [300, 100], [300, 50], [728, 90], [300, 250]], 'div-gpt-ad-1489467324804-0').defineSizeMapping(leaderBoard).addService(googletag.pubads());
googletag.pubads().collapseEmptyDivs();
googletag.pubads().setTargeting('url', window.location.pathname.split( '/' )[1]);
googletag.pubads().setTargeting('url2', window.location.pathname.split( '/' )[2]);
googletag.enableServices();
});
}
</script>

<div id='div-gpt-ad-1489467324804-0' style='margin:0 auto;height:auto'>
<script>
if(Url_Seg1==="sports"){ $(".ad").css("background","white"); }else{
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1489467324804-0'); });
}
</script>
</div>
</div> </section><div class="container mt-4 px-0">
<nav aria-label="breadcrumb">
<ol class="breadcrumb col-12">
<li class="breadcrumb-item "><a href="/tea">The East African</a></li>
<li class="breadcrumb-item active" aria-current=&quot;page&quot;><a href="#">Magazine</a></li>
</ol>
</nav>
<div class="section-home-header clearfix mb-3">
</div>
</div> <header>
<h2>&#39;The Greedy Barbarian&#39; is more Idi Amin than Museveni</h2>
<p class="summary"></p>
<h6>Friday January 21 2022</h6>
<div class="social-networks noprint">
<a href="https://twitter.com/share?text=&#39;The Greedy Barbarian&#39; is more Idi Amin than Museveni&amp;url=https://www.theeastafrican.co.ke/tea/magazine/the-greedy-barbarian-more-idi-amin-than-museveni-3689390&amp;via=The_EastAfrican" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a>
<a href="https://www.facebook.com/sharer.php?u=https://www.theeastafrican.co.ke/tea/magazine/the-greedy-barbarian-more-idi-amin-than-museveni-3689390" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a>
<a href="https://www.linkedin.com/shareArticle?mini=true&amp;url=https://www.theeastafrican.co.ke/tea/magazine/the-greedy-barbarian-more-idi-amin-than-museveni-3689390" target="_blank"><i class="fa fa-linkedin" aria-hidden="true"></i></a>
<div class="mobileShow">
<a href="https://api.whatsapp.com/send?text=https://www.theeastafrican.co.ke/tea/magazine/the-greedy-barbarian-more-idi-amin-than-museveni-3689390" target="_blank"><i class="fa fa-whatsapp" aria-hidden="true"></i></a>
</div>
<a href="javascript:window.print()" target="_blank"><i class="fa fa-print" aria-hidden="true"></i></a>
<a href="/cdn-cgi/l/email-protection#86b9f5f3e4ece3e5f2bba0a5b5bfbdd2eee3a6c1f4e3e3e2ffa6c4e7f4e4e7f4efe7e8a0a5b5bfbda6eff5a6ebe9f4e3a6cfe2efa6c7ebefe8a6f2eee7e8a6cbf3f5e3f0e3e8efa0e7ebf6bde4e9e2ffbba0a5b5bfbdd2eee3a6c1f4e3e3e2ffa6c4e7f4e4e7f4efe7e8a0a5b5bfbda6eff5a6ebe9f4e3a6cfe2efa6c7ebefe8a6f2eee7e8a6cbf3f5e3f0e3e8efabeef2f2f6f5bca9a9f1f1f1a8f2eee3e3e7f5f2e7e0f4efe5e7e8a8e5e9a8ede3a9f2e3e7a9ebe7e1e7fcefe8e3a9f2eee3abe1f4e3e3e2ffabe4e7f4e4e7f4efe7e8abebe9f4e3abefe2efabe7ebefe8abf2eee7e8abebf3f5e3f0e3e8efabb5b0bebfb5bfb6" target="_blank"><i class="fa fa-envelope-o" aria-hidden="true"></i></a>
</div> <div>
<div class="storyTopPic">
<img src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mNkYAAAAAYAAjCB0C8AAAAASUVORK5CYII=" alt="The Greedy Barbarian" class="cm-media cm-media--loading cm-media--responsive cm-media--loading " title="" data-cm-responsive-media="[{&quot;name&quot;:&quot;landscape_ratio16x9&quot;,&quot;ratioWidth&quot;:16,&quot;ratioHeight&quot;:9,&quot;linksForWidth&quot;:{&quot;200&quot;:&quot;/resource/image/3689406/landscape_ratio16x9/200/112/bb0e86d82d0cc2ae4cff4dd227188913/Xz/the-greedy-barbarian.jpg&quot;,&quot;300&quot;:&quot;/resource/image/3689406/landscape_ratio16x9/300/168/bb0e86d82d0cc2ae4cff4dd227188913/Yr/the-greedy-barbarian.jpg&quot;,&quot;400&quot;:&quot;/resource/image/3689406/landscape_ratio16x9/400/225/bb0e86d82d0cc2ae4cff4dd227188913/kG/the-greedy-barbarian.jpg&quot;,&quot;1160&quot;:&quot;/resource/image/3689406/landscape_ratio16x9/1160/652/bb0e86d82d0cc2ae4cff4dd227188913/Nq/the-greedy-barbarian.jpg&quot;}},{&quot;name&quot;:&quot;portrait_ratio2x3&quot;,&quot;ratioWidth&quot;:2,&quot;ratioHeight&quot;:3,&quot;linksForWidth&quot;:{&quot;200&quot;:&quot;/resource/image/3689406/portrait_ratio2x3/200/300/ce06204eb1fe03d20ac3d889e3318dab/zh/the-greedy-barbarian.jpg&quot;,&quot;400&quot;:&quot;/resource/image/3689406/portrait_ratio2x3/400/600/ce06204eb1fe03d20ac3d889e3318dab/Qy/the-greedy-barbarian.jpg&quot;,&quot;768&quot;:&quot;/resource/image/3689406/portrait_ratio2x3/768/1152/ce06204eb1fe03d20ac3d889e3318dab/va/the-greedy-barbarian.jpg&quot;}},{&quot;name&quot;:&quot;landscape_ratio2x1&quot;,&quot;ratioWidth&quot;:2,&quot;ratioHeight&quot;:1,&quot;linksForWidth&quot;:{&quot;200&quot;:&quot;/resource/image/3689406/landscape_ratio2x1/200/100/7702ced201d3e738a9eafae8a339e8fe/CR/the-greedy-barbarian.jpg&quot;}},{&quot;name&quot;:&quot;landscape_ratio3x2&quot;,&quot;ratioWidth&quot;:3,&quot;ratioHeight&quot;:2,&quot;linksForWidth&quot;:{&quot;300&quot;:&quot;/resource/image/3689406/landscape_ratio3x2/300/200/46166720d5a791b94edc20f3112bcd8b/Vo/the-greedy-barbarian.jpg&quot;,&quot;400&quot;:&quot;/resource/image/3689406/landscape_ratio3x2/400/267/46166720d5a791b94edc20f3112bcd8b/xW/the-greedy-barbarian.jpg&quot;,&quot;768&quot;:&quot;/resource/image/3689406/landscape_ratio3x2/768/512/46166720d5a791b94edc20f3112bcd8b/pQ/the-greedy-barbarian.jpg&quot;}},{&quot;name&quot;:&quot;portrait_ratio1x1&quot;,&quot;ratioWidth&quot;:1,&quot;ratioHeight&quot;:1,&quot;linksForWidth&quot;:{&quot;50&quot;:&quot;/resource/image/3689406/portrait_ratio1x1/50/50/afdda00263f6aa7c80f3363ec4f28fea/mR/the-greedy-barbarian.jpg&quot;,&quot;60&quot;:&quot;/resource/image/3689406/portrait_ratio1x1/60/60/afdda00263f6aa7c80f3363ec4f28fea/Wi/the-greedy-barbarian.jpg&quot;,&quot;200&quot;:&quot;/resource/image/3689406/portrait_ratio1x1/200/200/afdda00263f6aa7c80f3363ec4f28fea/Jy/the-greedy-barbarian.jpg&quot;,&quot;400&quot;:&quot;/resource/image/3689406/portrait_ratio1x1/400/400/afdda00263f6aa7c80f3363ec4f28fea/uQ/the-greedy-barbarian.jpg&quot;,&quot;768&quot;:&quot;/resource/image/3689406/portrait_ratio1x1/768/768/afdda00263f6aa7c80f3363ec4f28fea/eR/the-greedy-barbarian.jpg&quot;}},{&quot;name&quot;:&quot;landscape_ratio4x3&quot;,&quot;ratioWidth&quot;:4,&quot;ratioHeight&quot;:3,&quot;linksForWidth&quot;:{&quot;200&quot;:&quot;/resource/image/3689406/landscape_ratio4x3/200/150/99cb1e219e523a72b37a99641516b563/DF/the-greedy-barbarian.jpg&quot;,&quot;400&quot;:&quot;/resource/image/3689406/landscape_ratio4x3/400/300/99cb1e219e523a72b37a99641516b563/Tk/the-greedy-barbarian.jpg&quot;,&quot;768&quot;:&quot;/resource/image/3689406/landscape_ratio4x3/768/576/99cb1e219e523a72b37a99641516b563/QQ/the-greedy-barbarian.jpg&quot;}}]">
</div>
<p id="photo_article_caption">The Greedy Barbarian by Kakwenza Rukirabashaija. Top: The author. PHOTO | COURTESY</p> </div>
</header>
<article class="article">
<section class="article-sidebar">
<section class="summary">
<h4><b>Summary</b></h4>
<div>
<ul class="rte--list"><li>And more so against his son Lt-Gen Muhoozi Kainerubaga, Commander of Uganda’s Land Forces, whom the writer described as “obese and obscene”, and who is seen in some quarters as the Ugandan strongman’s preferred successor.</li><li>The first time Ugandan police arrested Rukirabashaija was in April of 2020, just after Covid-19 had struck Uganda’s shores.</li><li>Sentences like “his cantankerous demeanour, vulgar and harsh, would haunt him all his life” are many and cumbersome, and the reader lumbers through this dense dictionary-word world of bombast throughout the book.</li></ul> </div>
</section>
<section class="ad noprint">
<span class="">Advertisement</span>
<div class="ad">
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script>
window.googletag = window.googletag || {cmd: []};
googletag.cmd.push(function() {
googletag.defineSlot('/1010816/EA-300X250-Article-3', [300, 250], 'div-gpt-ad-1594211656305-0').addService(googletag.pubads());
googletag.pubads().enableSingleRequest();
googletag.enableServices();
});
</script>

<div id='div-gpt-ad-1594211656305-0' style='width: 300px; height: 250px;'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1594211656305-0'); });
</script>
</div> </div>
</section>
</section>
<section class="body-copy">
<section class="author noprint">
<figure class="left">
</figure>
<strong>By TONY MOCHAMA</strong>
<div><a href="/tea/author-profiles/tony-mochama-3689394"><span class="author-profile">More by this Author</span></a></div>
</section>
<br />
<p>Ugandan writer Kakwenza Rukirabashaija was definitely not in the 2021 Christmas season spirit when he expressed his freedom of expression by going on a three-day Twitter tirade against long-serving (some may say self-serving) Ugandan President Yoweri Museveni.</p><p>And more so against his son Lt-Gen Muhoozi Kainerubaga, Commander of Uganda’s Land Forces, whom the writer described as “obese and obscene”, and who is seen in some quarters as the Ugandan strongman’s preferred successor.</p><p>Eventually the police, who have twice before arrested writer Rukirabashaija, took him just after Boxing Day, and — in direct violation of his Constitutional rights — kept him detained for a week, which Ugandan CID police spokesman Charlie Twiine blamed on the “festive season with [CID] workers away, and courts closed, leading to delay in processing him”.</p><p>The first time Ugandan police arrested Rukirabashajia was in April of 2020, just after Covid-19 had struck Uganda’s shores. At the time, the author claimed it was over his self-published book <em>The Greedy Barbarian</em>.</p><p>This book reviewer was eager to read the current Ugandan best-seller.</p><p>Unfortunately, for the professional book critic, <em>The Greedy Barbarian,</em> satirical though it is, has too much “tell and not show”, where the protagonist is explained in word instead of demonstrated in art.</p> <div id="relatedCoverage" class="article-related-coverage">
<div class="related-coverage-header"><h3>Related</h3></div>
<div class="related-coverage-body">
<ul>
<li><a href="/tea/news/east-africa/eu-mounts-pressure-on-uganda-government-release-kakwenza-3673754">
<span class="relImage">
<figure>
<div class="relatedTeaser">
<img src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mNkYAAAAAYAAjCB0C8AAAAASUVORK5CYII=" alt="Kakwenza Rukirabashaija" class="cm-media cm-media--loading cm-media--responsive cm-media--loading " title="" data-cm-responsive-media="[{&quot;name&quot;:&quot;landscape_ratio16x9&quot;,&quot;ratioWidth&quot;:16,&quot;ratioHeight&quot;:9,&quot;linksForWidth&quot;:{&quot;200&quot;:&quot;/resource/image/3673776/landscape_ratio16x9/200/112/a1fa645076332b44c81ae4ad403f7032/GK/kakwenza-rukirabashaija-eu.jpg&quot;,&quot;300&quot;:&quot;/resource/image/3673776/landscape_ratio16x9/300/168/a1fa645076332b44c81ae4ad403f7032/JK/kakwenza-rukirabashaija-eu.jpg&quot;,&quot;400&quot;:&quot;/resource/image/3673776/landscape_ratio16x9/400/225/a1fa645076332b44c81ae4ad403f7032/Gx/kakwenza-rukirabashaija-eu.jpg&quot;,&quot;1160&quot;:&quot;/resource/image/3673776/landscape_ratio16x9/1160/652/a1fa645076332b44c81ae4ad403f7032/IR/kakwenza-rukirabashaija-eu.jpg&quot;}},{&quot;name&quot;:&quot;portrait_ratio2x3&quot;,&quot;ratioWidth&quot;:2,&quot;ratioHeight&quot;:3,&quot;linksForWidth&quot;:{&quot;200&quot;:&quot;/resource/image/3673776/portrait_ratio2x3/200/300/e45a4706d2b4ec29e8a01b044c8f1ee7/kQ/kakwenza-rukirabashaija-eu.jpg&quot;,&quot;400&quot;:&quot;/resource/image/3673776/portrait_ratio2x3/400/600/e45a4706d2b4ec29e8a01b044c8f1ee7/qN/kakwenza-rukirabashaija-eu.jpg&quot;,&quot;768&quot;:&quot;/resource/image/3673776/portrait_ratio2x3/768/1152/e45a4706d2b4ec29e8a01b044c8f1ee7/Gh/kakwenza-rukirabashaija-eu.jpg&quot;}},{&quot;name&quot;:&quot;landscape_ratio2x1&quot;,&quot;ratioWidth&quot;:2,&quot;ratioHeight&quot;:1,&quot;linksForWidth&quot;:{&quot;200&quot;:&quot;/resource/image/3673776/landscape_ratio2x1/200/100/5b733ec9741177bc1e9a11b16930f41b/uY/kakwenza-rukirabashaija-eu.jpg&quot;}},{&quot;name&quot;:&quot;landscape_ratio3x2&quot;,&quot;ratioWidth&quot;:3,&quot;ratioHeight&quot;:2,&quot;linksForWidth&quot;:{&quot;300&quot;:&quot;/resource/image/3673776/landscape_ratio3x2/300/200/c6ff19d88a34be7d15663ca6301df989/GX/kakwenza-rukirabashaija-eu.jpg&quot;,&quot;400&quot;:&quot;/resource/image/3673776/landscape_ratio3x2/400/267/c6ff19d88a34be7d15663ca6301df989/Th/kakwenza-rukirabashaija-eu.jpg&quot;,&quot;768&quot;:&quot;/resource/image/3673776/landscape_ratio3x2/768/512/c6ff19d88a34be7d15663ca6301df989/Db/kakwenza-rukirabashaija-eu.jpg&quot;}},{&quot;name&quot;:&quot;portrait_ratio1x1&quot;,&quot;ratioWidth&quot;:1,&quot;ratioHeight&quot;:1,&quot;linksForWidth&quot;:{&quot;50&quot;:&quot;/resource/image/3673776/portrait_ratio1x1/50/50/3ce6ac5de5485ca49e517ffea8d5b3a4/WZ/kakwenza-rukirabashaija-eu.jpg&quot;,&quot;60&quot;:&quot;/resource/image/3673776/portrait_ratio1x1/60/60/3ce6ac5de5485ca49e517ffea8d5b3a4/ma/kakwenza-rukirabashaija-eu.jpg&quot;,&quot;200&quot;:&quot;/resource/image/3673776/portrait_ratio1x1/200/200/3ce6ac5de5485ca49e517ffea8d5b3a4/GG/kakwenza-rukirabashaija-eu.jpg&quot;,&quot;400&quot;:&quot;/resource/image/3673776/portrait_ratio1x1/400/400/3ce6ac5de5485ca49e517ffea8d5b3a4/Vs/kakwenza-rukirabashaija-eu.jpg&quot;,&quot;768&quot;:&quot;/resource/image/3673776/portrait_ratio1x1/768/768/3ce6ac5de5485ca49e517ffea8d5b3a4/Yh/kakwenza-rukirabashaija-eu.jpg&quot;}},{&quot;name&quot;:&quot;landscape_ratio4x3&quot;,&quot;ratioWidth&quot;:4,&quot;ratioHeight&quot;:3,&quot;linksForWidth&quot;:{&quot;200&quot;:&quot;/resource/image/3673776/landscape_ratio4x3/200/150/3a8b14d50ec0125c3bdc19bb98bf4287/mv/kakwenza-rukirabashaija-eu.jpg&quot;,&quot;400&quot;:&quot;/resource/image/3673776/landscape_ratio4x3/400/300/3a8b14d50ec0125c3bdc19bb98bf4287/By/kakwenza-rukirabashaija-eu.jpg&quot;,&quot;768&quot;:&quot;/resource/image/3673776/landscape_ratio4x3/768/576/3a8b14d50ec0125c3bdc19bb98bf4287/jK/kakwenza-rukirabashaija-eu.jpg&quot;}}]">
</div> </figure>
</span>
<span class="relText">
EU urges Uganda to release activist Kakwenza
</span>
</a></li>
<li><a href="/tea/news/east-africa/ugandan-novelist-kakwenza-badly-tortured-lawyer-3671620">
<span class="relImage">
<figure>
<div class="relatedTeaser">
<img src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mNkYAAAAAYAAjCB0C8AAAAASUVORK5CYII=" alt="Kakwenza Rukirabashaija" class="cm-media cm-media--loading cm-media--responsive cm-media--loading " title="" data-cm-responsive-media="[{&quot;name&quot;:&quot;landscape_ratio16x9&quot;,&quot;ratioWidth&quot;:16,&quot;ratioHeight&quot;:9,&quot;linksForWidth&quot;:{&quot;200&quot;:&quot;/resource/image/3671632/landscape_ratio16x9/200/112/a1fa645076332b44c81ae4ad403f7032/sA/kakwenza-rukirabashaija.jpg&quot;,&quot;300&quot;:&quot;/resource/image/3671632/landscape_ratio16x9/300/168/a1fa645076332b44c81ae4ad403f7032/Tw/kakwenza-rukirabashaija.jpg&quot;,&quot;400&quot;:&quot;/resource/image/3671632/landscape_ratio16x9/400/225/a1fa645076332b44c81ae4ad403f7032/Yn/kakwenza-rukirabashaija.jpg&quot;,&quot;1160&quot;:&quot;/resource/image/3671632/landscape_ratio16x9/1160/652/a1fa645076332b44c81ae4ad403f7032/mX/kakwenza-rukirabashaija.jpg&quot;}},{&quot;name&quot;:&quot;portrait_ratio2x3&quot;,&quot;ratioWidth&quot;:2,&quot;ratioHeight&quot;:3,&quot;linksForWidth&quot;:{&quot;200&quot;:&quot;/resource/image/3671632/portrait_ratio2x3/200/300/a888a439b6b09dbebcf4723bdfca569e/fD/kakwenza-rukirabashaija.jpg&quot;,&quot;400&quot;:&quot;/resource/image/3671632/portrait_ratio2x3/400/600/a888a439b6b09dbebcf4723bdfca569e/RQ/kakwenza-rukirabashaija.jpg&quot;,&quot;768&quot;:&quot;/resource/image/3671632/portrait_ratio2x3/768/1152/a888a439b6b09dbebcf4723bdfca569e/oY/kakwenza-rukirabashaija.jpg&quot;}},{&quot;name&quot;:&quot;landscape_ratio2x1&quot;,&quot;ratioWidth&quot;:2,&quot;ratioHeight&quot;:1,&quot;linksForWidth&quot;:{&quot;200&quot;:&quot;/resource/image/3671632/landscape_ratio2x1/200/100/5b733ec9741177bc1e9a11b16930f41b/iW/kakwenza-rukirabashaija.jpg&quot;}},{&quot;name&quot;:&quot;landscape_ratio3x2&quot;,&quot;ratioWidth&quot;:3,&quot;ratioHeight&quot;:2,&quot;linksForWidth&quot;:{&quot;300&quot;:&quot;/resource/image/3671632/landscape_ratio3x2/300/200/c6ff19d88a34be7d15663ca6301df989/HB/kakwenza-rukirabashaija.jpg&quot;,&quot;400&quot;:&quot;/resource/image/3671632/landscape_ratio3x2/400/267/c6ff19d88a34be7d15663ca6301df989/Bn/kakwenza-rukirabashaija.jpg&quot;,&quot;768&quot;:&quot;/resource/image/3671632/landscape_ratio3x2/768/512/c6ff19d88a34be7d15663ca6301df989/Kt/kakwenza-rukirabashaija.jpg&quot;}},{&quot;name&quot;:&quot;portrait_ratio1x1&quot;,&quot;ratioWidth&quot;:1,&quot;ratioHeight&quot;:1,&quot;linksForWidth&quot;:{&quot;50&quot;:&quot;/resource/image/3671632/portrait_ratio1x1/50/50/3ce6ac5de5485ca49e517ffea8d5b3a4/VL/kakwenza-rukirabashaija.jpg&quot;,&quot;60&quot;:&quot;/resource/image/3671632/portrait_ratio1x1/60/60/3ce6ac5de5485ca49e517ffea8d5b3a4/AQ/kakwenza-rukirabashaija.jpg&quot;,&quot;200&quot;:&quot;/resource/image/3671632/portrait_ratio1x1/200/200/3ce6ac5de5485ca49e517ffea8d5b3a4/xY/kakwenza-rukirabashaija.jpg&quot;,&quot;400&quot;:&quot;/resource/image/3671632/portrait_ratio1x1/400/400/3ce6ac5de5485ca49e517ffea8d5b3a4/Vq/kakwenza-rukirabashaija.jpg&quot;,&quot;768&quot;:&quot;/resource/image/3671632/portrait_ratio1x1/768/768/3ce6ac5de5485ca49e517ffea8d5b3a4/Uv/kakwenza-rukirabashaija.jpg&quot;}},{&quot;name&quot;:&quot;landscape_ratio4x3&quot;,&quot;ratioWidth&quot;:4,&quot;ratioHeight&quot;:3,&quot;linksForWidth&quot;:{&quot;200&quot;:&quot;/resource/image/3671632/landscape_ratio4x3/200/150/3a8b14d50ec0125c3bdc19bb98bf4287/HJ/kakwenza-rukirabashaija.jpg&quot;,&quot;400&quot;:&quot;/resource/image/3671632/landscape_ratio4x3/400/300/3a8b14d50ec0125c3bdc19bb98bf4287/lg/kakwenza-rukirabashaija.jpg&quot;,&quot;768&quot;:&quot;/resource/image/3671632/landscape_ratio4x3/768/576/3a8b14d50ec0125c3bdc19bb98bf4287/Lo/kakwenza-rukirabashaija.jpg&quot;}}]">
</div> </figure>
</span>
<span class="relText">
Ugandan novelist Kakwenza badly tortured: lawyer
</span>
</a></li>
</ul>
</div>
</div>
<section class="ad noprint">
<span class="">Advertisement</span>
<div class="ad">
<script>
window.googletag = window.googletag || {cmd: []};
googletag.cmd.push(function() {
var leaderBoard = googletag.sizeMapping().
addSize([1024, 0], [728, 90]).
addSize([600, 0], [300, 250]).
addSize([800, 0], [728, 90]).
addSize([0, 0], [[320, 50], [300, 75], [300, 100], [300, 50], [300, 250]]).
build();
googletag.defineSlot('/1010816/Z-DN-728x90-inArticleRelated', [[300, 50], [320, 480], [300, 100], [320, 50], [300, 250], [300, 75], [728, 90]], 'div-gpt-ad-1592285737951-0').defineSizeMapping(leaderBoard).addService(googletag.pubads());
googletag.pubads().enableSingleRequest();
googletag.pubads().collapseEmptyDivs();
googletag.enableServices();
});
</script>

<div id='div-gpt-ad-1592285737951-0'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1592285737951-0'); });
</script>
</div> </div>
</section>
<p>Sentences like “his cantankerous demeanour, vulgar and harsh, would haunt him all his life” are many and cumbersome, and the reader lumbers through this dense dictionary-word world of bombast throughout the book.</p><p>The line between the artful writer and the Twitter activist are blurred, at least in terms of literary style.</p><h3>Verbal artillery</h3><p>“Muhoozi bum-lickers! Dare attempt to bully me again and I show you fire,” Rukirabashaija tweeted just before his arrest. “I have more verbal artillery in my toolkit to bludgeon your empty heads and dirty mouths that spews hocus-pocus and balderdash!”</p><p>Unfortunately, if writing is a craft and a book the work of that craftsmanship, Rukirabashaija may have way too much verbal artillery in his writer’s toolkit, that then tends to bludgeon the reader (empty-headed or not) with big words. The Greedy Barbarian may equally be described as a hocus-pocus of a book in plot, whose writer has made a dash for the bold, but ended up in a world of Ballads of the Bad that end up in ribald.</p><p>The protagonist of the book, Kayibanda, born in fictional Muhemba (Rwanda) where his mother is a night harlot, is not even an anti-hero, but the outright antagonist of the novel.</p><p>Crossing over the border at six years of age on the back of his machete-maimed mother Bekunda, to Kalenga (Uganda), one can see how this could have started as a deeper story about the 1994 Rwanda Genocide against the Tutsi; but Rukirabashaija is not interested in any deeper historical analogies in his novel.</p><p>Kayibanda is truly a bad seed (from a rapist father) and the author has no interest in his character development in the book. Kayibanda’s is a linear trajectory of unadulterated evil that can come off as laughable to the seasoned reader.</p><p>He is that bad boy in school that goes from stealing pencils to straight heists in violent bank robberies.</p><p>In Kayibanda’s case, he goes from stealing chicken in his childhood to killing his son’s “baby mama” in college in a foreign country (a fictional Kenya), just to accommodate his new lover Miss Kembaga.</p><p>Never mind that he is on an Economics’ scholarship — for which the author says he has “no head”— but had been expelled from high school after getting caught cavorting in the school library with his schoolmate, Kamagoba, the baby mama whom he will murder later in the story.</p><p>In the interlude between the two incidents, he gets to work as a vigilante in the village, and spares neither his guardian Bamwine nor his adopted father in his vigilantism. Never mind that “Dad” is a wizard who can turn into a snake, or stone, very Aaron biblically speaking, at the drop of a rod.</p><h3>Uninhibited imagination</h3><p>Rukirabashaija’s imagination steams forward, uninhibited and loosely structured, making reading this book similar to trying to drive a car with an over-heated engine. His imagination is fevered, and the book is a frenzy of unmitigated violence and covetousness.</p><p>“Kayibanda becomes the political hitman of a military dictator!”</p><p>Again, we might have seen parallels to President Museveni’s "Operation Wembley" in 2002, where young Ugandan assassins were recruited and trained to take out organised crime figures in Kampala in extra-judicial killings of other young criminals; violent crime dropped by half when "Wembley" was done.</p><p>Instead we are rushed to the scene where Kayibanda wrests state control from the strongman, and with the reins of power in his hands, he can now grab, loot and kill at will, to sate his barbarous greed — as Rukirabashaija gives full and unbridled rein to his rather undisciplined authorial imagination.</p><p>With leaders like Milton Obote having been overthrown by henchmen like Idi Amin, complete with occult practices, who most closely comes to resembling Kayibanda rather than the Museveni most folks assume this book is about, one feels frustration that, again, no parallels are drawn.</p><p>In the end, devoid of any research and little in the way of craft, The Greedy Barbarian, with its gore, can still be a luridly entertaining read — if one was a subscriber to tabloids like the Red Pepper of yore.</p><p>In August of 2020, Rukirabashaija was arrested for what he claimed was his book Banana Republic (where writing is treasonous). This may be true, but it is hard to imagine that the Ugandan state earlier that April arrested him for The Greedy Barbarian.</p><p>It is more likely that the barbarians came to his gate for his Twitter tirades against Lt General Muhoozi.</p><p>Regardless, Rukirabashaija was named the PEN International Writer of Courage in 2021 by the Zimbabwean activist and writer, Tsitsi Dangaremba.</p><p>Dangaremba won the 2021 PEN Pinter Prize for work that "defines the real truth of lives in our societies" — and who Zimbabwean President Emmerson Mnagwaga’s regime has tried to gag on previous occasions.</p><p><em><strong>Tony Mochama is PEN International secretary-general, Kenya Chapter</strong></em></p> </section>
</article>
<script type="text/javascript" src="https://theconversation.com/javascripts/lib/content_tracker_hook.js" id="theconversation_tracker_hook" data-counter="https://counter.theconversation.com/content/UNDEFINED/count?distributor=republish-lightbox-advanced" async="async"></script> <section class="ad noprint">
<span class="">Advertisement</span>
<div class="ad">
<script>
window.googletag = window.googletag || {cmd: []};
googletag.cmd.push(function() {
var mobileResize = googletag.sizeMapping().
addSize([1024, 0], [728, 90]).
addSize([600, 0], [300, 250]).
addSize([800, 0], [728, 90]).
addSize([0, 0], [300, 250]).
build();
googletag.defineSlot('/1010816/Z-DN-728x90-lifestyleArticleEnd', [[728, 90], [300, 250]], 'div-gpt-ad-1591700752620-0').defineSizeMapping(mobileResize).addService(googletag.pubads());
googletag.pubads().enableSingleRequest();
googletag.pubads().collapseEmptyDivs();
googletag.enableServices();
});
</script>

<div id='div-gpt-ad-1591700752620-0'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1591700752620-0'); });
</script>
</div> </div>
</section>
<section class="print-section big-blog noprint" id="headlines">
<header class="clearfix">
<div class="blog-header clearfix">
<h3>In the headlines</h3>
</div>
</header>
<article>
<div class="row">
<div class="five-eight column">
<div class="story-teaser medium-teaser">
<h3> <a href="/tea/news/east-africa/police-to-ease-traffic-along-the-webuye-malaba-highway-3689644">Police to ease traffic along Webuye-Malaba Highway</a></h3>
<div class="">
<figure class="">
<a href="/tea/news/east-africa/police-to-ease-traffic-along-the-webuye-malaba-highway-3689644">
<div class="mediumTeaserImage">
<img src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mNkYAAAAAYAAjCB0C8AAAAASUVORK5CYII=" alt="Trucks" class="cm-media cm-media--loading cm-media--responsive cm-media--loading " title="" data-cm-responsive-media="[{&quot;name&quot;:&quot;landscape_ratio16x9&quot;,&quot;ratioWidth&quot;:16,&quot;ratioHeight&quot;:9,&quot;linksForWidth&quot;:{&quot;200&quot;:&quot;/resource/image/3689648/landscape_ratio16x9/200/112/7ae96ec762a41715a8e4562d9644f3a5/Ku/trucks.jpg&quot;,&quot;300&quot;:&quot;/resource/image/3689648/landscape_ratio16x9/300/168/7ae96ec762a41715a8e4562d9644f3a5/YC/trucks.jpg&quot;,&quot;400&quot;:&quot;/resource/image/3689648/landscape_ratio16x9/400/225/7ae96ec762a41715a8e4562d9644f3a5/ql/trucks.jpg&quot;,&quot;1160&quot;:&quot;/resource/image/3689648/landscape_ratio16x9/1160/652/7ae96ec762a41715a8e4562d9644f3a5/nZ/trucks.jpg&quot;}},{&quot;name&quot;:&quot;portrait_ratio2x3&quot;,&quot;ratioWidth&quot;:2,&quot;ratioHeight&quot;:3,&quot;linksForWidth&quot;:{&quot;200&quot;:&quot;/resource/image/3689648/portrait_ratio2x3/200/300/ebdd2cf019f3bd56984b1238bbbdccae/ri/trucks.jpg&quot;,&quot;400&quot;:&quot;/resource/image/3689648/portrait_ratio2x3/400/600/ebdd2cf019f3bd56984b1238bbbdccae/nH/trucks.jpg&quot;,&quot;768&quot;:&quot;/resource/image/3689648/portrait_ratio2x3/768/1152/ebdd2cf019f3bd56984b1238bbbdccae/Wv/trucks.jpg&quot;}},{&quot;name&quot;:&quot;landscape_ratio2x1&quot;,&quot;ratioWidth&quot;:2,&quot;ratioHeight&quot;:1,&quot;linksForWidth&quot;:{&quot;200&quot;:&quot;/resource/image/3689648/landscape_ratio2x1/200/100/56ef2b76b83394e7f9170a0e18b85ce3/Tb/trucks.jpg&quot;}},{&quot;name&quot;:&quot;landscape_ratio3x2&quot;,&quot;ratioWidth&quot;:3,&quot;ratioHeight&quot;:2,&quot;linksForWidth&quot;:{&quot;300&quot;:&quot;/resource/image/3689648/landscape_ratio3x2/300/200/30e00ea4932c29bdcf14cdd5cc0193ec/Uo/trucks.jpg&quot;,&quot;400&quot;:&quot;/resource/image/3689648/landscape_ratio3x2/400/267/30e00ea4932c29bdcf14cdd5cc0193ec/EW/trucks.jpg&quot;,&quot;768&quot;:&quot;/resource/image/3689648/landscape_ratio3x2/768/512/30e00ea4932c29bdcf14cdd5cc0193ec/GI/trucks.jpg&quot;}},{&quot;name&quot;:&quot;portrait_ratio1x1&quot;,&quot;ratioWidth&quot;:1,&quot;ratioHeight&quot;:1,&quot;linksForWidth&quot;:{&quot;50&quot;:&quot;/resource/image/3689648/portrait_ratio1x1/50/50/2ed56d429ea581e54cda14644a772994/AF/trucks.jpg&quot;,&quot;60&quot;:&quot;/resource/image/3689648/portrait_ratio1x1/60/60/2ed56d429ea581e54cda14644a772994/dy/trucks.jpg&quot;,&quot;200&quot;:&quot;/resource/image/3689648/portrait_ratio1x1/200/200/2ed56d429ea581e54cda14644a772994/oS/trucks.jpg&quot;,&quot;400&quot;:&quot;/resource/image/3689648/portrait_ratio1x1/400/400/2ed56d429ea581e54cda14644a772994/cE/trucks.jpg&quot;,&quot;768&quot;:&quot;/resource/image/3689648/portrait_ratio1x1/768/768/2ed56d429ea581e54cda14644a772994/GN/trucks.jpg&quot;}},{&quot;name&quot;:&quot;landscape_ratio4x3&quot;,&quot;ratioWidth&quot;:4,&quot;ratioHeight&quot;:3,&quot;linksForWidth&quot;:{&quot;200&quot;:&quot;/resource/image/3689648/landscape_ratio4x3/200/150/687fab2745ef575013a4d96cab472baf/no/trucks.jpg&quot;,&quot;400&quot;:&quot;/resource/image/3689648/landscape_ratio4x3/400/300/687fab2745ef575013a4d96cab472baf/yb/trucks.jpg&quot;,&quot;768&quot;:&quot;/resource/image/3689648/landscape_ratio4x3/768/576/687fab2745ef575013a4d96cab472baf/bH/trucks.jpg&quot;}}]">
</div> </a>
</figure>
<p>
The protests resulted in traffic snarl-up that stretched about 120 kilometers and is yet to clear even after the fee was removed. </p>
</div>
</div><div class="story-teaser medium-teaser">
<h3> <a href="/tea/news/east-africa/armed-conflict-climate-change-fan-africa-refugee-crisis-3689500">Armed conflict, climate change fan Africa’s refugee crisis</a></h3>
<div class="">
<figure class="">
<a href="/tea/news/east-africa/armed-conflict-climate-change-fan-africa-refugee-crisis-3689500">
<div class="mediumTeaserImage">
<img src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mNkYAAAAAYAAjCB0C8AAAAASUVORK5CYII=" alt="Refugees." class="cm-media cm-media--loading cm-media--responsive cm-media--loading " title="" data-cm-responsive-media="[{&quot;name&quot;:&quot;landscape_ratio16x9&quot;,&quot;ratioWidth&quot;:16,&quot;ratioHeight&quot;:9,&quot;linksForWidth&quot;:{&quot;200&quot;:&quot;/resource/image/3689502/landscape_ratio16x9/200/112/a30294df43d2c62222e86d320bfcd875/YB/refugees1.jpg&quot;,&quot;300&quot;:&quot;/resource/image/3689502/landscape_ratio16x9/300/168/a30294df43d2c62222e86d320bfcd875/MN/refugees1.jpg&quot;,&quot;400&quot;:&quot;/resource/image/3689502/landscape_ratio16x9/400/225/a30294df43d2c62222e86d320bfcd875/go/refugees1.jpg&quot;,&quot;1160&quot;:&quot;/resource/image/3689502/landscape_ratio16x9/1160/652/a30294df43d2c62222e86d320bfcd875/RM/refugees1.jpg&quot;}},{&quot;name&quot;:&quot;portrait_ratio2x3&quot;,&quot;ratioWidth&quot;:2,&quot;ratioHeight&quot;:3,&quot;linksForWidth&quot;:{&quot;200&quot;:&quot;/resource/image/3689502/portrait_ratio2x3/200/300/b5234887edd4a2cc48a47d9df42aad7a/KB/refugees1.jpg&quot;,&quot;400&quot;:&quot;/resource/image/3689502/portrait_ratio2x3/400/600/b5234887edd4a2cc48a47d9df42aad7a/rC/refugees1.jpg&quot;,&quot;768&quot;:&quot;/resource/image/3689502/portrait_ratio2x3/768/1152/b5234887edd4a2cc48a47d9df42aad7a/LG/refugees1.jpg&quot;}},{&quot;name&quot;:&quot;landscape_ratio2x1&quot;,&quot;ratioWidth&quot;:2,&quot;ratioHeight&quot;:1,&quot;linksForWidth&quot;:{&quot;200&quot;:&quot;/resource/image/3689502/landscape_ratio2x1/200/100/265bd354b0ac6bf410b45586d8759eff/sf/refugees1.jpg&quot;}},{&quot;name&quot;:&quot;landscape_ratio3x2&quot;,&quot;ratioWidth&quot;:3,&quot;ratioHeight&quot;:2,&quot;linksForWidth&quot;:{&quot;300&quot;:&quot;/resource/image/3689502/landscape_ratio3x2/300/200/8a3aba4202acf6450e7d3000feb832e6/jI/refugees1.jpg&quot;,&quot;400&quot;:&quot;/resource/image/3689502/landscape_ratio3x2/400/267/8a3aba4202acf6450e7d3000feb832e6/vm/refugees1.jpg&quot;,&quot;768&quot;:&quot;/resource/image/3689502/landscape_ratio3x2/768/512/8a3aba4202acf6450e7d3000feb832e6/jw/refugees1.jpg&quot;}},{&quot;name&quot;:&quot;portrait_ratio1x1&quot;,&quot;ratioWidth&quot;:1,&quot;ratioHeight&quot;:1,&quot;linksForWidth&quot;:{&quot;50&quot;:&quot;/resource/image/3689502/portrait_ratio1x1/50/50/145f3e7a792c5ce2c7bdb332454c6880/SE/refugees1.jpg&quot;,&quot;60&quot;:&quot;/resource/image/3689502/portrait_ratio1x1/60/60/145f3e7a792c5ce2c7bdb332454c6880/gt/refugees1.jpg&quot;,&quot;200&quot;:&quot;/resource/image/3689502/portrait_ratio1x1/200/200/145f3e7a792c5ce2c7bdb332454c6880/op/refugees1.jpg&quot;,&quot;400&quot;:&quot;/resource/image/3689502/portrait_ratio1x1/400/400/145f3e7a792c5ce2c7bdb332454c6880/qT/refugees1.jpg&quot;,&quot;768&quot;:&quot;/resource/image/3689502/portrait_ratio1x1/768/768/145f3e7a792c5ce2c7bdb332454c6880/YM/refugees1.jpg&quot;}},{&quot;name&quot;:&quot;landscape_ratio4x3&quot;,&quot;ratioWidth&quot;:4,&quot;ratioHeight&quot;:3,&quot;linksForWidth&quot;:{&quot;200&quot;:&quot;/resource/image/3689502/landscape_ratio4x3/200/150/7baf72d87d4cf932ad8d6a2b27eea992/bT/refugees1.jpg&quot;,&quot;400&quot;:&quot;/resource/image/3689502/landscape_ratio4x3/400/300/7baf72d87d4cf932ad8d6a2b27eea992/fi/refugees1.jpg&quot;,&quot;768&quot;:&quot;/resource/image/3689502/landscape_ratio4x3/768/576/7baf72d87d4cf932ad8d6a2b27eea992/UO/refugees1.jpg&quot;}}]">
</div> </a>
</figure>
<p>
Five million people were displaced in eastern Africa in 2020 as Covid-19 worsened the plight of migrants and asylum seekers.</p>
</div>
</div> </div>
<div class="three-eight column">
<div class="small-story-list">
<h5 class="small-story-list"><a href="/tea/news/east-africa/museveni-it-obvious-africa-deserves-permanent-seat-at-un-3689108">Museveni: Africa deserves UN permanent seat</a></h5><h5 class="small-story-list"><a href="/tea/news/east-africa/somalia-resumes-parliamentary-elections-following-deal-3689252">Somalia resumes parliamentary elections following deal</a></h5><h5 class="small-story-list"><a href="/tea/rest-of-africa/us-pressure-on-zimbabwe-over-electoral-reforms-3689160">US pressures Zimbabwe over electoral reforms</a></h5><h5 class="small-story-list"><a href="/tea/news/east-africa/ccm-nominates-deputy-speaker-tulia-ackson-to-replace-ndugai-3688488">CCM nominates Tulia Ackson for Speaker</a></h5><h5 class="small-story-list"><a href="/tea/news/east-africa/kenya-to-start-registration-of-diaspora-voters-3688138">Kenya to start registration of diaspora voters</a></h5> </div>
</div>
</div>
</article>
</section>
</article>
<aside class="aside column noprint">
<div class="row">
<div class="sidebar-item">
<script>
window.googletag = window.googletag || {cmd: []};
googletag.cmd.push(function() {
googletag.defineSlot('/1010816/EA-300X250-Article0-1', [300, 250], 'div-gpt-ad-1594211421577-0').addService(googletag.pubads());
googletag.pubads().enableSingleRequest();
googletag.enableServices();
});
</script>

<div id='div-gpt-ad-1594211421577-0' class='ad'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1594211421577-0'); });
</script>
</div> </div>
<div class="sidebar-item">
<div class="tab-header">
<div class="tab">
<span class="icon most-read-icon"></span>Latest</div>
</div>
<div class="tab-body">
<li class="most-popular-item">
<a href="/tea/science-health/elephant-spawns-twins-in-rarely-observed-event-3689132">
<span class="most-number">1</span>
<span class="most-headline"><span>Science &amp; Health</span> Elephant spawns twins in rarely observed event</span>
</a>
</li>
<li class="most-popular-item">
<a href="/tea/news/east-africa/police-to-ease-traffic-along-the-webuye-malaba-highway-3689644">
<span class="most-number">2</span>
<span class="most-headline"><span>East Africa</span> Police to ease traffic along Webuye-Malaba Highway</span>
</a>
</li>
<li class="most-popular-item">
<a href="/tea/science-health/team-to-study-ea-rift-system-slow-break-up-3688084">
<span class="most-number">3</span>
<span class="most-headline"><span>Science &amp; Health</span> Team to study EA Rift System&#39;s slow break-up</span>
</a>
</li>
<li class="most-popular-item">
<a href="/tea/magazine/fort-ternan-a-tunnel-to-kenya-s-mixed-colonial-past-3689516">
<span class="most-number">4</span>
<span class="most-headline"><span>Magazine</span> Fort Ternan: A tunnel to Kenya&#39;s mixed colonial past</span>
</a>
</li>
<li class="most-popular-item">
<a href="/tea/rest-of-africa/al-shabab-leader-arrested-in-mozambique-3688424">
<span class="most-number">5</span>
<span class="most-headline"><span>Rest of Africa</span> Al-Shabaab leader arrested in Mozambique</span>
</a>
</li>
<li class="most-popular-item">
<a href="/tea/news/east-africa/armed-conflict-climate-change-fan-africa-refugee-crisis-3689500">
<span class="most-number">6</span>
<span class="most-headline"><span>East Africa</span> Armed conflict, climate change fan Africa’s refugee crisis</span>
</a>
</li>
<li class="most-popular-item">
<a href="/tea/news/east-africa/female-migrants-struggle-to-integrate-back-home-3689496">
<span class="most-number">7</span>
<span class="most-headline"><span>East Africa</span> Female migrants struggle to integrate back home</span>
</a>
</li>
<li class="most-popular-item">
<a href="/tea/oped/comment/why-firms-must-evolve-along-with-customer-demand-3689482">
<span class="most-number">8</span>
<span class="most-headline"><span>Comment</span> AKINYEMI: Why firms must evolve along with customer demand for instant fixes</span>
</a>
</li>
<li class="most-popular-item">
<a href="/tea/oped/comment/our-social-media-is-a-melee-it-lacks-politeness-and-carefulness-3689478">
<span class="most-number">9</span>
<span class="most-headline"><span>Comment</span> EYAKUZE: Our social media is a melee as it lacks politeness and carefulness</span>
</a>
</li>
</div> </div>
<div class="sidebar-item">
<script>
window.googletag = window.googletag || {cmd: []};
googletag.cmd.push(function() {
googletag.defineSlot('/1010816/EA-300X250-Article-2', [300, 250], 'div-gpt-ad-1594211537827-0').addService(googletag.pubads());
googletag.pubads().enableSingleRequest();
googletag.enableServices();
});
</script>

<div id='div-gpt-ad-1594211537827-0' class='ad'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1594211537827-0'); });
</script>
</div> </div>
<div class="sidebar-item">
<section class="ad noprint">
<span class="">Advertisement</span>
<div class="ad">
<ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-0846142691248784" data-ad-slot="7537505707"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script> </div> </section> </div>
</div>
</aside>
</div>
</div>
<script type="text/javascript">
/* CONFIGURATION START */
var _ain = {
id: "1910",
postid: "new-3689390",
maincontent: "h2, #photo_article_caption, section.summary, section.body-copy",
title: "&#39;The Greedy Barbarian&#39; is more Idi Amin than Museveni",
pubdate: "2022-01-21 12:45:00",
authors: "TONY MOCHAMA",
sections: "Magazine",
tags: "Ugandan President Yoweri Museveni,Kakwenza Rukirabashaija,Muhoozi Kainerubaga, Commander of Uganda’s Land Forces, Constitutional rights,Ugandan CID,Boxing Day,The Greedy Barbarian ,PEN International Writer of Courage in 2021,Tsitsi Dangaremba ",
comments: "",
access_level: "free",
reader_type: "anonymous"
};
/* CONFIGURATION END */
(function(d,s){var sf=d.createElement(s);sf.type='text/javascript';sf.async=!0;sf.src=(('https:'==d.location.protocol)?'https://d7d3cf2e81d293050033-3dfc0615b0fd7b49143049256703bfce.ssl.cf1.rackcdn.com':'http://t.contentinsights.com')+'/stf.js';var t=d.getElementsByTagName(s)[0];t.parentNode.insertBefore(sf,t)})(document,'script')
</script>
<script>
dataLayer = [{
'site': 'theeastafrican.co.ke',
'section': 'Magazine',
'pageTitle': '&#39;The Greedy Barbarian&#39; is more Idi Amin than Museveni',
'author': 'TONY MOCHAMA',
'keywords': 'Ugandan President Yoweri Museveni,Kakwenza Rukirabashaija,Muhoozi Kainerubaga, Commander of Uganda’s Land Forces, Constitutional rights,Ugandan CID,Boxing Day,The Greedy Barbarian ,PEN International Writer of Courage in 2021,Tsitsi Dangaremba '
}];
</script> </section>
</article>
<footer class="wrapper page-footer" id="page-footer">
<div class="menu-holder menu-holder-footer noprint">
<nav class="menu-vertical footer-section" role="navigation">
<header>
<a href="/tea/news" title="News">
<h3 class="footer-section-heading">News</h3>
</a>
</header>
<a href="/tea/news/east-africa" title="East Africa">East Africa</a>
<a href="/tea/news/rest-of-africa" title="Rest of Africa">Rest of Africa</a>
<a href="/tea/news/world" title="World">World</a>
</nav>
<nav class="menu-vertical footer-section" role="navigation">
<header>
<a href="/tea/business" title="Business">
<h3 class="footer-section-heading">Business</h3>
</a>
</header>
</nav>
<nav class="menu-vertical footer-section" role="navigation">
<header>
<a href="/tea/oped" title="Opinion">
<h3 class="footer-section-heading">Opinion</h3>
</a>
</header>
</nav>
<nav class="menu-vertical footer-section" role="navigation">
<header>
<a href="/tea/science-health" title="Science &amp; Health">
<h3 class="footer-section-heading">Science &amp; Health</h3>
</a>
</header>
</nav>
<nav class="menu-vertical footer-section" role="navigation">
<header>
<a href="/tea/magazine" title="Magazine">
<h3 class="footer-section-heading">Magazine</h3>
</a>
</header>
</nav>
<nav class="menu-vertical footer-section" role="navigation">
<header>
<a href="/tea/sports" title="Sports">
<h3 class="footer-section-heading">Sports</h3>
</a>
</header>
</nav>
<nav class="menu-vertical footer-section" role="navigation">
<header>
<a href="/tea/rest-of-africa" title="Rest of Africa">
<h3 class="footer-section-heading">Rest of Africa</h3>
</a>
</header>
</nav>
<nav class="menu-vertical footer-section" role="navigation">
<header>
<a href="/tea/kusi-ideas" title="KUSI IDEAS">
<h3 class="footer-section-heading">KUSI IDEAS</h3>
</a>
</header>
</nav>
</div>
<footer id="dnFooter">
<div class="dnFooter-row noprint">
<div class="dnFooter-col-sm-3">
<h5></h5>
<h5></h5>
<a href="/tea">
<img src="/resource/crblob/1830002/4d4ba1f86b20e22d593b250208bb3581/amp-logo-png-data.png" alt="The East African" class="logo">
</a>
</div>
<div class="dnFooter-col-sm-2">
<h5>Apps</h5>
<ul>
<li><a href="https://play.google.com/store/apps/developer?id=Nation%20Media%20Group&amp;amp;hl=en&amp;amp;pcampaignid=MKT-Other-global-all-co-prtnr-py-PartBadge-Mar2515-1" target="_blank"><img alt="Play Store" src="/resource/crblob/654084/50e4f00026394f5a265aaf340a5d0a57/google-play-badge-png-data.png"></a></li><br>
<li><a href="https://itunes.apple.com/us/developer/nation-media-group-ltd/id771736086" target="_blank"><img src="/resource/crblob/654060/de9cff10d1c98ad9ce9274954e2fbc20/appstoreicon-svg-data.svg" alt="App Store" class="logo"></a></li>
</ul>
</div>
<div class="dnFooter-col-sm-2">
<h5>Information</h5>
<ul>
<li><a href="https://nation.africa/kenya/contact-us-294088" target="_blank" title="Contact Us">Contact Us</a></li>
<li><a href="https://nation.africa/kenya/frequently-asked-questions-303716" target="_blank" title="Frequently asked questions">Frequently asked questions</a></li>
<li><a href="https://nation.africa/kenya/nmg-privacy-policy-303724" target="_blank" title="NMG Privacy Policy">NMG Privacy Policy</a></li>
<li><a href="https://nation.africa/kenya/terms-of-use-303726" target="_blank" title="Terms of use">Terms of use</a></li>
<li><a href="https://nation.africa/kenya/terms-and-conditions" target="_blank" title="Terms and Conditions of Use">Terms and Conditions of Use</a></li>
<li><a href="https://nation.africa/kenya/our-blog-rules-549010" target="_blank" title="Our Blog Rules">Our Blog Rules</a></li>
</ul>
</div>
<div class="dnFooter-col-sm-2">
<h5>NMG Sites</h5>
<ul>
<li><a href="https://newsstand.nationmedia.com" target="_blank" title="E-Papers">E-Papers</a></li>
<li><a href="http://www.businessdailyafrica.com/" target="_blank" title="Business Daily">Business Daily</a></li>
<li><a href="https://ntv.nation.co.ke/" target="_blank" title="NTV">NTV</a></li>
<li><a href="http://www.ntv.co.ug/" target="_blank" title="NTV Uganda">NTV Uganda</a></li>
<li><a href="http://www.monitor.co.ug/" target="_blank" title="Daily Monitor">Daily Monitor</a></li>
<li><a href="http://www.thecitizen.co.tz/" target="_blank" title="The Citizen">The Citizen</a></li>
<li><a href="https://www.theeastafrican.co.ke/" target="_blank" title="The Eastafrican">The Eastafrican</a></li>
<li><a href="http://www.nationmedia.com/" target="_blank" title="Nation Media Group">Nation Media Group</a></li>
</ul>
</div>
<div class="dnFooter-col-sm-3">
<h5>Follow us</h5>
<div class="social-networks">
<a href="https://www.facebook.com/DailyNation" target="_blank">
<i class="fa fa-facebook" aria-hidden="true"></i>
</a>
<a href="https://www.instagram.com/dailynation" target="_blank">
<i class="fa fa-instagram" aria-hidden="true"></i>
</a>
<a href="https://twitter.com/dailynation" target="_blank">
<i class="fa fa-twitter" aria-hidden="true"></i>
</a>
<a href="https://www.youtube.com/user/DNKenya" target="_blank">
<i class="fa fa-youtube" aria-hidden="true"></i>
</a>
<a href="https://t.me/DailyNation" target="_blank">
<i class="fa fa-telegram" aria-hidden="true"></i>
</a>
<a href="/service/rss/tea/1289152/feed.rss" target="_blank">
<i class="fa fa-rss-square" aria-hidden="true"></i>
</a>
<h1 style="font-size: 0px; margin: 0px;">The East African</h1>
</div>
</div>
</footer>
</footer><noscript class="cm-javascript">
Please enable JavaScript to use this website.
</noscript>
<script type='text/javascript' src='//www.youtube.com/iframe_api'></script>
<script type='text/javascript'>
(function() {
var _sf_async_config = window._sf_async_config = (window._sf_async_config || {});
/** CONFIGURATION START **/
_sf_async_config.uid = 63208;
_sf_async_config.domain = 'theeastafrican.co.ke';
_sf_async_config.flickerControl = false;
_sf_async_config.useCanonical = true;
_sf_async_config.useCanonicalDomain = true;
_sf_async_config.sections = 'Magazine';
_sf_async_config.authors ='TONY MOCHAMA';
/** CONFIGURATION END **/
function loadChartbeat() {
var e = document.createElement('script');
var n = document.getElementsByTagName('script')[0];
e.type = 'text/javascript';
e.async = true;
e.src = '//static.chartbeat.com/js/chartbeat_video.js';
n.parentNode.insertBefore(e, n);
}
/** TELL CHARTBEAT TO AUTODETECT YOUTUBE VIDEOS **/
var _cbv = window._cbv || (window._cbv = []);
_cbv.push(['autoDetectYouTubeIframes']);
loadChartbeat();
})();
</script>
<script async src="//static.chartbeat.com/js/chartbeat_mab.js"></script> <script type="text/javascript">
window._taboola = window._taboola || [];
_taboola.push({flush: true});
</script>
<script src="/resource/themes/east-african/js/commons-654256-2.js"></script><script src="/resource/themes/east-african/js/east-african-654258-7.js"></script>
<script>window.googletag=window.googletag ||{cmd: []}; googletag.cmd.push(function(){googletag.defineSlot('/1010816/TEA-1x1', [1, 1], 'div-gpt-ad-1634797092980-0').addService(googletag.pubads()); googletag.pubads().enableSingleRequest(); googletag.pubads().collapseEmptyDivs(); googletag.enableServices();});</script><div id='div-gpt-ad-1634797092980-0'> <script>googletag.cmd.push(function(){googletag.display('div-gpt-ad-1634797092980-0');}); </script></div><script type="text/javascript">(function(){window['__CF$cv$params']={r:'6d155b797ff457ca',m:'nollemHARN_Wcg126RAx1T9N8hyRRT3SxJgB.0eB_lU-1642818594-0-AZBFNLbNtdByhwpaHnRJjH/DJgP4rtTjB2wrAw/nhK9SeNCOX8HhES/ldztrChIX97figvslQb9tTyQWeSnAvzHv3lgJrbRM9s/6vXOGUB4t9IiVTxCQ8T+tmzbw8vnAjelkado+37Tley65Z91F9KX4NfsXZkinTY6opXP80ISgfM0kezEG1qPGdJehvCqo/mDUSqn9ODQwzKbJUIXz0b8=',s:[0x44cac515cf,0x48ed39eea6],}})();</script></body></html>
