<!DOCTYPE html>
<!--[if lt IE 7]><html lang="en" class="no-js lt-ie9 lt-ie8 lt-ie7" prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb# article: http://ogp.me/ns/article# video: http://ogp.me/ns/video#
profile: http://ogp.me/ns/profile#"><![endif]-->
<!--[if IE 7]><html lang="en" class="no-js lt-ie9 lt-ie8" prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb# article: http://ogp.me/ns/article# video: http://ogp.me/ns/video#
profile: http://ogp.me/ns/profile#"><![endif]-->
<!--[if IE 8]><html lang="en" class="no-js lt-ie9" prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb# article: http://ogp.me/ns/article# video: http://ogp.me/ns/video#
profile: http://ogp.me/ns/profile#"><![endif]-->
<!--[if IE 9]><html lang="en" class="no-js ie9" prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb# article: http://ogp.me/ns/article# video: http://ogp.me/ns/video#
profile: http://ogp.me/ns/profile#" ><![endif]-->
<!--[if gt IE 8]><!--><html class="no-js" lang="en" dir="ltr">
<head>

<script src="/cdn-cgi/apps/head/cf_9l7RKgDs4MbXIY5TRYBrR1cs.js"></script><script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-KBT24PQ');</script>

<meta charset="UTF-8">
<link rel="apple-touch-icon" sizes="180x180" href="/resource/crblob/654062/401e0e1f2272bebbbcd23456403002c4/apple-touch-icon-png-data.png">
<link rel="icon" type="image/png" sizes="32x32" href="/resource/crblob/654080/663580258f749228316ee276e0f3cd6c/favicon-32x32-png-data.png">
<link rel="icon" type="image/png" sizes="16x16" href="/resource/crblob/654078/daa211aeb0ce3157f0075e45c26364bf/favicon-16x16-png-data.png">
<link rel="manifest" href="/site.webmanifest">
<link rel="mask-icon" href="/resource/crblob/654108/050c2c369f7ecebd815fb78f4057e9af/safari-pinned-tab-svg-data.svg" color="#5bbad5">
<link rel="shortcut icon" type="image/x-icon" href="/resource/crblob/654082/6813c1d688e9fadd7b8f7189a6e5179f/favicon-ico-data.ico">
<meta name="msapplication-TileColor" content="#da532c">
<title>Uganda&#39;s oldest opposition party agrees to a new deal ruling NRM - The East African</title>
<meta name="keywords" content="norbert mao">
<meta name="viewport" content="width=device-width, initial-scale=1">
<meta name="robots" content="index, follow" />
<meta name="viewport" content="width=device-width,initial-scale=1.0,user-scalable=0">
<script type="application/ld+json">
{
"@context": "https://schema.org",
"@type": "NewsArticle",
"mainEntityOfPage": {
"@type": "WebPage",
"@id": "https://www.theeastafrican.co.ke/tea/news/east-africa/uganda-oldest-opposition-party-agrees-new-deal-ruling-nrm-3889630"
},
"name": "Uganda&apos;s oldest opposition party agrees to a new deal ruling NRM",
"headline": "Uganda&apos;s oldest opposition party agrees to a new deal ruling NRM",
"description": "<p>Norbert Mao, who heads Uganda’s oldest opposition party has been appointed Minister for Justice and Constitutional Affairs.<\/p>",
"image": {"@type": "ImageObject", "url": "https://www.theeastafrican.co.ke/resource/blob/1375366/f3d0e27bc4206de323ccb63e25fe32a0/mao-data.jpg", "height": 391, "width": 696 },
"datePublished": "2022-07-23T13:45:00Z",
"dateModified": "2022-07-23T14:04:00Z",
"author": [
{ "@type": "Person",
"name": "JONATHAN KAMOGA",
"url": "https://www.theeastafrican.co.ke/tea/author-profiles/jonathan-kamoga-1401674"
}
],
"publisher": {
"@type": "Organization",
"name": "The East African",
"logo": {
"@type": "ImageObject",
"url": "https://www.theeastafrican.co.ke/resource/crblob/654080/663580258f749228316ee276e0f3cd6c/favicon-32x32-png-data.png",
"width":40,
"height":29
}
}
}
</script>
<script type="application/ld+json">
{
"@context": "http://schema.org",
"@type": "BreadcrumbList",
"itemListElement": [
{
"@type": "ListItem",
"position": 1,
"name": "Home",
"item": "https://www.theeastafrican.co.ke/tea"
}
,
{
"@type": "ListItem",
"position": 2,
"name": "News",
"item": "https://www.theeastafrican.co.ke/tea/news"
}
,
{
"@type": "ListItem",
"position": 3,
"name": "East Africa",
"item": "https://www.theeastafrican.co.ke/tea/news/east-africa"
}
]
}
</script>
<meta name="description" content="
Norbert Mao, who heads Uganda’s oldest opposition party has been appointed Minister for Justice and Constitutional Affairs.">
<meta property="og:site_name" content="The East African" />
<meta property="og:type" content="article" />
<meta property="fb:app_id" content="174023979648743" />
<meta property="og:title" content="Uganda&#39;s oldest opposition party agrees to a new deal ruling NRM" />
<meta property="og:url" content="https://www.theeastafrican.co.ke/tea/news/east-africa/uganda-oldest-opposition-party-agrees-new-deal-ruling-nrm-3889630" />
<meta property="og:description" content="
Norbert Mao, who heads Uganda’s oldest opposition party has been appointed Minister for Justice and Constitutional Affairs." />
<meta property="og:locale" content="en" />
<meta property="og:locale:alternate" content="en_US" />
<meta property="og:article:published_time" content="2022-07-23 17:04:00" />
<meta property="og:image" content="https://www.theeastafrican.co.ke/resource/blob/1375366/f3d0e27bc4206de323ccb63e25fe32a0/mao-data.jpg">
<meta name="twitter:card" content="summary_large_image">
<meta name="twitter:site" content="@The_EastAfrican">
<meta name="twitter:title" content="Uganda&#39;s oldest opposition party agrees to a new deal ruling NRM">
<meta name="twitter:description" content="
Norbert Mao, who heads Uganda’s oldest opposition party has been appointed Minister for Justice and Constitutional Affairs.">
<meta name="twitter:image" content="https://www.theeastafrican.co.ke/resource/blob/1375366/f3d0e27bc4206de323ccb63e25fe32a0/mao-data.jpg"> <meta charset="utf-8">
<link rel="canonical" href="https://www.theeastafrican.co.ke/tea/news/east-africa/uganda-oldest-opposition-party-agrees-new-deal-ruling-nrm-3889630">
<meta name="google-site-verification" content="7PI23eF83yLrptihU4-C11bEaznAQl8mts5BfCS1W2U" />
<script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>
<script>
var googletag = googletag || {};
googletag.cmd = googletag.cmd || [];
</script>
<script>document.documentElement.className = document.documentElement.className.replace(/no-js/g, 'js');</script>
<link href="//cdnjs.cloudflare.com/ajax/libs/font-awesome/4.7.0/css/font-awesome.min.css" rel="stylesheet">
<link rel="stylesheet" href="//secure.widget.cloud.opta.net/v3/css/v3.core.opta-widgets.css">
<link rel="stylesheet" href="//secure.widget.cloud.opta.net/v3/css/v3.football.opta-widgets.css">
<link rel="amphtml" href="https://www.theeastafrican.co.ke/tea/news/east-africa/uganda-oldest-opposition-party-agrees-new-deal-ruling-nrm-3889630?view=htmlamp">
<script type="text/javascript">
window._taboola = window._taboola || [];
_taboola.push({article:'auto'});
!function (e, f, u, i) {
if (!document.getElementById(i)){
e.async = 1;
e.src = u;
e.id = i;
f.parentNode.insertBefore(e, f);
}
}(document.createElement('script'),
document.getElementsByTagName('script')[0],
'//cdn.taboola.com/libtrc/nationmediagroup-dailynation/loader.js',
'tb_loader_script');
if(window.performance && typeof window.performance.mark == 'function')
{window.performance.mark('tbl_ic');}
</script>
<link href="/resource/themes/east-african/css/east-african-654262-141.css" rel="stylesheet">
<script type="text/javascript"> function GaAccountData(webPropertyId, domainName) {
this.webPropertyId = webPropertyId;
this.domainName = domainName;
}
function GaPageviewData(contentId, contentType, navigationPath, pageUrl, authors, pubDate, tags, queryParameter, query, userSegments, disableAdFeaturesPlugin) {
this.contentId = contentId;
this.contentType = contentType;
this.navigationPath = navigationPath;
this.pageUrl = pageUrl;
this.authors = authors;
this.pubDate = pubDate;
this.tags = tags;
this.queryParameter = queryParameter;
this.query = query;
this.userSegments = userSegments;
this.disableAdvertisingFeaturesPlugin = typeof disableAdFeaturesPlugin !== 'undefined' ? disableAdFeaturesPlugin : false;
}
function GaEventData(category, action, name, value) {
this.category = category;
this.action = action;
this.name = name;
this.value = value;
}
function gaTrackPageview(ga, gaAccountData, gaPageviewData, trackerName) {
var t = _gaTrackerPrefix(trackerName);
//set Account
if (trackerName && trackerName.length > 0) {
ga('create', gaAccountData.webPropertyId, gaAccountData.domainName, {'name': trackerName});
} else {
ga('create', gaAccountData.webPropertyId, gaAccountData.domainName);
}
ga(t.concat('set'), 'anonymizeIp', true);
if (!gaPageviewData.disableAdvertisingFeaturesPlugin) {
ga(t.concat('require'), 'displayfeatures');
}
//set custom vars
ga(t.concat('set'), 'dimension1', gaPageviewData.contentId);
ga(t.concat('set'), 'dimension2', gaPageviewData.contentType);
ga(t.concat('set'), 'dimension3', gaPageviewData.navigationPath);
ga(t.concat('set'), 'dimension4', gaPageviewData.userSegments);
ga(t.concat('set'), 'dimension5', gaPageviewData.authors);
ga(t.concat('set'), 'dimension6', gaPageviewData.pubDate);
ga(t.concat('set'), 'dimension7', gaPageviewData.tags);
// if a search was performed on the website, retain the search query
var query = "";
if (gaPageviewData.query && gaPageviewData.queryParameter) {
query = "?" + gaPageviewData.queryParameter + "=" + encodeURIComponent(gaPageviewData.query);
}
//send page view
ga(t.concat('send'), 'pageview', gaPageviewData.pageUrl + query);
}
function gaTrackEvent(ga, gaAccountData, gaPageviewData, gaEventData, trackerName) {
var t = _gaTrackerPrefix(trackerName);
//set Account
if (trackerName && trackerName.length > 0) {
ga('create', gaAccountData.webPropertyId, gaAccountData.domainName, {'name': trackerName});
} else {
ga('create', gaAccountData.webPropertyId, gaAccountData.domainName);
}
ga(t.concat('set'), 'anonymizeIp', true);
if (!gaPageviewData.disableAdvertisingFeaturesPlugin) {
ga(t.concat('require'), 'displayfeatures');
}
//set custom vars
ga(t.concat('set'), 'dimension1', gaPageviewData.contentId);
ga(t.concat('set'), 'dimension2', gaPageviewData.contentType);
ga(t.concat('set'), 'dimension3', gaPageviewData.navigationPath);
ga(t.concat('set'), 'dimension4', gaPageviewData.userSegments);
ga(t.concat('set'), 'dimension5', gaPageviewData.authors);
ga(t.concat('set'), 'dimension6', gaPageviewData.pubDate);
ga(t.concat('set'), 'dimension7', gaPageviewData.tags);
//sent event
ga(t.concat('send'), 'event', gaEventData.category, gaEventData.action, gaEventData.name, gaEventData.value);
}
function _gaTrackerPrefix(trackerName) {
return (trackerName && trackerName.length > 0)
? trackerName.concat('.')
: '';
}
(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
})(window,document,'script','//www.google-analytics.com/analytics.js','ga');
var gaAccountData = new GaAccountData("UA-1030601-5", "www.theeastafrican.co.ke");
var gaPageData = new GaPageviewData(
"3889630",
"CMArticle",
"1289142_1289144_1289208",
"/tea/news/east-africa/uganda-oldest-opposition-party-agrees-new-deal-ruling-nrm-3889630",
"JONATHAN KAMOGA",
"23-07-2022",
"Politics",
false
);
gaTrackPageview(ga, gaAccountData, gaPageData);
</script> <script async src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
<script async src='/cdn-cgi/bm/cv/669835187/api.js'></script></head><body id="top" style="zoom:1;">

<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-KBT24PQ"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>

<nav class="navbar navbar-default full-width">
<div class="container justify-content-between justify-content-md-start">
<div class="navbar-header">
<a href="/tea" class="logo"></a>
</div>
<ul id="panel" class="nav navbar-nav d-md-none">
<li><a href="/tea/news">News</a></li>
<li><a href="/tea/business">Business</a></li>
<li><a href="/tea/oped">Opinion</a></li>
<li><a href="/tea/science-health">Science &amp; Health</a></li>
<li><a href="/tea/magazine">Magazine</a></li>
<li><a href="/tea/sports">Sports</a></li>
<li><a href="/tea/rest-of-africa">Rest of Africa</a></li>
<li><a href="/tea/kusi-ideas">KUSI IDEAS</a></li>
</ul>
<ul class="nav navbar-nav d-none d-md-block pl-lg-3">
<li>
<a href="/tea/news">News</a>
<div class="mega-menu">
<div class="row no-gutters">
<div class="col-3">
<a href="/tea/news/east-africa">East Africa</a>
<a href="/tea/news/rest-of-africa">Rest of Africa</a>
<a href="/tea/news/world">World</a>
</div>
<div class="col-8 offset-1">
<h4>Latest News</h4>
<div class="row no-gutters">
<div class="col-6">
<div class="story-teaser tiny-teaser">
<a href="/tea/news/east-africa/election-observers-arrive-in-kenya-3889636"><i class="fa fa-caret-right" aria-hidden="true"></i> Election observers arrive in Kenya as Ruto, Raila trade accusations</a>
</div>
<div class="story-teaser tiny-teaser">
<a href="/tea/news/east-africa/uganda-oldest-opposition-party-agrees-new-deal-ruling-nrm-3889630"><i class="fa fa-caret-right" aria-hidden="true"></i> Uganda&#39;s oldest opposition party agrees to a new deal ruling NRM</a>
</div>
</div>
<div class="col-6">
<div class="story-teaser tiny-teaser">
<a href="/tea/news/rest-of-africa/post-election-victims-forgotten-in-abidjan-3889624"><i class="fa fa-caret-right" aria-hidden="true"></i> Post-election victims ‘forgotten’ in Abidjan</a>
</div>
<div class="story-teaser tiny-teaser">
<a href="/tea/news/rest-of-africa/tribal-clashes-pose-fresh-headache-in-sudan-3889620"><i class="fa fa-caret-right" aria-hidden="true"></i> Tribal clashes pose fresh headache in Sudan</a>
</div>
</div>
</div>
</div> </div>
</div>
</li>
<li>
<a href="/tea/business">Business</a>
<div class="mega-menu">
<div class="row no-gutters">
<div class="col-3">
</div>
<div class="col-8 offset-1">
<h4>Latest Business</h4>
<div class="row no-gutters">
<div class="col-6">
<div class="story-teaser tiny-teaser">
<a href="/tea/business/afdb-arm-releases-5-4-million-for-somalia-food-security-3889930"><i class="fa fa-caret-right" aria-hidden="true"></i> AfDB arm releases $5.4 million for Somalia food security </a>
</div>
<div class="story-teaser tiny-teaser">
<a href="/tea/business/museveni-electric-vehicles-will-help-counter-oil-supply-shocks-3889634"><i class="fa fa-caret-right" aria-hidden="true"></i> Museveni: Electric vehicles will help counter oil supply shocks</a>
</div>
</div>
<div class="col-6">
<div class="story-teaser tiny-teaser">
<a href="/tea/business/greenpeace-opposes-drc-oil-and-gas-project-3889606"><i class="fa fa-caret-right" aria-hidden="true"></i> Greenpeace opposes DRC oil and gas project</a>
</div>
<div class="story-teaser tiny-teaser">
<a href="/tea/business/eac-common-market-scorecard-falls-short-3889534"><i class="fa fa-caret-right" aria-hidden="true"></i> EAC Common Market scorecard falls short of expectations</a>
</div>
</div>
</div>
</div> </div>
</div>
</li>
<li>
<a href="/tea/oped">Opinion</a>
<div class="mega-menu">
<div class="row no-gutters">
<div class="col-3">
</div>
<div class="col-8 offset-1">
<h4>Latest Opinion</h4>
<div class="row no-gutters">
<div class="col-6">
<div class="story-teaser tiny-teaser">
<a href="/tea/oped/comment/on-omanyala-debate-we-can-do-much-better-3889828"><i class="fa fa-caret-right" aria-hidden="true"></i> On Omanyala, debate, we can do much better</a>
</div>
<div class="story-teaser tiny-teaser">
<a href="/tea/oped/editorial/somalia-wants-in-but-eac-should-rethink-expansion-3889822"><i class="fa fa-caret-right" aria-hidden="true"></i> Somalia wants in but EAC should rethink expansion</a>
</div>
</div>
<div class="col-6">
<div class="story-teaser tiny-teaser">
<a href="/tea/oped/comment/task-ahead-of-east-africa-s-best-brains-in-arusha-august-house-3888718"><i class="fa fa-caret-right" aria-hidden="true"></i> Task ahead of East Africa’s best brains in Arusha august House</a>
</div>
<div class="story-teaser tiny-teaser">
<a href="/tea/oped/comment/africa-elite-buccaneers-clean-the-state-coffers-3888672"><i class="fa fa-caret-right" aria-hidden="true"></i> We lynch chicken thieves as elite buccaneers clean the state coffers</a>
</div>
</div>
</div>
</div> </div>
</div>
</li>
<li>
<a href="/tea/science-health">Science &amp; Health</a>
<div class="mega-menu">
<div class="row no-gutters">
<div class="col-3">
</div>
<div class="col-8 offset-1">
<h4>Latest Science &amp; Health</h4>
<div class="row no-gutters">
<div class="col-6">
<div class="story-teaser tiny-teaser">
<a href="/tea/science-health/who-triggers-highest-alert-on-monkeypox-3889920"><i class="fa fa-caret-right" aria-hidden="true"></i> WHO triggers highest alert on monkeypox</a>
</div>
<div class="story-teaser tiny-teaser">
<a href="/tea/science-health/rise-in-viagra-sales-sows-worries-for-puntland-politicians-3886134"><i class="fa fa-caret-right" aria-hidden="true"></i> Rise in viagra sales sows worries for Puntland politicians</a>
</div>
</div>
<div class="col-6">
<div class="story-teaser tiny-teaser">
<a href="/tea/science-health/tanzania-confirms-outbreak-of-leptospirosis-3883916"><i class="fa fa-caret-right" aria-hidden="true"></i> Tanzania confirms outbreak of leptospirosis </a>
</div>
<div class="story-teaser tiny-teaser">
<a href="/tea/science-health/rivers-and-seas-in-global-south-suffocate-under-intense-silting-3881460"><i class="fa fa-caret-right" aria-hidden="true"></i> Rivers and seas in global south suffocate under intense silting</a>
</div>
</div>
</div>
</div> </div>
</div>
</li>
<li>
<a href="/tea/magazine">Magazine</a>
<div class="mega-menu">
<div class="row no-gutters">
<div class="col-3">
</div>
<div class="col-8 offset-1">
<h4>Latest Magazine</h4>
<div class="row no-gutters">
<div class="col-6">
<div class="story-teaser tiny-teaser">
<a href="/tea/magazine/henrietta-mwangola-blazing-the-lodge-trail-3888924"><i class="fa fa-caret-right" aria-hidden="true"></i> Henrietta Mwangola: Blazing the lodge trail</a>
</div>
<div class="story-teaser tiny-teaser">
<a href="/tea/magazine/caine-prize-winner-speaks-highly-of-local-storytelling-3888928"><i class="fa fa-caret-right" aria-hidden="true"></i> Caine Prize winner speaks highly of local storytelling</a>
</div>
</div>
<div class="col-6">
<div class="story-teaser tiny-teaser">
<a href="/tea/magazine/former-kenya-s-attorney-general-dubs-book-valedictory-speech-3888930"><i class="fa fa-caret-right" aria-hidden="true"></i> Former Kenya&#39;s Attorney-General dubs book &#39;valedictory speech&#39;</a>
</div>
<div class="story-teaser tiny-teaser">
<a href="/tea/magazine/kigali-explores-eco-tourism-at-nyandungu-green-park--3888938"><i class="fa fa-caret-right" aria-hidden="true"></i> Kigali explores eco-tourism at Nyandungu green park</a>
</div>
</div>
</div>
</div> </div>
</div>
</li>
<li>
<a href="/tea/sports">Sports</a>
<div class="mega-menu">
<div class="row no-gutters">
<div class="col-3">
</div>
<div class="col-8 offset-1">
<h4>Latest Sports</h4>
<div class="row no-gutters">
<div class="col-6">
<div class="story-teaser tiny-teaser">
<a href="/tea/sports/ugandan-joshua-cheptegei-runaway-success--3888932"><i class="fa fa-caret-right" aria-hidden="true"></i> Ugandan Joshua Cheptegei’s runaway success</a>
</div>
<div class="story-teaser tiny-teaser">
<a href="/tea/sports/angella-okutoyi-kenya-tennis-star-3881426"><i class="fa fa-caret-right" aria-hidden="true"></i> Tales of tragedy, defiance and hope from two continents</a>
</div>
</div>
<div class="col-6">
<div class="story-teaser tiny-teaser">
<a href="/tea/sports/safari-rally-uhuru-kenyatta-legacy-kenya-sporting-history-3859224"><i class="fa fa-caret-right" aria-hidden="true"></i> Safari Rally rich part of Uhuru Kenyatta legacy and Kenya’s sporting history</a>
</div>
<div class="story-teaser tiny-teaser">
<a href="/tea/sports/egypt-lose-to-ethiopia-afcon-3844100"><i class="fa fa-caret-right" aria-hidden="true"></i> Egypt suffer shock AFCON loss to Ethiopia</a>
</div>
</div>
</div>
</div> </div>
</div>
</li>
<li>
<a href="/tea/rest-of-africa">Rest of Africa</a>
<div class="mega-menu">
<div class="row no-gutters">
<div class="col-3">
</div>
<div class="col-8 offset-1">
<h4>Latest Rest of Africa</h4>
<div class="row no-gutters">
<div class="col-6">
<div class="story-teaser tiny-teaser">
<a href="/tea/news/rest-of-africa/post-election-victims-forgotten-in-abidjan-3889624"><i class="fa fa-caret-right" aria-hidden="true"></i> Post-election victims ‘forgotten’ in Abidjan</a>
</div>
<div class="story-teaser tiny-teaser">
<a href="/tea/news/rest-of-africa/tribal-clashes-pose-fresh-headache-in-sudan-3889620"><i class="fa fa-caret-right" aria-hidden="true"></i> Tribal clashes pose fresh headache in Sudan</a>
</div>
</div>
<div class="col-6">
<div class="story-teaser tiny-teaser">
<a href="/tea/news/rest-of-africa/defining-moment-in-chad-as-transition-period-gives-way-3889618"><i class="fa fa-caret-right" aria-hidden="true"></i> Defining moment in Chad as transition period gives way</a>
</div>
<div class="story-teaser tiny-teaser">
<a href="/tea/news/rest-of-africa/zimbabwe-chokes-under-weight-of-china-loans-3886082"><i class="fa fa-caret-right" aria-hidden="true"></i> Zimbabwe chokes under weight of $13 billion China loans</a>
</div>
</div>
</div>
</div> </div>
</div>
</li>
<li>
<a href="/tea/kusi-ideas">KUSI IDEAS</a>
<div class="mega-menu">
<div class="row no-gutters">
<div class="col-3">
</div>
<div class="col-8 offset-1">
<h4>Latest KUSI IDEAS</h4>
<div class="row no-gutters">
<div class="col-6">
<div class="story-teaser tiny-teaser">
<a href="/tea/kusi-ideas/afcfta-on-track-to-lift-100-million-africans-out-of-poverty-3664440"><i class="fa fa-caret-right" aria-hidden="true"></i> AfCFTA on track to lift 100 million Africans out of poverty by 2035</a>
</div>
<div class="story-teaser tiny-teaser">
<a href="/tea/kusi-ideas/youth-and-creative-sector-banking-on-integration-3664378"><i class="fa fa-caret-right" aria-hidden="true"></i> Youth and creative sector banking on integration</a>
</div>
</div>
<div class="col-6">
<div class="story-teaser tiny-teaser">
<a href="/tea/kusi-ideas/targeting-specialist-markets-can-be-big-winner-3664432"><i class="fa fa-caret-right" aria-hidden="true"></i> Targeting specialist markets can be big winner</a>
</div>
<div class="story-teaser tiny-teaser">
<a href="/tea/kusi-ideas/water-management-tech-can-stave-off-effects-of-climate-change-3664418"><i class="fa fa-caret-right" aria-hidden="true"></i> Water management and technology can stave off worst effects of climate change</a>
</div>
</div>
</div>
</div> </div>
</div>
</li>
</ul>
<a class="btn-slide">
<i class="fa fa-bars d-block d-md-none" aria-hidden="true"></i>
</a>
<div class="search-form clearfix">
<form id="searchHeader" name="searchfrm" action="/service/search/tea/1446352" autocomplete="off" role="search">
<input name="query" type="search" placeholder="Search" minlength="3" required>
<input type="submit" name="" value="">
</form>
</div> </div>
</nav>
<div class="breaking-news">
<div class="container">
<div class="breaking-news-container" data-separator="|" data-fragments-link="/ajax/breaking-news/tea">
</div>
</div>
</div>
<article role="main" class="wrapper newsplex-article">
<section role="main" class="main-home artTop ">
<div class="container">
<div class="row">
<article class="main column">
<section class="ad noprint"> <span class="">Advertisement</span> <div class="ad">
<script>
var Url_Seg1=window.location.pathname.split( '/' )[1];
if(Url_Seg1==="sports"){ }else{
googletag.cmd.push(function() {
var leaderBoard = googletag.sizeMapping().
addSize([1024, 0], [728, 90]).
addSize([600, 0], [300, 250]).
addSize([800, 0], [728, 90]).
addSize([0, 0], [[320, 50], [320, 100], [300, 75], [300, 100], [300, 50], [300, 250]]).
build();
window.bk_dfp_integration = window.bk_dfp_integration || {}; window.bk_dfp_integration.functions = window.bk_dfp_integration.functions || {}; if(typeof bk_dfp_integration.functions.sendDfp === "function"){ bk_dfp_integration.functions.sendDfp(); }
googletag.defineSlot('/1010816/Z-DN-728x90-ArticleTop',[[320, 50], [320, 100], [300, 75], [300, 100], [300, 50], [728, 90], [300, 250]], 'div-gpt-ad-1489467324804-0').defineSizeMapping(leaderBoard).addService(googletag.pubads());
googletag.pubads().collapseEmptyDivs();
googletag.pubads().setTargeting('url', window.location.pathname.split( '/' )[1]);
googletag.pubads().setTargeting('url2', window.location.pathname.split( '/' )[2]);
googletag.enableServices();
});
}
</script>

<div id='div-gpt-ad-1489467324804-0' style='margin:0 auto;height:auto'>
<script>
if(Url_Seg1==="sports"){ $(".ad").css("background","white"); }else{
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1489467324804-0'); });
}
</script>
</div>
</div> </section><div class="container mt-4 px-0">
<nav aria-label="breadcrumb">
<ol class="breadcrumb col-12">
<li class="breadcrumb-item "><a href="/tea">The East African</a></li>
<li class="breadcrumb-item "><a href="/tea/news">News</a></li>
<li class="breadcrumb-item active" aria-current=&quot;page&quot;><a href="#">East Africa</a></li>
</ol>
</nav>
<div class="section-home-header clearfix mb-3">
</div>
</div> <header>
<h2>Uganda&#39;s oldest opposition party agrees to a new deal ruling NRM</h2>
<p class="summary"></p>
<h6>Saturday July 23 2022</h6>
<div class="social-networks noprint">
<a href="https://twitter.com/share?text=Another opposition leader joins Uganda government&amp;url=https://www.theeastafrican.co.ke/tea/news/east-africa/uganda-oldest-opposition-party-agrees-new-deal-ruling-nrm-3889630&amp;via=The_EastAfrican" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a>
<a href="https://www.facebook.com/sharer.php?u=https://www.theeastafrican.co.ke/tea/news/east-africa/uganda-oldest-opposition-party-agrees-new-deal-ruling-nrm-3889630" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a>
<a href="https://www.linkedin.com/shareArticle?mini=true&amp;url=https://www.theeastafrican.co.ke/tea/news/east-africa/uganda-oldest-opposition-party-agrees-new-deal-ruling-nrm-3889630" target="_blank"><i class="fa fa-linkedin" aria-hidden="true"></i></a>
<div class="mobileShow">
<a href="https://api.whatsapp.com/send?text=https://www.theeastafrican.co.ke/tea/news/east-africa/uganda-oldest-opposition-party-agrees-new-deal-ruling-nrm-3889630" target="_blank"><i class="fa fa-whatsapp" aria-hidden="true"></i></a>
</div>
<a href="javascript:window.print()" target="_blank"><i class="fa fa-print" aria-hidden="true"></i></a>
<a href="/cdn-cgi/l/email-protection#dce3afa9beb6b9bfa8e19db2b3a8b4b9aefcb3acacb3afb5a8b5b3b2fcb0b9bdb8b9aefcb6b3b5b2affc89bbbdb2b8bdfcbbb3aab9aeb2b1b9b2a8fabdb1ace7beb3b8a5e19db2b3a8b4b9aefcb3acacb3afb5a8b5b3b2fcb0b9bdb8b9aefcb6b3b5b2affc89bbbdb2b8bdfcbbb3aab9aeb2b1b9b2a8f1b4a8a8acafe6f3f3abababf2a8b4b9b9bdafa8bdbaaeb5bfbdb2f2bfb3f2b7b9f3a8b9bdf3b2b9abaff3b9bdafa8f1bdbaaeb5bfbdf3a9bbbdb2b8bdf1b3b0b8b9afa8f1b3acacb3afb5a8b5b3b2f1acbdaea8a5f1bdbbaeb9b9aff1b2b9abf1b8b9bdb0f1aea9b0b5b2bbf1b2aeb1f1efe4e4e5eaefec" target="_blank"><i class="fa fa-envelope-o" aria-hidden="true"></i></a>
</div> <div>
<div class="storyTopPic">
<img src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mNkYAAAAAYAAjCB0C8AAAAASUVORK5CYII=" alt="mao" class="cm-media cm-media--loading cm-media--responsive cm-media--loading " title="" data-cm-responsive-media="[{&quot;name&quot;:&quot;landscape_ratio16x9&quot;,&quot;ratioWidth&quot;:16,&quot;ratioHeight&quot;:9,&quot;linksForWidth&quot;:{&quot;200&quot;:&quot;/resource/image/1375366/landscape_ratio16x9/200/112/dcb743fa43347449ab89db6b1878964c/xL/mao.jpg&quot;,&quot;300&quot;:&quot;/resource/image/1375366/landscape_ratio16x9/300/168/dcb743fa43347449ab89db6b1878964c/Nn/mao.jpg&quot;,&quot;400&quot;:&quot;/resource/image/1375366/landscape_ratio16x9/400/225/dcb743fa43347449ab89db6b1878964c/BS/mao.jpg&quot;,&quot;1160&quot;:&quot;/resource/image/1375366/landscape_ratio16x9/1160/652/dcb743fa43347449ab89db6b1878964c/Sm/mao.jpg&quot;}},{&quot;name&quot;:&quot;portrait_ratio2x3&quot;,&quot;ratioWidth&quot;:2,&quot;ratioHeight&quot;:3,&quot;linksForWidth&quot;:{&quot;200&quot;:&quot;/resource/image/1375366/portrait_ratio2x3/200/300/549c41eede55f8c15dbfba37f94b47fb/lk/mao.jpg&quot;,&quot;400&quot;:&quot;/resource/image/1375366/portrait_ratio2x3/400/600/549c41eede55f8c15dbfba37f94b47fb/IN/mao.jpg&quot;,&quot;768&quot;:&quot;/resource/image/1375366/portrait_ratio2x3/768/1152/549c41eede55f8c15dbfba37f94b47fb/kx/mao.jpg&quot;}},{&quot;name&quot;:&quot;landscape_ratio2x1&quot;,&quot;ratioWidth&quot;:2,&quot;ratioHeight&quot;:1,&quot;linksForWidth&quot;:{&quot;200&quot;:&quot;/resource/image/1375366/landscape_ratio2x1/200/100/23f655ef435c8d8b564f8f72239236cb/ts/mao.jpg&quot;}},{&quot;name&quot;:&quot;landscape_ratio3x2&quot;,&quot;ratioWidth&quot;:3,&quot;ratioHeight&quot;:2,&quot;linksForWidth&quot;:{&quot;300&quot;:&quot;/resource/image/1375366/landscape_ratio3x2/300/200/6869cdcffb333965c4c2324a81fd7a2f/yS/mao.jpg&quot;,&quot;400&quot;:&quot;/resource/image/1375366/landscape_ratio3x2/400/267/6869cdcffb333965c4c2324a81fd7a2f/gI/mao.jpg&quot;,&quot;768&quot;:&quot;/resource/image/1375366/landscape_ratio3x2/768/512/6869cdcffb333965c4c2324a81fd7a2f/bG/mao.jpg&quot;}},{&quot;name&quot;:&quot;portrait_ratio1x1&quot;,&quot;ratioWidth&quot;:1,&quot;ratioHeight&quot;:1,&quot;linksForWidth&quot;:{&quot;50&quot;:&quot;/resource/image/1375366/portrait_ratio1x1/50/50/9e85b97122ea5648bc402c3c717b0aba/dw/mao.jpg&quot;,&quot;60&quot;:&quot;/resource/image/1375366/portrait_ratio1x1/60/60/9e85b97122ea5648bc402c3c717b0aba/NB/mao.jpg&quot;,&quot;200&quot;:&quot;/resource/image/1375366/portrait_ratio1x1/200/200/9e85b97122ea5648bc402c3c717b0aba/fl/mao.jpg&quot;,&quot;400&quot;:&quot;/resource/image/1375366/portrait_ratio1x1/400/400/9e85b97122ea5648bc402c3c717b0aba/Wb/mao.jpg&quot;,&quot;768&quot;:&quot;/resource/image/1375366/portrait_ratio1x1/768/768/9e85b97122ea5648bc402c3c717b0aba/lg/mao.jpg&quot;}},{&quot;name&quot;:&quot;landscape_ratio4x3&quot;,&quot;ratioWidth&quot;:4,&quot;ratioHeight&quot;:3,&quot;linksForWidth&quot;:{&quot;200&quot;:&quot;/resource/image/1375366/landscape_ratio4x3/200/150/a0ee4d42cf9ff7f52361a13f7c2ad767/bd/mao.jpg&quot;,&quot;400&quot;:&quot;/resource/image/1375366/landscape_ratio4x3/400/300/a0ee4d42cf9ff7f52361a13f7c2ad767/lk/mao.jpg&quot;,&quot;768&quot;:&quot;/resource/image/1375366/landscape_ratio4x3/768/576/a0ee4d42cf9ff7f52361a13f7c2ad767/yQ/mao.jpg&quot;}}]">
</div>
<p id="photo_article_caption">Uganda's Democratic Party leader Norbert Mao. PHOTO | NMG</p> </div>
</header>
<article class="article">
<section class="article-sidebar">
<section class="ad noprint">
<span class="">Advertisement</span>
<div class="ad">
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script>
window.googletag = window.googletag || {cmd: []};
googletag.cmd.push(function() {
googletag.defineSlot('/1010816/EA-300X250-Article-3', [300, 250], 'div-gpt-ad-1594211656305-0').addService(googletag.pubads());
googletag.pubads().enableSingleRequest();
googletag.enableServices();
});
</script>

<div id='div-gpt-ad-1594211656305-0' style='width: 300px; height: 250px;'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1594211656305-0'); });
</script>
</div> </div>
</section>
</section>
<section class="body-copy">
<section class="author noprint">
<figure class="left">
<div class="articleAuthor">
<img src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mNkYAAAAAYAAjCB0C8AAAAASUVORK5CYII=" alt="kamoga" class="cm-media cm-media--loading cm-media--responsive cm-media--loading " title="" data-cm-responsive-media="[{&quot;name&quot;:&quot;landscape_ratio16x9&quot;,&quot;ratioWidth&quot;:16,&quot;ratioHeight&quot;:9,&quot;linksForWidth&quot;:{&quot;200&quot;:&quot;/resource/image/3475714/landscape_ratio16x9/200/112/b2df6ae77b6209ba98168c11770e4e3c/NP/kamoga.jpg&quot;,&quot;300&quot;:&quot;/resource/image/3475714/landscape_ratio16x9/300/168/b2df6ae77b6209ba98168c11770e4e3c/aX/kamoga.jpg&quot;,&quot;400&quot;:&quot;/resource/image/3475714/landscape_ratio16x9/400/225/b2df6ae77b6209ba98168c11770e4e3c/dG/kamoga.jpg&quot;,&quot;1160&quot;:&quot;/resource/image/3475714/landscape_ratio16x9/1160/652/b2df6ae77b6209ba98168c11770e4e3c/Zu/kamoga.jpg&quot;}},{&quot;name&quot;:&quot;portrait_ratio2x3&quot;,&quot;ratioWidth&quot;:2,&quot;ratioHeight&quot;:3,&quot;linksForWidth&quot;:{&quot;200&quot;:&quot;/resource/image/3475714/portrait_ratio2x3/200/300/6decb94e8601b29e314b6f7ddb564165/gV/kamoga.jpg&quot;,&quot;400&quot;:&quot;/resource/image/3475714/portrait_ratio2x3/400/600/6decb94e8601b29e314b6f7ddb564165/vu/kamoga.jpg&quot;,&quot;768&quot;:&quot;/resource/image/3475714/portrait_ratio2x3/768/1152/6decb94e8601b29e314b6f7ddb564165/Om/kamoga.jpg&quot;}},{&quot;name&quot;:&quot;landscape_ratio2x1&quot;,&quot;ratioWidth&quot;:2,&quot;ratioHeight&quot;:1,&quot;linksForWidth&quot;:{&quot;200&quot;:&quot;/resource/image/3475714/landscape_ratio2x1/200/100/f9e3a204936eea2b703a73e20fc7129d/ll/kamoga.jpg&quot;}},{&quot;name&quot;:&quot;landscape_ratio3x2&quot;,&quot;ratioWidth&quot;:3,&quot;ratioHeight&quot;:2,&quot;linksForWidth&quot;:{&quot;300&quot;:&quot;/resource/image/3475714/landscape_ratio3x2/300/200/f7608167c3d73db4280e0c0a5ae84600/AJ/kamoga.jpg&quot;,&quot;400&quot;:&quot;/resource/image/3475714/landscape_ratio3x2/400/267/f7608167c3d73db4280e0c0a5ae84600/VT/kamoga.jpg&quot;,&quot;768&quot;:&quot;/resource/image/3475714/landscape_ratio3x2/768/512/f7608167c3d73db4280e0c0a5ae84600/Jt/kamoga.jpg&quot;}},{&quot;name&quot;:&quot;portrait_ratio1x1&quot;,&quot;ratioWidth&quot;:1,&quot;ratioHeight&quot;:1,&quot;linksForWidth&quot;:{&quot;50&quot;:&quot;/resource/image/3475714/portrait_ratio1x1/50/50/5bf2609e685a519d9c6be7ad7ce0ae40/BD/kamoga.jpg&quot;,&quot;60&quot;:&quot;/resource/image/3475714/portrait_ratio1x1/60/60/5bf2609e685a519d9c6be7ad7ce0ae40/Nk/kamoga.jpg&quot;,&quot;200&quot;:&quot;/resource/image/3475714/portrait_ratio1x1/200/200/5bf2609e685a519d9c6be7ad7ce0ae40/zI/kamoga.jpg&quot;,&quot;400&quot;:&quot;/resource/image/3475714/portrait_ratio1x1/400/400/5bf2609e685a519d9c6be7ad7ce0ae40/Qm/kamoga.jpg&quot;,&quot;768&quot;:&quot;/resource/image/3475714/portrait_ratio1x1/768/768/5bf2609e685a519d9c6be7ad7ce0ae40/zb/kamoga.jpg&quot;}},{&quot;name&quot;:&quot;landscape_ratio4x3&quot;,&quot;ratioWidth&quot;:4,&quot;ratioHeight&quot;:3,&quot;linksForWidth&quot;:{&quot;200&quot;:&quot;/resource/image/3475714/landscape_ratio4x3/200/150/3c99ce0363369bad7787b822db80a391/bX/kamoga.jpg&quot;,&quot;400&quot;:&quot;/resource/image/3475714/landscape_ratio4x3/400/300/3c99ce0363369bad7787b822db80a391/bW/kamoga.jpg&quot;,&quot;768&quot;:&quot;/resource/image/3475714/landscape_ratio4x3/768/576/3c99ce0363369bad7787b822db80a391/ia/kamoga.jpg&quot;}}]">
</div> </figure>
<strong>By JONATHAN KAMOGA</strong>
<div><a href="/tea/author-profiles/jonathan-kamoga-1401674"><span class="author-profile">More by this Author</span></a></div>
</section>
<br />
<p>President Yoweri Museveni’s decision to name Norbert Mao minister for Justice and Constitutional Affairs could deal the opposition a blow in countering his leadership, even though it could calm political waters.</p><p>Mao, 55, a former legislator, is the current leader of the opposition Democratic Party (DP), Uganda’s oldest political party. His appointment on Thursday came a day after his party signed a memorandum of understanding on cooperation with the ruling National Resistance Movement (NRM).</p><p>Museveni announced the development on Wednesday on his official Twitter handle accompanied with a video of the two principals signing the agreement at State House.</p><p>“I met with Democratic Party President Norbert Mao at State House Entebbe. We signed a cooperation agreement between the NRM and the DP. I salute the DP leadership for this gesture of mature, foresighted and constructive politics,” President Museveni said.</p><blockquote class="twitter-tweet" data-partner="tweetdeck"><p lang="en" dir="ltr">I met with Democratic Party President Norbert Mao at State House Entebbe. We signed a cooperation agreement between the NRM and the DP. I salute the DP leadership for this gesture of mature, foresighted and constructive politics. <a href="https://t.co/sPHDMjDeZq">pic.twitter.com/sPHDMjDeZq</a></p>&mdash; Yoweri K Museveni (@KagutaMuseveni) <a href="https://twitter.com/KagutaMuseveni/status/1549780731362250757?ref_src=twsrc%5Etfw">July 20, 2022</a></blockquote>
<script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script><h3>Change of mind</h3> <div id="relatedCoverage" class="article-related-coverage">
<div class="related-coverage-header"><h3>Related</h3></div>
<div class="related-coverage-body">
<ul>
<li><a href="/tea/oped/comment/mao-s-little-black-book-is-coming-lock-up-your-mistresses-and-hide-your-assets-1404634">
<span class="relImage">
<figure>
<div class="relatedTeaser">
<img src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mNkYAAAAAYAAjCB0C8AAAAASUVORK5CYII=" alt="mao" class="cm-media cm-media--loading cm-media--responsive cm-media--loading " title="" data-cm-responsive-media="[{&quot;name&quot;:&quot;landscape_ratio16x9&quot;,&quot;ratioWidth&quot;:16,&quot;ratioHeight&quot;:9,&quot;linksForWidth&quot;:{&quot;200&quot;:&quot;/resource/image/1404636/landscape_ratio16x9/200/112/82bdd3df60aa28d354d5d5f35764f588/PH/mao.jpg&quot;,&quot;300&quot;:&quot;/resource/image/1404636/landscape_ratio16x9/300/168/82bdd3df60aa28d354d5d5f35764f588/zD/mao.jpg&quot;,&quot;400&quot;:&quot;/resource/image/1404636/landscape_ratio16x9/400/225/82bdd3df60aa28d354d5d5f35764f588/mi/mao.jpg&quot;,&quot;1160&quot;:&quot;/resource/image/1404636/landscape_ratio16x9/1160/652/82bdd3df60aa28d354d5d5f35764f588/ki/mao.jpg&quot;}},{&quot;name&quot;:&quot;portrait_ratio2x3&quot;,&quot;ratioWidth&quot;:2,&quot;ratioHeight&quot;:3,&quot;linksForWidth&quot;:{&quot;200&quot;:&quot;/resource/image/1404636/portrait_ratio2x3/200/300/3043f12f0cc7aa990d52ff8f3743c53/uF/mao.jpg&quot;,&quot;400&quot;:&quot;/resource/image/1404636/portrait_ratio2x3/400/600/3043f12f0cc7aa990d52ff8f3743c53/bm/mao.jpg&quot;,&quot;768&quot;:&quot;/resource/image/1404636/portrait_ratio2x3/768/1152/3043f12f0cc7aa990d52ff8f3743c53/VC/mao.jpg&quot;}},{&quot;name&quot;:&quot;landscape_ratio2x1&quot;,&quot;ratioWidth&quot;:2,&quot;ratioHeight&quot;:1,&quot;linksForWidth&quot;:{&quot;200&quot;:&quot;/resource/image/1404636/landscape_ratio2x1/200/100/e1c23e3b2e12aca98cad8cf6c29db92d/Ba/mao.jpg&quot;}},{&quot;name&quot;:&quot;landscape_ratio3x2&quot;,&quot;ratioWidth&quot;:3,&quot;ratioHeight&quot;:2,&quot;linksForWidth&quot;:{&quot;300&quot;:&quot;/resource/image/1404636/landscape_ratio3x2/300/200/3a87fa49267697e5416ebc05d88703d9/Tn/mao.jpg&quot;,&quot;400&quot;:&quot;/resource/image/1404636/landscape_ratio3x2/400/267/3a87fa49267697e5416ebc05d88703d9/uJ/mao.jpg&quot;,&quot;768&quot;:&quot;/resource/image/1404636/landscape_ratio3x2/768/512/3a87fa49267697e5416ebc05d88703d9/vv/mao.jpg&quot;}},{&quot;name&quot;:&quot;portrait_ratio1x1&quot;,&quot;ratioWidth&quot;:1,&quot;ratioHeight&quot;:1,&quot;linksForWidth&quot;:{&quot;50&quot;:&quot;/resource/image/1404636/portrait_ratio1x1/50/50/fe63b53d09a7093fae34ab75f0596d7d/Av/mao.jpg&quot;,&quot;60&quot;:&quot;/resource/image/1404636/portrait_ratio1x1/60/60/fe63b53d09a7093fae34ab75f0596d7d/kA/mao.jpg&quot;,&quot;200&quot;:&quot;/resource/image/1404636/portrait_ratio1x1/200/200/fe63b53d09a7093fae34ab75f0596d7d/Uc/mao.jpg&quot;,&quot;400&quot;:&quot;/resource/image/1404636/portrait_ratio1x1/400/400/fe63b53d09a7093fae34ab75f0596d7d/LS/mao.jpg&quot;,&quot;768&quot;:&quot;/resource/image/1404636/portrait_ratio1x1/768/768/fe63b53d09a7093fae34ab75f0596d7d/aX/mao.jpg&quot;}},{&quot;name&quot;:&quot;landscape_ratio4x3&quot;,&quot;ratioWidth&quot;:4,&quot;ratioHeight&quot;:3,&quot;linksForWidth&quot;:{&quot;200&quot;:&quot;/resource/image/1404636/landscape_ratio4x3/200/150/723763ee020a1f4cd82948a652d0d135/dC/mao.jpg&quot;,&quot;400&quot;:&quot;/resource/image/1404636/landscape_ratio4x3/400/300/723763ee020a1f4cd82948a652d0d135/nJ/mao.jpg&quot;,&quot;768&quot;:&quot;/resource/image/1404636/landscape_ratio4x3/768/576/723763ee020a1f4cd82948a652d0d135/tx/mao.jpg&quot;}}]">
</div> </figure>
</span>
<span class="relText">
Mao’s Little Black Book is coming, hide your assets
</span>
</a></li>
<li><a href="/tea/news/east-africa/questions-swirl-around-select-ugandan-mps-cash-bonanza-3859296">
<span class="relImage">
<figure>
<div class="relatedTeaser">
<img src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mNkYAAAAAYAAjCB0C8AAAAASUVORK5CYII=" alt="Bobi Wine." class="cm-media cm-media--loading cm-media--responsive cm-media--loading " title="" data-cm-responsive-media="[{&quot;name&quot;:&quot;landscape_ratio16x9&quot;,&quot;ratioWidth&quot;:16,&quot;ratioHeight&quot;:9,&quot;linksForWidth&quot;:{&quot;200&quot;:&quot;/resource/image/3859560/landscape_ratio16x9/200/112/6232412baab603923715ed4d2e7e7ef2/cl/bobi-wine.jpg&quot;,&quot;300&quot;:&quot;/resource/image/3859560/landscape_ratio16x9/300/168/6232412baab603923715ed4d2e7e7ef2/Qx/bobi-wine.jpg&quot;,&quot;400&quot;:&quot;/resource/image/3859560/landscape_ratio16x9/400/225/6232412baab603923715ed4d2e7e7ef2/dI/bobi-wine.jpg&quot;,&quot;1160&quot;:&quot;/resource/image/3859560/landscape_ratio16x9/1160/652/6232412baab603923715ed4d2e7e7ef2/jY/bobi-wine.jpg&quot;}},{&quot;name&quot;:&quot;portrait_ratio2x3&quot;,&quot;ratioWidth&quot;:2,&quot;ratioHeight&quot;:3,&quot;linksForWidth&quot;:{&quot;200&quot;:&quot;/resource/image/3859560/portrait_ratio2x3/200/300/495817b8c820ef7a5b3555d33025d431/wP/bobi-wine.jpg&quot;,&quot;400&quot;:&quot;/resource/image/3859560/portrait_ratio2x3/400/600/495817b8c820ef7a5b3555d33025d431/TI/bobi-wine.jpg&quot;,&quot;768&quot;:&quot;/resource/image/3859560/portrait_ratio2x3/768/1152/495817b8c820ef7a5b3555d33025d431/nM/bobi-wine.jpg&quot;}},{&quot;name&quot;:&quot;landscape_ratio2x1&quot;,&quot;ratioWidth&quot;:2,&quot;ratioHeight&quot;:1,&quot;linksForWidth&quot;:{&quot;200&quot;:&quot;/resource/image/3859560/landscape_ratio2x1/200/100/3131173014deff5490dde72722749f04/jR/bobi-wine.jpg&quot;}},{&quot;name&quot;:&quot;landscape_ratio3x2&quot;,&quot;ratioWidth&quot;:3,&quot;ratioHeight&quot;:2,&quot;linksForWidth&quot;:{&quot;300&quot;:&quot;/resource/image/3859560/landscape_ratio3x2/300/200/693bf956516ebcbd57fff6a72ec201e2/tZ/bobi-wine.jpg&quot;,&quot;400&quot;:&quot;/resource/image/3859560/landscape_ratio3x2/400/267/693bf956516ebcbd57fff6a72ec201e2/xn/bobi-wine.jpg&quot;,&quot;768&quot;:&quot;/resource/image/3859560/landscape_ratio3x2/768/512/693bf956516ebcbd57fff6a72ec201e2/oF/bobi-wine.jpg&quot;}},{&quot;name&quot;:&quot;portrait_ratio1x1&quot;,&quot;ratioWidth&quot;:1,&quot;ratioHeight&quot;:1,&quot;linksForWidth&quot;:{&quot;50&quot;:&quot;/resource/image/3859560/portrait_ratio1x1/50/50/1bab8176f34c328e0bb69a93c7f43e3d/NN/bobi-wine.jpg&quot;,&quot;60&quot;:&quot;/resource/image/3859560/portrait_ratio1x1/60/60/1bab8176f34c328e0bb69a93c7f43e3d/cC/bobi-wine.jpg&quot;,&quot;200&quot;:&quot;/resource/image/3859560/portrait_ratio1x1/200/200/1bab8176f34c328e0bb69a93c7f43e3d/dq/bobi-wine.jpg&quot;,&quot;400&quot;:&quot;/resource/image/3859560/portrait_ratio1x1/400/400/1bab8176f34c328e0bb69a93c7f43e3d/XE/bobi-wine.jpg&quot;,&quot;768&quot;:&quot;/resource/image/3859560/portrait_ratio1x1/768/768/1bab8176f34c328e0bb69a93c7f43e3d/Ex/bobi-wine.jpg&quot;}},{&quot;name&quot;:&quot;landscape_ratio4x3&quot;,&quot;ratioWidth&quot;:4,&quot;ratioHeight&quot;:3,&quot;linksForWidth&quot;:{&quot;200&quot;:&quot;/resource/image/3859560/landscape_ratio4x3/200/150/78254bc9ec940e120705cec1371560ba/Na/bobi-wine.jpg&quot;,&quot;400&quot;:&quot;/resource/image/3859560/landscape_ratio4x3/400/300/78254bc9ec940e120705cec1371560ba/JZ/bobi-wine.jpg&quot;,&quot;768&quot;:&quot;/resource/image/3859560/landscape_ratio4x3/768/576/78254bc9ec940e120705cec1371560ba/pp/bobi-wine.jpg&quot;}}]">
</div> </figure>
</span>
<span class="relText">
Questions swirl around select Ugandan MPs’ cash bonanza
</span>
</a></li>
</ul>
</div>
</div>
<section class="ad noprint">
<span class="">Advertisement</span>
<div class="ad">
<script>
window.googletag = window.googletag || {cmd: []};
googletag.cmd.push(function() {
var leaderBoard = googletag.sizeMapping().
addSize([1024, 0], [728, 90]).
addSize([600, 0], [300, 250]).
addSize([800, 0], [728, 90]).
addSize([0, 0], [[320, 50], [300, 75], [300, 100], [300, 50], [300, 250]]).
build();
googletag.defineSlot('/1010816/Z-DN-728x90-inArticleRelated', [[300, 50], [320, 480], [300, 100], [320, 50], [300, 250], [300, 75], [728, 90]], 'div-gpt-ad-1592285737951-0').defineSizeMapping(leaderBoard).addService(googletag.pubads());
googletag.pubads().enableSingleRequest();
googletag.pubads().collapseEmptyDivs();
googletag.enableServices();
});
</script>

<div id='div-gpt-ad-1592285737951-0'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1592285737951-0'); });
</script>
</div> </div>
</section>
<p>Mao said his decision to work with the NRM – which he has for years criticised for its poor record on human rights, governance and rule of law – was a bid to create a better Uganda.</p><p>“Your excellency, you now have the historical opportunity to gather patriots that are scattered all over Uganda. You must look for them wherever they are. They are all in the political parties and in all corners of Uganda. These are things which I believe will be enjoyed most by the unborn children. They may thank you when you're not around. So, we salute the courage you have shown,” Mao said.</p><p>NRM has a similar <a href="https://www.theeastafrican.co.ke/tea/news/east-africa/museveni-akena-deal-makes-a-case-for-besigye-mbabazi-alliance-in-the-hunt-for-votes--1343054" target="_blank" rel="noopener">agreement with the opposition Uganda People’s Congress</a> led by Jimmy Micheal Akena, the son of former president Milton Obote.</p><p><strong>Read: </strong><a href="https://www.theeastafrican.co.ke/tea/news/east-africa/why-museveni-is-now-dining-with-swine-offspring--1350878">Why Museveni is now dining with ‘swine’ offspring</a></p><p>Mr Mao, a lawyer who has led DP for nearly 12 years, has been accused by party members of poor administration, hobnobbing with the NRM and creating factions within the party.</p><p>In the run up to the general election in 2021, 11 MPs subscribing to DP defected to the new National Unity Platform party led by Robert Kyagulanyi aka Bobi Wine.</p><h3>Double speak?</h3><p>Mao joins a growing list of opposition politicians that Museveni has wooed to his side in recent years.</p><p>They include Florence Nakiwala Kiyingi, who was appointed minister for Youth and Child Affairs after losing the Kampala Woman MP seat on the DP ticket.</p><p>Mao had condemned her appointment and announced that his party would not work with her.</p><p>“We have had a very bad experience with those relations. Basing on what happened after the liberation war in 1986 in the gentleman’s agreement where DP members like John Ssebaana Kizito, Paul Kawanga Ssemwogerere joined Museveni and gained nothing, we can’t work with him (Museveni) again,” Mao had said.</p><p>Lewis Rubongoya, the secretary general of the National Unity platform has dismissed Mao as a self-seeker after the appointment to Museveni’s Cabinet.</p><p>“The pretense is over. [It] explains the attacks on NUP (National Unity Platform). Hope this clears the air for those who always ask about "opposition unity" in Uganda,” he said.</p><p>Museveni’s critics have over the years accused him of only allowing a semblance of the opposition to boost his democratic credentials with donors.</p> </section>
</article>
<script type="text/javascript" src="https://theconversation.com/javascripts/lib/content_tracker_hook.js" id="theconversation_tracker_hook" data-counter="https://counter.theconversation.com/content/UNDEFINED/count?distributor=republish-lightbox-advanced" async="async"></script> <section class="ad noprint">
<span class="">Advertisement</span>
<div class="ad">
<script>
window.googletag = window.googletag || {cmd: []};
googletag.cmd.push(function() {
var mobileResize = googletag.sizeMapping().
addSize([1024, 0], [728, 90]).
addSize([600, 0], [300, 250]).
addSize([800, 0], [728, 90]).
addSize([0, 0], [300, 250]).
build();
googletag.defineSlot('/1010816/Z-Dn-728x90-newsarticle', [[300, 250], [728, 90]], 'div-gpt-ad-1591700957341-0').defineSizeMapping(mobileResize).addService(googletag.pubads());
googletag.pubads().enableSingleRequest();
googletag.pubads().collapseEmptyDivs();
googletag.enableServices();
});
</script>

<div id='div-gpt-ad-1591700957341-0'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1591700957341-0'); });
</script>
</div> </div>
</section>
<section class="print-section big-blog noprint" id="headlines">
<header class="clearfix">
<div class="blog-header clearfix">
<h3>In the headlines</h3>
</div>
</header>
<article>
<div class="row">
<div class="five-eight column">
<div class="story-teaser medium-teaser">
<h3> <a href="/tea/science-health/who-triggers-highest-alert-on-monkeypox-3889920">WHO triggers highest alert on monkeypox</a></h3>
<div class="">
<figure class="">
<a href="/tea/science-health/who-triggers-highest-alert-on-monkeypox-3889920">
<div class="mediumTeaserImage">
<img src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mNkYAAAAAYAAjCB0C8AAAAASUVORK5CYII=" alt="WHO Director-General Tedros Adhanom Ghebreyesus." class="cm-media cm-media--loading cm-media--responsive cm-media--loading " title="" data-cm-responsive-media="[{&quot;name&quot;:&quot;landscape_ratio16x9&quot;,&quot;ratioWidth&quot;:16,&quot;ratioHeight&quot;:9,&quot;linksForWidth&quot;:{&quot;200&quot;:&quot;/resource/image/3781734/landscape_ratio16x9/200/112/2aa242d6f3c1ae114ba323857491fad/QE/crisis.jpg&quot;,&quot;300&quot;:&quot;/resource/image/3781734/landscape_ratio16x9/300/168/2aa242d6f3c1ae114ba323857491fad/dc/crisis.jpg&quot;,&quot;400&quot;:&quot;/resource/image/3781734/landscape_ratio16x9/400/225/2aa242d6f3c1ae114ba323857491fad/GT/crisis.jpg&quot;,&quot;1160&quot;:&quot;/resource/image/3781734/landscape_ratio16x9/1160/652/2aa242d6f3c1ae114ba323857491fad/hP/crisis.jpg&quot;}},{&quot;name&quot;:&quot;portrait_ratio2x3&quot;,&quot;ratioWidth&quot;:2,&quot;ratioHeight&quot;:3,&quot;linksForWidth&quot;:{&quot;200&quot;:&quot;/resource/image/3781734/portrait_ratio2x3/200/300/3b84966c703991650e295b25df1b6512/Fx/crisis.jpg&quot;,&quot;400&quot;:&quot;/resource/image/3781734/portrait_ratio2x3/400/600/3b84966c703991650e295b25df1b6512/RG/crisis.jpg&quot;,&quot;768&quot;:&quot;/resource/image/3781734/portrait_ratio2x3/768/1152/3b84966c703991650e295b25df1b6512/Ue/crisis.jpg&quot;}},{&quot;name&quot;:&quot;landscape_ratio2x1&quot;,&quot;ratioWidth&quot;:2,&quot;ratioHeight&quot;:1,&quot;linksForWidth&quot;:{&quot;200&quot;:&quot;/resource/image/3781734/landscape_ratio2x1/200/100/272262ef7e77961fa80e59ba0e8d22bc/bq/crisis.jpg&quot;}},{&quot;name&quot;:&quot;landscape_ratio3x2&quot;,&quot;ratioWidth&quot;:3,&quot;ratioHeight&quot;:2,&quot;linksForWidth&quot;:{&quot;300&quot;:&quot;/resource/image/3781734/landscape_ratio3x2/300/200/fce3393b440a6fd4ed1a9f06098f102b/Dw/crisis.jpg&quot;,&quot;400&quot;:&quot;/resource/image/3781734/landscape_ratio3x2/400/267/fce3393b440a6fd4ed1a9f06098f102b/Te/crisis.jpg&quot;,&quot;768&quot;:&quot;/resource/image/3781734/landscape_ratio3x2/768/512/fce3393b440a6fd4ed1a9f06098f102b/Cc/crisis.jpg&quot;}},{&quot;name&quot;:&quot;portrait_ratio1x1&quot;,&quot;ratioWidth&quot;:1,&quot;ratioHeight&quot;:1,&quot;linksForWidth&quot;:{&quot;50&quot;:&quot;/resource/image/3781734/portrait_ratio1x1/50/50/7a700cabaf510722dbec8628913cc035/aE/crisis.jpg&quot;,&quot;60&quot;:&quot;/resource/image/3781734/portrait_ratio1x1/60/60/7a700cabaf510722dbec8628913cc035/uF/crisis.jpg&quot;,&quot;200&quot;:&quot;/resource/image/3781734/portrait_ratio1x1/200/200/7a700cabaf510722dbec8628913cc035/yh/crisis.jpg&quot;,&quot;400&quot;:&quot;/resource/image/3781734/portrait_ratio1x1/400/400/7a700cabaf510722dbec8628913cc035/Kj/crisis.jpg&quot;,&quot;768&quot;:&quot;/resource/image/3781734/portrait_ratio1x1/768/768/7a700cabaf510722dbec8628913cc035/dY/crisis.jpg&quot;}},{&quot;name&quot;:&quot;landscape_ratio4x3&quot;,&quot;ratioWidth&quot;:4,&quot;ratioHeight&quot;:3,&quot;linksForWidth&quot;:{&quot;200&quot;:&quot;/resource/image/3781734/landscape_ratio4x3/200/150/9e048d8f8abedeccf20ece53f9a270a1/bt/crisis.jpg&quot;,&quot;400&quot;:&quot;/resource/image/3781734/landscape_ratio4x3/400/300/9e048d8f8abedeccf20ece53f9a270a1/RE/crisis.jpg&quot;,&quot;768&quot;:&quot;/resource/image/3781734/landscape_ratio4x3/768/576/9e048d8f8abedeccf20ece53f9a270a1/UI/crisis.jpg&quot;}}]">
</div> </a>
</figure>
<p>
Monkeypox has affected over 15,800 people in 72 countries.</p>
</div>
</div><div class="story-teaser medium-teaser">
<h3> <a href="/tea/news/east-africa/somalia-gets-a-warm-reception-in-its-quest-join-the-eac-3889434">Mohamud: Why Somalia cannot wait to join EAC </a></h3>
<div class="">
<figure class="">
<a href="/tea/news/east-africa/somalia-gets-a-warm-reception-in-its-quest-join-the-eac-3889434">
<div class="mediumTeaserImage">
<img src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mNkYAAAAAYAAjCB0C8AAAAASUVORK5CYII=" alt="mohamud" class="cm-media cm-media--loading cm-media--responsive cm-media--loading " title="" data-cm-responsive-media="[{&quot;name&quot;:&quot;landscape_ratio16x9&quot;,&quot;ratioWidth&quot;:16,&quot;ratioHeight&quot;:9,&quot;linksForWidth&quot;:{&quot;200&quot;:&quot;/resource/image/3889594/landscape_ratio16x9/200/112/e383b56ed0b7eb5282c836711d6ef281/fD/mohamud.jpg&quot;,&quot;300&quot;:&quot;/resource/image/3889594/landscape_ratio16x9/300/168/e383b56ed0b7eb5282c836711d6ef281/jv/mohamud.jpg&quot;,&quot;400&quot;:&quot;/resource/image/3889594/landscape_ratio16x9/400/225/e383b56ed0b7eb5282c836711d6ef281/na/mohamud.jpg&quot;,&quot;1160&quot;:&quot;/resource/image/3889594/landscape_ratio16x9/1160/652/e383b56ed0b7eb5282c836711d6ef281/xa/mohamud.jpg&quot;}},{&quot;name&quot;:&quot;portrait_ratio2x3&quot;,&quot;ratioWidth&quot;:2,&quot;ratioHeight&quot;:3,&quot;linksForWidth&quot;:{&quot;200&quot;:&quot;/resource/image/3889594/portrait_ratio2x3/200/300/5ecdf756c45282b6ee86b21a69e63731/ed/mohamud.jpg&quot;,&quot;400&quot;:&quot;/resource/image/3889594/portrait_ratio2x3/400/600/5ecdf756c45282b6ee86b21a69e63731/MK/mohamud.jpg&quot;,&quot;768&quot;:&quot;/resource/image/3889594/portrait_ratio2x3/768/1152/5ecdf756c45282b6ee86b21a69e63731/yG/mohamud.jpg&quot;}},{&quot;name&quot;:&quot;landscape_ratio2x1&quot;,&quot;ratioWidth&quot;:2,&quot;ratioHeight&quot;:1,&quot;linksForWidth&quot;:{&quot;200&quot;:&quot;/resource/image/3889594/landscape_ratio2x1/200/100/cf924c578a201448b67c4e87060ab66b/Yc/mohamud.jpg&quot;}},{&quot;name&quot;:&quot;landscape_ratio3x2&quot;,&quot;ratioWidth&quot;:3,&quot;ratioHeight&quot;:2,&quot;linksForWidth&quot;:{&quot;300&quot;:&quot;/resource/image/3889594/landscape_ratio3x2/300/200/8ef8db1a99cd33f0642e78a984eccee3/sy/mohamud.jpg&quot;,&quot;400&quot;:&quot;/resource/image/3889594/landscape_ratio3x2/400/267/8ef8db1a99cd33f0642e78a984eccee3/ow/mohamud.jpg&quot;,&quot;768&quot;:&quot;/resource/image/3889594/landscape_ratio3x2/768/512/8ef8db1a99cd33f0642e78a984eccee3/Gy/mohamud.jpg&quot;}},{&quot;name&quot;:&quot;portrait_ratio1x1&quot;,&quot;ratioWidth&quot;:1,&quot;ratioHeight&quot;:1,&quot;linksForWidth&quot;:{&quot;50&quot;:&quot;/resource/image/3889594/portrait_ratio1x1/50/50/383651a8090d441934cb378e281058d0/mi/mohamud.jpg&quot;,&quot;60&quot;:&quot;/resource/image/3889594/portrait_ratio1x1/60/60/383651a8090d441934cb378e281058d0/cr/mohamud.jpg&quot;,&quot;200&quot;:&quot;/resource/image/3889594/portrait_ratio1x1/200/200/383651a8090d441934cb378e281058d0/fL/mohamud.jpg&quot;,&quot;400&quot;:&quot;/resource/image/3889594/portrait_ratio1x1/400/400/383651a8090d441934cb378e281058d0/bN/mohamud.jpg&quot;,&quot;768&quot;:&quot;/resource/image/3889594/portrait_ratio1x1/768/768/383651a8090d441934cb378e281058d0/Gi/mohamud.jpg&quot;}},{&quot;name&quot;:&quot;landscape_ratio4x3&quot;,&quot;ratioWidth&quot;:4,&quot;ratioHeight&quot;:3,&quot;linksForWidth&quot;:{&quot;200&quot;:&quot;/resource/image/3889594/landscape_ratio4x3/200/150/1b1a731e07d7b8be62dd1ab6c15e7127/ki/mohamud.jpg&quot;,&quot;400&quot;:&quot;/resource/image/3889594/landscape_ratio4x3/400/300/1b1a731e07d7b8be62dd1ab6c15e7127/gh/mohamud.jpg&quot;,&quot;768&quot;:&quot;/resource/image/3889594/landscape_ratio4x3/768/576/1b1a731e07d7b8be62dd1ab6c15e7127/gh/mohamud.jpg&quot;}}]">
</div> </a>
</figure>
<p>
Bloc leaders agreed Friday to fasttrack the verification process as new President Mohamud pursues a cooperative foreign policy with neighbours.</p>
</div>
</div> </div>
<div class="three-eight column">
<div class="small-story-list">
<h5 class="small-story-list"><a href="/tea/magazine/uganda-50-years-after-the-expulsion-of-indians-3888918">Uganda reckons with Indian exodus 50 years on </a></h5><h5 class="small-story-list"><a href="/tea/news/east-africa/eac-leaders-laud-uhuru-kenyatta-3889498">Uhuru Kenyatta&#39;s swan song in Arusha</a></h5><h5 class="small-story-list"><a href="/tea/business/museveni-electric-vehicles-will-help-counter-oil-supply-shocks-3889634">Museveni: Electric cars will help counter oil supply shocks</a></h5><h5 class="small-story-list"><a href="/tea/magazine/new-look-heritage-sites-for-tanzania-3888934">New look heritage sites for Tanzania</a></h5><h5 class="small-story-list"><a href="/tea/magazine/kigali-explores-eco-tourism-at-nyandungu-green-park--3888938">Kigali explores eco-tourism at Nyandungu green park</a></h5> </div>
</div>
</div>
</article>
</section>
</article>
<aside class="aside column noprint">
<div class="row">
<div class="sidebar-item">
<script>
window.googletag = window.googletag || {cmd: []};
googletag.cmd.push(function() {
googletag.defineSlot('/1010816/EA-300X250-Article0-1', [300, 250], 'div-gpt-ad-1594211421577-0').addService(googletag.pubads());
googletag.pubads().enableSingleRequest();
googletag.enableServices();
});
</script>

<div id='div-gpt-ad-1594211421577-0' class='ad'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1594211421577-0'); });
</script>
</div> </div>
<div class="sidebar-item">
<div class="tab-header">
<div class="tab">
<span class="icon most-read-icon"></span>EAC Summit</div>
</div>
<div class="tab-body">
<li class="most-popular-item">
<a href="/tea/oped/editorial/somalia-wants-in-but-eac-should-rethink-expansion-3889822">
<span class="most-number">1</span>
<span class="most-headline"><span>Editorial</span> EDITORIAL: Somalia wants in but EAC should rethink expansion</span>
</a>
</li>
<li class="most-popular-item">
<a href="/tea/business/eac-common-market-scorecard-falls-short-3889534">
<span class="most-number">2</span>
<span class="most-headline"><span>Business</span> EAC Common Market scorecard falls short</span>
</a>
</li>
<li class="most-popular-item">
<a href="/tea/news/east-africa/eac-leaders-laud-uhuru-kenyatta-3889498">
<span class="most-number">3</span>
<span class="most-headline"><span>East Africa</span> Uhuru Kenyatta&#39;s swan song in Arusha</span>
</a>
</li>
<li class="most-popular-item">
<a href="/tea/news/east-africa/somalia-gets-a-warm-reception-in-its-quest-join-the-eac-3889434">
<span class="most-number">4</span>
<span class="most-headline"><span>East Africa</span> Mohamud: Why Somalia cannot wait to join EAC </span>
</a>
</li>
<li class="most-popular-item">
<a href="/tea/news/east-africa/eac-summit-uhuru-samia-launch-42km-arusha-voi-road-3888346">
<span class="most-number">5</span>
<span class="most-headline"><span>East Africa</span> Uhuru, Samia launch 42km Arusha bypass</span>
</a>
</li>
</div> </div>
<div class="sidebar-item">
<div class="tab-header">
<div class="tab">
<span class="icon most-read-icon"></span>Latest</div>
</div>
<div class="tab-body">
<li class="most-popular-item">
<a href="/tea/business/afdb-arm-releases-5-4-million-for-somalia-food-security-3889930">
<span class="most-number">1</span>
<span class="most-headline"><span>Business</span> AfDB arm releases $5.4 million for Somalia food security </span>
</a>
</li>
<li class="most-popular-item">
<a href="/tea/science-health/who-triggers-highest-alert-on-monkeypox-3889920">
<span class="most-number">2</span>
<span class="most-headline"><span>Science &amp; Health</span> WHO triggers highest alert on monkeypox</span>
</a>
</li>
<li class="most-popular-item">
<a href="/tea/oped/comment/on-omanyala-debate-we-can-do-much-better-3889828">
<span class="most-number">3</span>
<span class="most-headline"><span>Comment</span> NGUGI: On Omanyala, debate, we can do much better</span>
</a>
</li>
<li class="most-popular-item">
<a href="/tea/oped/editorial/somalia-wants-in-but-eac-should-rethink-expansion-3889822">
<span class="most-number">4</span>
<span class="most-headline"><span>Editorial</span> EDITORIAL: Somalia wants in but EAC should rethink expansion</span>
</a>
</li>
<li class="most-popular-item">
<a href="/tea/news/east-africa/election-observers-arrive-in-kenya-3889636">
<span class="most-number">5</span>
<span class="most-headline"><span>East Africa</span> Poll observers arrive in Kenya as Ruto, Raila trade accusations</span>
</a>
</li>
<li class="most-popular-item">
<a href="/tea/news/east-africa/uganda-oldest-opposition-party-agrees-new-deal-ruling-nrm-3889630">
<span class="most-number">6</span>
<span class="most-headline"><span>East Africa</span> Another opposition leader joins Uganda government</span>
</a>
</li>
<li class="most-popular-item">
<a href="/tea/news/rest-of-africa/post-election-victims-forgotten-in-abidjan-3889624">
<span class="most-number">7</span>
<span class="most-headline"><span>Rest of Africa</span> Post-election victims ‘forgotten’ in Abidjan</span>
</a>
</li>
<li class="most-popular-item">
<a href="/tea/news/rest-of-africa/tribal-clashes-pose-fresh-headache-in-sudan-3889620">
<span class="most-number">8</span>
<span class="most-headline"><span>Rest of Africa</span> Tribal clashes pose fresh headache in Sudan</span>
</a>
</li>
<li class="most-popular-item">
<a href="/tea/news/rest-of-africa/defining-moment-in-chad-as-transition-period-gives-way-3889618">
<span class="most-number">9</span>
<span class="most-headline"><span>Rest of Africa</span> Defining moment in Chad as transition period gives way</span>
</a>
</li>
</div> </div>
<div class="sidebar-item">
<script>
window.googletag = window.googletag || {cmd: []};
googletag.cmd.push(function() {
googletag.defineSlot('/1010816/EA-300X250-Article-2', [300, 250], 'div-gpt-ad-1594211537827-0').addService(googletag.pubads());
googletag.pubads().enableSingleRequest();
googletag.enableServices();
});
</script>

<div id='div-gpt-ad-1594211537827-0' class='ad'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1594211537827-0'); });
</script>
</div> </div>
<div class="sidebar-item">
<section class="ad noprint">
<span class="">Advertisement</span>
<div class="ad">
<ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-0846142691248784" data-ad-slot="7537505707"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script> </div> </section> </div>
</div>
</aside>
</div>
</div>
<script type="text/javascript">
/* CONFIGURATION START */
var _ain = {
id: "1910",
postid: "new-3889630",
maincontent: "h2, #photo_article_caption, section.summary, section.body-copy",
title: "Uganda&#39;s oldest opposition party agrees to a new deal ruling NRM",
pubdate: "2022-07-23 04:45:00",
authors: "JONATHAN KAMOGA",
sections: "East Africa",
tags: "Uganda, Politics, norbert mao",
comments: "",
access_level: "free",
reader_type: "anonymous"
};
/* CONFIGURATION END */
(function(d,s){var sf=d.createElement(s);sf.type='text/javascript';sf.async=!0;sf.src=(('https:'==d.location.protocol)?'https://d7d3cf2e81d293050033-3dfc0615b0fd7b49143049256703bfce.ssl.cf1.rackcdn.com':'http://t.contentinsights.com')+'/stf.js';var t=d.getElementsByTagName(s)[0];t.parentNode.insertBefore(sf,t)})(document,'script')
</script>
<script>
dataLayer = [{
'site': 'theeastafrican.co.ke',
'section': 'East Africa',
'pageTitle': 'Uganda&#39;s oldest opposition party agrees to a new deal ruling NRM',
'author': 'JONATHAN KAMOGA',
'keywords': 'Uganda, Politics, norbert mao'
}];
</script> </section>
</article>
<footer class="wrapper page-footer" id="page-footer">
<div class="menu-holder menu-holder-footer noprint">
<nav class="menu-vertical footer-section" role="navigation">
<header>
<a href="/tea/news" title="News">
<h3 class="footer-section-heading">News</h3>
</a>
</header>
<a href="/tea/news/east-africa" title="East Africa">East Africa</a>
<a href="/tea/news/rest-of-africa" title="Rest of Africa">Rest of Africa</a>
<a href="/tea/news/world" title="World">World</a>
</nav>
<nav class="menu-vertical footer-section" role="navigation">
<header>
<a href="/tea/business" title="Business">
<h3 class="footer-section-heading">Business</h3>
</a>
</header>
</nav>
<nav class="menu-vertical footer-section" role="navigation">
<header>
<a href="/tea/oped" title="Opinion">
<h3 class="footer-section-heading">Opinion</h3>
</a>
</header>
</nav>
<nav class="menu-vertical footer-section" role="navigation">
<header>
<a href="/tea/science-health" title="Science &amp; Health">
<h3 class="footer-section-heading">Science &amp; Health</h3>
</a>
</header>
</nav>
<nav class="menu-vertical footer-section" role="navigation">
<header>
<a href="/tea/magazine" title="Magazine">
<h3 class="footer-section-heading">Magazine</h3>
</a>
</header>
</nav>
<nav class="menu-vertical footer-section" role="navigation">
<header>
<a href="/tea/sports" title="Sports">
<h3 class="footer-section-heading">Sports</h3>
</a>
</header>
</nav>
<nav class="menu-vertical footer-section" role="navigation">
<header>
<a href="/tea/rest-of-africa" title="Rest of Africa">
<h3 class="footer-section-heading">Rest of Africa</h3>
</a>
</header>
</nav>
<nav class="menu-vertical footer-section" role="navigation">
<header>
<a href="/tea/kusi-ideas" title="KUSI IDEAS">
<h3 class="footer-section-heading">KUSI IDEAS</h3>
</a>
</header>
</nav>
</div>
<footer id="dnFooter">
<div class="dnFooter-row noprint">
<div class="dnFooter-col-sm-3">
<h5></h5>
<h5></h5>
<a href="/tea">
<img src="/resource/crblob/1830002/4d4ba1f86b20e22d593b250208bb3581/amp-logo-png-data.png" alt="The East African" class="logo">
</a>
</div>
<div class="dnFooter-col-sm-2">
<h5>Apps</h5>
<ul>
<li><a href="https://play.google.com/store/apps/developer?id=Nation%20Media%20Group&amp;amp;hl=en&amp;amp;pcampaignid=MKT-Other-global-all-co-prtnr-py-PartBadge-Mar2515-1" target="_blank"><img alt="Play Store" src="/resource/crblob/654084/50e4f00026394f5a265aaf340a5d0a57/google-play-badge-png-data.png"></a></li><br>
<li><a href="https://itunes.apple.com/us/developer/nation-media-group-ltd/id771736086" target="_blank"><img src="/resource/crblob/654060/de9cff10d1c98ad9ce9274954e2fbc20/appstoreicon-svg-data.svg" alt="App Store" class="logo"></a></li>
</ul>
</div>
<div class="dnFooter-col-sm-2">
<h5>Information</h5>
<ul>
<li><a href="https://nation.africa/kenya/contact-us-294088" target="_blank" title="Contact Us">Contact Us</a></li>
<li><a href="https://nation.africa/kenya/frequently-asked-questions-303716" target="_blank" title="Frequently asked questions">Frequently asked questions</a></li>
<li><a href="https://nation.africa/kenya/nmg-privacy-policy-303724" target="_blank" title="NMG Privacy Policy">NMG Privacy Policy</a></li>
<li><a href="https://nation.africa/kenya/terms-of-use-303726" target="_blank" title="Terms of use">Terms of use</a></li>
<li><a href="https://nation.africa/kenya/terms-and-conditions" target="_blank" title="Terms and Conditions of Use">Terms and Conditions of Use</a></li>
<li><a href="https://nation.africa/kenya/our-blog-rules-549010" target="_blank" title="Our Blog Rules">Our Blog Rules</a></li>
</ul>
</div>
<div class="dnFooter-col-sm-2">
<h5>NMG Sites</h5>
<ul>
<li><a href="https://epaper.nation.africa" target="_blank" title="Nation ePaper">Nation ePaper</a></li>
<li><a href="http://www.businessdailyafrica.com/" target="_blank" title="Business Daily">Business Daily</a></li>
<li><a href="https://www.ntvkenya.co.ke" target="_blank" title="NTV">NTV</a></li>
<li><a href="http://www.ntv.co.ug/" target="_blank" title="NTV Uganda">NTV Uganda</a></li>
<li><a href="http://www.monitor.co.ug/" target="_blank" title="Daily Monitor">Daily Monitor</a></li>
<li><a href="http://www.thecitizen.co.tz/" target="_blank" title="The Citizen">The Citizen</a></li>
<li><a href="https://www.theeastafrican.co.ke/" target="_blank" title="The Eastafrican">The Eastafrican</a></li>
<li><a href="http://www.nationmedia.com/" target="_blank" title="Nation Media Group">Nation Media Group</a></li>
</ul>
</div>
<div class="dnFooter-col-sm-3">
<h5>Follow us</h5>
<div class="social-networks">
<a href="https://www.facebook.com/TheEastAfrican" target="_blank">
<i class="fa fa-facebook" aria-hidden="true"></i>
</a>
<a href="https://www.instagram.com/The_EastAfrican" target="_blank">
<i class="fa fa-instagram" aria-hidden="true"></i>
</a>
<a href="https://twitter.com/The_EastAfrican" target="_blank">
<i class="fa fa-twitter" aria-hidden="true"></i>
</a>
<a href="https://www.youtube.com/channel/UCjIeyvMe_cmyRrVyNvsyszQ" target="_blank">
<i class="fa fa-youtube" aria-hidden="true"></i>
</a>
<a href="https://t.me/theeastafrican" target="_blank">
<i class="fa fa-telegram" aria-hidden="true"></i>
</a>
<a href="/service/rss/tea/1289208/feed.rss" target="_blank">
<i class="fa fa-rss-square" aria-hidden="true"></i>
</a>
<h1 style="font-size: 0px; margin: 0px;">The East African</h1>
</div>
</div>
</footer>
</footer><noscript class="cm-javascript">
Please enable JavaScript to use this website.
</noscript>
<script type='text/javascript' src='//www.youtube.com/iframe_api'></script>
<script type='text/javascript'>
(function() {
var _sf_async_config = window._sf_async_config = (window._sf_async_config || {});
/** CONFIGURATION START **/
_sf_async_config.uid = 63208;
_sf_async_config.domain = 'theeastafrican.co.ke';
_sf_async_config.flickerControl = false;
_sf_async_config.useCanonical = true;
_sf_async_config.useCanonicalDomain = true;
_sf_async_config.sections = 'News,News - East Africa';
_sf_async_config.authors ='JONATHAN KAMOGA';
/** CONFIGURATION END **/
function loadChartbeat() {
var e = document.createElement('script');
var n = document.getElementsByTagName('script')[0];
e.type = 'text/javascript';
e.async = true;
e.src = '//static.chartbeat.com/js/chartbeat_video.js';
n.parentNode.insertBefore(e, n);
}
/** TELL CHARTBEAT TO AUTODETECT YOUTUBE VIDEOS **/
var _cbv = window._cbv || (window._cbv = []);
_cbv.push(['autoDetectYouTubeIframes']);
loadChartbeat();
})();
</script>
<script async src="//static.chartbeat.com/js/chartbeat_mab.js"></script>
<script>window.tentacles = {apiToken: 'duw3gbl8t40rhv3p6xsa5f9xlv3xe161'};</script>
<script async src="https://tentacles.smartocto.com/ten/tentacle.js"></script> <script type="text/javascript">
window._taboola = window._taboola || [];
_taboola.push({flush: true});
</script>
<script src="/resource/themes/east-african/js/commons-654256-2.js"></script><script src="/resource/themes/east-african/js/east-african-654258-7.js"></script>
<script>window.googletag=window.googletag ||{cmd: []}; googletag.cmd.push(function(){googletag.defineSlot('/1010816/TEA-1x1', [1, 1], 'div-gpt-ad-1634797092980-0').addService(googletag.pubads()); googletag.pubads().enableSingleRequest(); googletag.pubads().collapseEmptyDivs(); googletag.enableServices();});</script><div id='div-gpt-ad-1634797092980-0'> <script>googletag.cmd.push(function(){googletag.display('div-gpt-ad-1634797092980-0');}); </script></div><script>(function(){window['__CF$cv$params']={r:'72f5d5885d4881db',m:'EHYznjswokspXEFEpwplIDokDFCUHrho80pwIIKpEwQ-1658594177-0-Adz7SolbENusUhO1i+G0M6D9EMX9XR5f14EJGWHyVgGQaiKo3TTNxJ/PMCZhMTdtgybmqV5D4Zzb/cqCNzmkkHbeWVrMbIKZXb/ykk2h+zCq5UIoN/mV7N5Q0TO7D3lU5CW0bCoWy4orlAgvNf9n9VIJ1aPt/x9YxAtbdKxBwj/g7Y263Of63Dljq98YKM/aJMCDZ1SItcJCGIk2cDAeGwFnc176N3HYStB9HZKR+r2k',s:[0x41cd0ba8c4,0x9e79332498],}})();</script></body></html>
