<!DOCTYPE html>
<!--[if lt IE 7]><html lang="en" class="no-js lt-ie9 lt-ie8 lt-ie7" prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb# article: http://ogp.me/ns/article# video: http://ogp.me/ns/video#
profile: http://ogp.me/ns/profile#"><![endif]-->
<!--[if IE 7]><html lang="en" class="no-js lt-ie9 lt-ie8" prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb# article: http://ogp.me/ns/article# video: http://ogp.me/ns/video#
profile: http://ogp.me/ns/profile#"><![endif]-->
<!--[if IE 8]><html lang="en" class="no-js lt-ie9" prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb# article: http://ogp.me/ns/article# video: http://ogp.me/ns/video#
profile: http://ogp.me/ns/profile#"><![endif]-->
<!--[if IE 9]><html lang="en" class="no-js ie9" prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb# article: http://ogp.me/ns/article# video: http://ogp.me/ns/video#
profile: http://ogp.me/ns/profile#" ><![endif]-->
<!--[if gt IE 8]><!--><html class="no-js" lang="en" dir="ltr">
<head>

<script src="/cdn-cgi/apps/head/T0y3J73fk_VKhzvXxiTdNq90xcU.js"></script><script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-KBT24PQ');</script>

<meta charset="UTF-8">
<link rel="apple-touch-icon" sizes="180x180" href="/resource/crblob/654062/401e0e1f2272bebbbcd23456403002c4/apple-touch-icon-png-data.png">
<link rel="icon" type="image/png" sizes="32x32" href="/resource/crblob/654080/663580258f749228316ee276e0f3cd6c/favicon-32x32-png-data.png">
<link rel="icon" type="image/png" sizes="16x16" href="/resource/crblob/654078/daa211aeb0ce3157f0075e45c26364bf/favicon-16x16-png-data.png">
<link rel="manifest" href="/site.webmanifest">
<link rel="mask-icon" href="/resource/crblob/654108/050c2c369f7ecebd815fb78f4057e9af/safari-pinned-tab-svg-data.svg" color="#5bbad5">
<link rel="shortcut icon" type="image/x-icon" href="/resource/crblob/654082/6813c1d688e9fadd7b8f7189a6e5179f/favicon-ico-data.ico">
<meta name="msapplication-TileColor" content="#da532c">
<title>9 years later: Lessons from the Westgate terror attack - The East African</title>
<meta name="keywords" content="westgate attack,terror attack,shabaab,dusit attack,nairobi,kenya,somalia,kakuma refugee camp,eastleigh">
<meta name="viewport" content="width=device-width, initial-scale=1">
<meta name="robots" content="index, follow">
<meta name="viewport" content="width=device-width,initial-scale=1.0,user-scalable=0">
<script type="application/ld+json">
{
"@context": "https://schema.org",
"@type": "NewsArticle",
"mainEntityOfPage": {
"@type": "WebPage",
"@id": "https://www.theeastafrican.co.ke/tea/news/east-africa/lessons-from-the-westgate-terror-attack-3959376"
},
"name": "9 years later: Lessons from the Westgate terror attack ",
"headline": "9 years later: Lessons from the Westgate terror attack ",
"description": "<p>Al Shabaab planned the attack for months, coordinating between planners in Somalia, Nairobi and Kakuma refugee camp.<\/p>",
"image": {"@type": "ImageObject", "url": "https://www.theeastafrican.co.ke/resource/blob/3959378/69ff5d4ecd229ed30977cdb2916ffa68/terror-data.jpg", "height": 391, "width": 696 },
"datePublished": "2022-09-23T11:30:00Z",
"dateModified": "2022-09-23T12:14:46Z",
"author": [
{ "@type": "Person",
"name": "MARY WAMBUI",
"url": "https://www.theeastafrican.co.ke/tea/author-profiles/mary-wambui-1420398"
}
],
"publisher": {
"@type": "Organization",
"name": "The East African",
"logo": {
"@type": "ImageObject",
"url": "https://www.theeastafrican.co.ke/resource/crblob/654080/663580258f749228316ee276e0f3cd6c/favicon-32x32-png-data.png",
"width":40,
"height":29
}
}
}
</script>
<script type="application/ld+json">
{
"@context": "http://schema.org",
"@type": "BreadcrumbList",
"itemListElement": [
{
"@type": "ListItem",
"position": 1,
"name": "Home",
"item": "https://www.theeastafrican.co.ke/tea"
}
,
{
"@type": "ListItem",
"position": 2,
"name": "News",
"item": "https://www.theeastafrican.co.ke/tea/news"
}
,
{
"@type": "ListItem",
"position": 3,
"name": "East Africa",
"item": "https://www.theeastafrican.co.ke/tea/news/east-africa"
}
]
}
</script>
<meta name="description" content="
Al Shabaab planned the attack for months, coordinating between planners in Somalia, Nairobi and Kakuma refugee camp.">
<meta property="og:site_name" content="The East African" />
<meta property="og:type" content="article" />
<meta property="fb:app_id" content="174023979648743" />
<meta property="og:title" content="9 years later: Lessons from the Westgate terror attack " />
<meta property="og:url" content="https://www.theeastafrican.co.ke/tea/news/east-africa/lessons-from-the-westgate-terror-attack-3959376" />
<meta property="og:description" content="
Al Shabaab planned the attack for months, coordinating between planners in Somalia, Nairobi and Kakuma refugee camp." />
<meta property="og:locale" content="en" />
<meta property="og:locale:alternate" content="en_US" />
<meta property="og:article:published_time" content="2022-09-23 15:14:46" />
<meta property="og:image" content="https://www.theeastafrican.co.ke/resource/blob/3959378/69ff5d4ecd229ed30977cdb2916ffa68/terror-data.jpg">
<meta name="twitter:card" content="summary_large_image">
<meta name="twitter:site" content="@The_EastAfrican">
<meta name="twitter:title" content="9 years later: Lessons from the Westgate terror attack ">
<meta name="twitter:description" content="
Al Shabaab planned the attack for months, coordinating between planners in Somalia, Nairobi and Kakuma refugee camp.">
<meta name="twitter:image" content="https://www.theeastafrican.co.ke/resource/blob/3959378/69ff5d4ecd229ed30977cdb2916ffa68/terror-data.jpg"> <meta charset="utf-8">
<link rel="canonical" href="https://www.theeastafrican.co.ke/tea/news/east-africa/lessons-from-the-westgate-terror-attack-3959376">
<meta name="google-site-verification" content="7PI23eF83yLrptihU4-C11bEaznAQl8mts5BfCS1W2U" />
<script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>
<script>
var googletag = googletag || {};
googletag.cmd = googletag.cmd || [];
</script>
<script>document.documentElement.className = document.documentElement.className.replace(/no-js/g, 'js');</script>
<link href="//cdnjs.cloudflare.com/ajax/libs/font-awesome/4.7.0/css/font-awesome.min.css" rel="stylesheet">
<link rel="amphtml" href="https://www.theeastafrican.co.ke/tea/news/east-africa/lessons-from-the-westgate-terror-attack-3959376?view=htmlamp">
<script type="text/javascript">
window._taboola = window._taboola || [];
_taboola.push({article:'auto'});
!function (e, f, u, i) {
if (!document.getElementById(i)){
e.async = 1;
e.src = u;
e.id = i;
f.parentNode.insertBefore(e, f);
}
}(document.createElement('script'),
document.getElementsByTagName('script')[0],
'//cdn.taboola.com/libtrc/nationmediagroup-dailynation/loader.js',
'tb_loader_script');
if(window.performance && typeof window.performance.mark == 'function')
{window.performance.mark('tbl_ic');}
</script>
<link href="/resource/themes/east-african/css/east-african-654262-146.css" rel="stylesheet"> <script async src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
</head><body id="top" style="zoom:1;">

<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-KBT24PQ"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>

<nav class="navbar navbar-default full-width">
<div class="container justify-content-between justify-content-md-start">
<div class="navbar-header">
<a href="/tea" class="logo"></a>
</div>
<ul id="panel" class="nav navbar-nav d-md-none">
<li><a href="/tea/news">News</a></li>
<li><a href="/tea/business">Business</a></li>
<li><a href="/tea/oped">Opinion</a></li>
<li><a href="/tea/science-health">Science &amp; Health</a></li>
<li><a href="/tea/magazine">Magazine</a></li>
<li><a href="/tea/sports">Sports</a></li>
<li><a href="/tea/rest-of-africa">Rest of Africa</a></li>
<li><a href="/tea/kusi-ideas">KUSI IDEAS</a></li>
</ul>
<ul class="nav navbar-nav d-none d-md-block pl-lg-3">
<li>
<a href="/tea/news">News</a>
<div class="mega-menu">
<div class="row no-gutters">
<div class="col-3">
<a href="/tea/news/east-africa">East Africa</a>
<a href="/tea/news/rest-of-africa">Rest of Africa</a>
<a href="/tea/news/world">World</a>
</div>
<div class="col-8 offset-1">
<h4>Latest News</h4>
<div class="row no-gutters">
<div class="col-6">
<div class="story-teaser tiny-teaser">
<a href="/tea/news/east-africa/lessons-from-the-westgate-terror-attack-3959376"><i class="fa fa-caret-right" aria-hidden="true"></i> 9 years later: Lessons from the Westgate terror attack </a>
</div>
<div class="story-teaser tiny-teaser">
<a href="/tea/news/east-africa/uganda-limits-gatherings-curb-ebola-spread-3959052"><i class="fa fa-caret-right" aria-hidden="true"></i> Uganda closes clubs, limits gatherings to curb Ebola spread</a>
</div>
</div>
<div class="col-6">
<div class="story-teaser tiny-teaser">
<a href="/tea/news/east-africa/tanzania-alert-ebola-after-uganda-outbreak-3958868"><i class="fa fa-caret-right" aria-hidden="true"></i> Tanzania to screen for Ebola after Uganda outbreak</a>
</div>
<div class="story-teaser tiny-teaser">
<a href="/tea/news/east-africa/human-trafficking-victims-rescued-laos-3958888"><i class="fa fa-caret-right" aria-hidden="true"></i> 22 Kenyans rescued from human traffickers in Laos </a>
</div>
</div>
</div>
</div> </div>
</div>
</li>
<li>
<a href="/tea/business">Business</a>
<div class="mega-menu">
<div class="row no-gutters">
<div class="col-3">
</div>
<div class="col-8 offset-1">
<h4>Latest Business</h4>
<div class="row no-gutters">
<div class="col-6">
<div class="story-teaser tiny-teaser">
<a href="/tea/business/saudi-remittances-double-3959522"><i class="fa fa-caret-right" aria-hidden="true"></i> Saudi remittances to Kenya double to $187m amid maids abuse</a>
</div>
<div class="story-teaser tiny-teaser">
<a href="/tea/business/nigerians-sue-over-cash-frozen-in-safaricom-banks-3959016"><i class="fa fa-caret-right" aria-hidden="true"></i> Nigerian investors sue over $11m Flutterwave cash frozen in Kenya</a>
</div>
</div>
<div class="col-6">
<div class="story-teaser tiny-teaser">
<a href="/tea/business/kenya-ruto-appeals-to-world-bank-imf-g20-africa-debt-relief-3958012"><i class="fa fa-caret-right" aria-hidden="true"></i> Kenya&#39;s Ruto appeals to World Bank, IMF, G20 for Africa debt relief</a>
</div>
<div class="story-teaser tiny-teaser">
<a href="/tea/business/east-africa-exporters-brace-for-impact-as-suez-canal-tolls-rise-3957464"><i class="fa fa-caret-right" aria-hidden="true"></i> East Africa exporters brace for impact as Suez Canal tolls rise</a>
</div>
</div>
</div>
</div> </div>
</div>
</li>
<li>
<a href="/tea/oped">Opinion</a>
<div class="mega-menu">
<div class="row no-gutters">
<div class="col-3">
</div>
<div class="col-8 offset-1">
<h4>Latest Opinion</h4>
<div class="row no-gutters">
<div class="col-6">
<div class="story-teaser tiny-teaser">
<a href="/tea/oped/comment/eac-presidents-retire-young-keep-them-busy-tap-their-knowledge-3951652"><i class="fa fa-caret-right" aria-hidden="true"></i> EAC presidents retire young, keep them busy and tap their knowledge</a>
</div>
<div class="story-teaser tiny-teaser">
<a href="/tea/oped/comment/uhuru-kenyatta-legacy-would-have-been-more-impressive-3951644"><i class="fa fa-caret-right" aria-hidden="true"></i> Uhuru Kenyatta’s legacy would have been more impressive</a>
</div>
</div>
<div class="col-6">
<div class="story-teaser tiny-teaser">
<a href="/tea/oped/comment/help-king-charles-iii-understand-the-queen-words-on-slavery-3951650"><i class="fa fa-caret-right" aria-hidden="true"></i> Let’s help Charles III understand the Queen’s words on slavery</a>
</div>
<div class="story-teaser tiny-teaser">
<a href="/tea/oped/comment/the-weight-of-an-oath-gives-a-person-power-to-give-promises-3951646"><i class="fa fa-caret-right" aria-hidden="true"></i> The weight of an oath gives a person power to give promises</a>
</div>
</div>
</div>
</div> </div>
</div>
</li>
<li>
<a href="/tea/science-health">Science &amp; Health</a>
<div class="mega-menu">
<div class="row no-gutters">
<div class="col-3">
</div>
<div class="col-8 offset-1">
<h4>Latest Science &amp; Health</h4>
<div class="row no-gutters">
<div class="col-6">
<div class="story-teaser tiny-teaser">
<a href="/tea/science-health/campaigners-want-health-funding-cuts-reversed-africa-crises-3958370"><i class="fa fa-caret-right" aria-hidden="true"></i> Campaigners want health funding cuts reversed amid Africa crises</a>
</div>
<div class="story-teaser tiny-teaser">
<a href="/tea/science-health/africa-set-for-fertiliser-boom-as-food-crisis-remains-critical-3954942"><i class="fa fa-caret-right" aria-hidden="true"></i> Africa set for fertiliser boom as food crisis remains critical</a>
</div>
</div>
<div class="col-6">
<div class="story-teaser tiny-teaser">
<a href="/tea/science-health/drug-resistant-pathogens-3953878"><i class="fa fa-caret-right" aria-hidden="true"></i> Concerns as Africa struggles to contain drug-resistant pathogens</a>
</div>
<div class="story-teaser tiny-teaser">
<a href="/tea/science-health/uganda-on-alert-as-malaria-cases-and-deaths-rise-3953882"><i class="fa fa-caret-right" aria-hidden="true"></i> Uganda on alert as malaria cases and deaths rise</a>
</div>
</div>
</div>
</div> </div>
</div>
</li>
<li>
<a href="/tea/magazine">Magazine</a>
<div class="mega-menu">
<div class="row no-gutters">
<div class="col-3">
</div>
<div class="col-8 offset-1">
<h4>Latest Magazine</h4>
<div class="row no-gutters">
<div class="col-6">
<div class="story-teaser tiny-teaser">
<a href="/tea/magazine/seasoned-voice-actor-kenya-3954978"><i class="fa fa-caret-right" aria-hidden="true"></i> Kenya’s seasoned voice actor on the openly &#39;hidden&#39; profession</a>
</div>
<div class="story-teaser tiny-teaser">
<a href="/tea/magazine/how-nyege-nyege-festival-went-down-3953930"><i class="fa fa-caret-right" aria-hidden="true"></i> How Nyege Nyege Festival went down</a>
</div>
</div>
<div class="col-6">
<div class="story-teaser tiny-teaser">
<a href="/tea/magazine/adios-jayden-enter-riggy-g-kenya-s-new-meme-king-3948472"><i class="fa fa-caret-right" aria-hidden="true"></i> Adios Jayden... Enter Riggy G, Kenya&#39;s new meme king</a>
</div>
<div class="story-teaser tiny-teaser">
<a href="/tea/magazine/charles-kariuki-road-to-african-air-guitar-champion-3944246"><i class="fa fa-caret-right" aria-hidden="true"></i> Charles Kariuki&#39;s road to African air guitar champion</a>
</div>
</div>
</div>
</div> </div>
</div>
</li>
<li>
<a href="/tea/sports">Sports</a>
<div class="mega-menu">
<div class="row no-gutters">
<div class="col-3">
</div>
<div class="col-8 offset-1">
<h4>Latest Sports</h4>
<div class="row no-gutters">
<div class="col-6">
<div class="story-teaser tiny-teaser">
<a href="/tea/sports/south-africa-to-bid-to-host-for-2027-women-world-cup-3956272"><i class="fa fa-caret-right" aria-hidden="true"></i> South Africa to bid to host for 2027 Women&#39;s World Cup</a>
</div>
<div class="story-teaser tiny-teaser">
<a href="/tea/sports/the-hamilton-effect-on-f1-following-in-eas-africa-3915980"><i class="fa fa-caret-right" aria-hidden="true"></i> The Hamilton effect on Formula One following in East Africa</a>
</div>
</div>
<div class="col-6">
<div class="story-teaser tiny-teaser">
<a href="/tea/sports/east-africans-sweep-commonwealth-marathon-3897216"><i class="fa fa-caret-right" aria-hidden="true"></i> East Africans sweep Commonwealth marathon</a>
</div>
<div class="story-teaser tiny-teaser">
<a href="/tea/sports/ugandan-joshua-cheptegei-runaway-success--3888932"><i class="fa fa-caret-right" aria-hidden="true"></i> Ugandan Joshua Cheptegei’s runaway success</a>
</div>
</div>
</div>
</div> </div>
</div>
</li>
<li>
<a href="/tea/rest-of-africa">Rest of Africa</a>
<div class="mega-menu">
<div class="row no-gutters">
<div class="col-3">
</div>
<div class="col-8 offset-1">
<h4>Latest Rest of Africa</h4>
<div class="row no-gutters">
<div class="col-6">
<div class="story-teaser tiny-teaser">
<a href="/tea/news/rest-of-africa/south-africa-signs-three-wind-power-deals-to-ease-outages-3958422"><i class="fa fa-caret-right" aria-hidden="true"></i> South Africa signs three wind power deals to ease outages</a>
</div>
<div class="story-teaser tiny-teaser">
<a href="/tea/news/rest-of-africa/african-leaders-at-unga-call-for-end-to-zimbabwe-sanctions-3958266"><i class="fa fa-caret-right" aria-hidden="true"></i> African leaders at UNGA call for end to Zimbabwe sanctions </a>
</div>
</div>
<div class="col-6">
<div class="story-teaser tiny-teaser">
<a href="/tea/news/rest-of-africa/nigeria-presidential-race-3956766"><i class="fa fa-caret-right" aria-hidden="true"></i> Nigeria approves 18 candidates for presidential race</a>
</div>
<div class="story-teaser tiny-teaser">
<a href="/tea/news/rest-of-africa/us-envoy-on-ethiopia-r-tigray-conflict-3956700"><i class="fa fa-caret-right" aria-hidden="true"></i> US not in a rush to sanction officials over Tigray war: envoy</a>
</div>
</div>
</div>
</div> </div>
</div>
</li>
<li>
<a href="/tea/kusi-ideas">KUSI IDEAS</a>
<div class="mega-menu">
<div class="row no-gutters">
<div class="col-3">
</div>
<div class="col-8 offset-1">
<h4>Latest KUSI IDEAS</h4>
<div class="row no-gutters">
<div class="col-6">
<div class="story-teaser tiny-teaser">
<a href="/tea/kusi-ideas/afcfta-on-track-to-lift-100-million-africans-out-of-poverty-3664440"><i class="fa fa-caret-right" aria-hidden="true"></i> AfCFTA on track to lift 100 million Africans out of poverty by 2035</a>
</div>
<div class="story-teaser tiny-teaser">
<a href="/tea/kusi-ideas/youth-and-creative-sector-banking-on-integration-3664378"><i class="fa fa-caret-right" aria-hidden="true"></i> Youth and creative sector banking on integration</a>
</div>
</div>
<div class="col-6">
<div class="story-teaser tiny-teaser">
<a href="/tea/kusi-ideas/targeting-specialist-markets-can-be-big-winner-3664432"><i class="fa fa-caret-right" aria-hidden="true"></i> Targeting specialist markets can be big winner</a>
</div>
<div class="story-teaser tiny-teaser">
<a href="/tea/kusi-ideas/water-management-tech-can-stave-off-effects-of-climate-change-3664418"><i class="fa fa-caret-right" aria-hidden="true"></i> Water management and technology can stave off worst effects of climate change</a>
</div>
</div>
</div>
</div> </div>
</div>
</li>
</ul>
<a class="btn-slide">
<i class="fa fa-bars d-block d-md-none" aria-hidden="true"></i>
</a>
<div class="search-form clearfix">
<form id="searchHeader" name="searchfrm" action="/service/search/tea/1446352" autocomplete="off" role="search">
<input name="query" type="search" placeholder="Search" minlength="3" required>
<input type="submit" name="" value="">
</form>
</div> </div>
</nav>
<div class="breaking-news">
<div class="container">
<div class="breaking-news-container" data-separator="|" data-fragments-link="/ajax/breaking-news/tea">
</div>
</div>
</div>
<article role="main" class="wrapper newsplex-article">
<section role="main" class="main-home artTop ">
<div class="container">
<div class="row">
<article class="main column">
<section class="ad noprint"> <span class="">Advertisement</span> <div class="ad">
<script>
var Url_Seg1=window.location.pathname.split( '/' )[1];
if(Url_Seg1==="sports"){ }else{
googletag.cmd.push(function() {
var leaderBoard = googletag.sizeMapping().
addSize([1024, 0], [728, 90]).
addSize([600, 0], [300, 250]).
addSize([800, 0], [728, 90]).
addSize([0, 0], [[320, 50], [320, 100], [300, 75], [300, 100], [300, 50], [300, 250]]).
build();
window.bk_dfp_integration = window.bk_dfp_integration || {}; window.bk_dfp_integration.functions = window.bk_dfp_integration.functions || {}; if(typeof bk_dfp_integration.functions.sendDfp === "function"){ bk_dfp_integration.functions.sendDfp(); }
googletag.defineSlot('/1010816/Z-DN-728x90-ArticleTop',[[320, 50], [320, 100], [300, 75], [300, 100], [300, 50], [728, 90], [300, 250]], 'div-gpt-ad-1489467324804-0').defineSizeMapping(leaderBoard).addService(googletag.pubads());
googletag.pubads().collapseEmptyDivs();
googletag.pubads().setTargeting('url', window.location.pathname.split( '/' )[1]);
googletag.pubads().setTargeting('url2', window.location.pathname.split( '/' )[2]);
googletag.enableServices();
});
}
</script>

<div id='div-gpt-ad-1489467324804-0' style='margin:0 auto;height:auto'>
<script>
if(Url_Seg1==="sports"){ $(".ad").css("background","white"); }else{
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1489467324804-0'); });
}
</script>
</div>
</div> </section><div class="container mt-4 px-0">
<nav aria-label="breadcrumb">
<ol class="breadcrumb col-12">
<li class="breadcrumb-item "><a href="/tea">The East African</a></li>
<li class="breadcrumb-item "><a href="/tea/news">News</a></li>
<li class="breadcrumb-item active" aria-current=&quot;page&quot;><a href="#">East Africa</a></li>
</ol>
</nav>
<div class="section-home-header clearfix mb-3">
</div>
</div> <header>
<h2>9 years later: Lessons from the Westgate terror attack </h2>
<p class="summary"></p>
<h6>Friday September 23 2022</h6>
<div class="social-networks noprint">
<a href="https://twitter.com/share?text=9 years later: Lessons from the Westgate terror attack &amp;url=https://www.theeastafrican.co.ke/tea/news/east-africa/lessons-from-the-westgate-terror-attack-3959376&amp;via=The_EastAfrican" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a>
<a href="https://www.facebook.com/sharer.php?u=https://www.theeastafrican.co.ke/tea/news/east-africa/lessons-from-the-westgate-terror-attack-3959376" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a>
<a href="https://www.linkedin.com/shareArticle?mini=true&amp;url=https://www.theeastafrican.co.ke/tea/news/east-africa/lessons-from-the-westgate-terror-attack-3959376" target="_blank"><i class="fa fa-linkedin" aria-hidden="true"></i></a>
<div class="mobileShow">
<a href="https://api.whatsapp.com/send?text=https://www.theeastafrican.co.ke/tea/news/east-africa/lessons-from-the-westgate-terror-attack-3959376" target="_blank"><i class="fa fa-whatsapp" aria-hidden="true"></i></a>
</div>
<a href="javascript:window.print()" target="_blank"><i class="fa fa-print" aria-hidden="true"></i></a>
<a href="/cdn-cgi/l/email-protection#80bff3f5e2eae5e3f4bdb9a0f9e5e1f2f3a0ece1f4e5f2baa0cce5f3f3efeef3a0e6f2efeda0f4e8e5a0d7e5f3f4e7e1f4e5a0f4e5f2f2eff2a0e1f4f4e1e3eba0a6e1edf0bbe2efe4f9bdb9a0f9e5e1f2f3a0ece1f4e5f2baa0cce5f3f3efeef3a0e6f2efeda0f4e8e5a0d7e5f3f4e7e1f4e5a0f4e5f2f2eff2a0e1f4f4e1e3eba0ade8f4f4f0f3baafaff7f7f7aef4e8e5e5e1f3f4e1e6f2e9e3e1eeaee3efaeebe5aff4e5e1afeee5f7f3afe5e1f3f4ade1e6f2e9e3e1afece5f3f3efeef3ade6f2efedadf4e8e5adf7e5f3f4e7e1f4e5adf4e5f2f2eff2ade1f4f4e1e3ebadb3b9b5b9b3b7b6" target="_blank"><i class="fa fa-envelope-o" aria-hidden="true"></i></a>
</div> <div>
<div class="storyTopPic">
<img src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mNkYAAAAAYAAjCB0C8AAAAASUVORK5CYII=" alt="Westgate attack" class="cm-media cm-media--loading cm-media--responsive cm-media--loading " title="" data-cm-responsive-media="[{&quot;name&quot;:&quot;landscape_ratio16x9&quot;,&quot;ratioWidth&quot;:16,&quot;ratioHeight&quot;:9,&quot;linksForWidth&quot;:{&quot;200&quot;:&quot;/resource/image/3959378/landscape_ratio16x9/200/112/5f23c0d589db25202085f360bc2c31fd/mz/terror.jpg&quot;,&quot;300&quot;:&quot;/resource/image/3959378/landscape_ratio16x9/300/168/5f23c0d589db25202085f360bc2c31fd/AH/terror.jpg&quot;,&quot;400&quot;:&quot;/resource/image/3959378/landscape_ratio16x9/400/225/5f23c0d589db25202085f360bc2c31fd/Sq/terror.jpg&quot;,&quot;1160&quot;:&quot;/resource/image/3959378/landscape_ratio16x9/1160/652/5f23c0d589db25202085f360bc2c31fd/wa/terror.jpg&quot;}},{&quot;name&quot;:&quot;portrait_ratio2x3&quot;,&quot;ratioWidth&quot;:2,&quot;ratioHeight&quot;:3,&quot;linksForWidth&quot;:{&quot;200&quot;:&quot;/resource/image/3959378/portrait_ratio2x3/200/300/4c9ebb34bbcad3422309ad3c3d8eff84/ip/terror.jpg&quot;,&quot;400&quot;:&quot;/resource/image/3959378/portrait_ratio2x3/400/600/4c9ebb34bbcad3422309ad3c3d8eff84/ja/terror.jpg&quot;,&quot;768&quot;:&quot;/resource/image/3959378/portrait_ratio2x3/768/1152/4c9ebb34bbcad3422309ad3c3d8eff84/Ky/terror.jpg&quot;}},{&quot;name&quot;:&quot;landscape_ratio2x1&quot;,&quot;ratioWidth&quot;:2,&quot;ratioHeight&quot;:1,&quot;linksForWidth&quot;:{&quot;200&quot;:&quot;/resource/image/3959378/landscape_ratio2x1/200/100/3b83244de7815b0047c232903667a7e/qc/terror.jpg&quot;}},{&quot;name&quot;:&quot;landscape_ratio3x2&quot;,&quot;ratioWidth&quot;:3,&quot;ratioHeight&quot;:2,&quot;linksForWidth&quot;:{&quot;300&quot;:&quot;/resource/image/3959378/landscape_ratio3x2/300/200/615170ecbef5ea412ecd4e2c42aa00b9/YV/terror.jpg&quot;,&quot;400&quot;:&quot;/resource/image/3959378/landscape_ratio3x2/400/267/615170ecbef5ea412ecd4e2c42aa00b9/Jf/terror.jpg&quot;,&quot;768&quot;:&quot;/resource/image/3959378/landscape_ratio3x2/768/512/615170ecbef5ea412ecd4e2c42aa00b9/lp/terror.jpg&quot;}},{&quot;name&quot;:&quot;portrait_ratio1x1&quot;,&quot;ratioWidth&quot;:1,&quot;ratioHeight&quot;:1,&quot;linksForWidth&quot;:{&quot;50&quot;:&quot;/resource/image/3959378/portrait_ratio1x1/50/50/98b41265a2f10e5a0a6ea2198b138e64/Ay/terror.jpg&quot;,&quot;60&quot;:&quot;/resource/image/3959378/portrait_ratio1x1/60/60/98b41265a2f10e5a0a6ea2198b138e64/Uz/terror.jpg&quot;,&quot;200&quot;:&quot;/resource/image/3959378/portrait_ratio1x1/200/200/98b41265a2f10e5a0a6ea2198b138e64/jT/terror.jpg&quot;,&quot;400&quot;:&quot;/resource/image/3959378/portrait_ratio1x1/400/400/98b41265a2f10e5a0a6ea2198b138e64/Qx/terror.jpg&quot;,&quot;768&quot;:&quot;/resource/image/3959378/portrait_ratio1x1/768/768/98b41265a2f10e5a0a6ea2198b138e64/jm/terror.jpg&quot;}},{&quot;name&quot;:&quot;landscape_ratio4x3&quot;,&quot;ratioWidth&quot;:4,&quot;ratioHeight&quot;:3,&quot;linksForWidth&quot;:{&quot;200&quot;:&quot;/resource/image/3959378/landscape_ratio4x3/200/150/583b19daeea57fa1f1df306203c5aea6/yu/terror.jpg&quot;,&quot;400&quot;:&quot;/resource/image/3959378/landscape_ratio4x3/400/300/583b19daeea57fa1f1df306203c5aea6/Jh/terror.jpg&quot;,&quot;768&quot;:&quot;/resource/image/3959378/landscape_ratio4x3/768/576/583b19daeea57fa1f1df306203c5aea6/Yl/terror.jpg&quot;}}]">
</div>
<p id="photo_article_caption">Shoppers scramble for safety as police confronted gunmen who barricaded themselves inside Westgate Mall in Nairobi, on September 21, 2013. PHOTO | FILE</p> </div>
</header>
<article class="article">
<section class="article-sidebar">
<section class="ad noprint">
<span class="">Advertisement</span>
<div class="ad">
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script>
window.googletag = window.googletag || {cmd: []};
googletag.cmd.push(function() {
googletag.defineSlot('/1010816/EA-300X250-Article-3', [300, 250], 'div-gpt-ad-1594211656305-0').addService(googletag.pubads());
googletag.pubads().enableSingleRequest();
googletag.enableServices();
});
</script>

<div id='div-gpt-ad-1594211656305-0' style='width: 300px; height: 250px;'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1594211656305-0'); });
</script>
</div> </div>
</section>
</section>
<section class="body-copy">
<section class="author noprint">
<figure class="left">
<div class="articleAuthor">
<img src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mNkYAAAAAYAAjCB0C8AAAAASUVORK5CYII=" alt="General Image" class="cm-media cm-media--loading cm-media--responsive cm-media--loading " title="" data-cm-responsive-media="[{&quot;name&quot;:&quot;landscape_ratio16x9&quot;,&quot;ratioWidth&quot;:16,&quot;ratioHeight&quot;:9,&quot;linksForWidth&quot;:{&quot;200&quot;:&quot;/resource/image/1367838/landscape_ratio16x9/200/112/a14bf856bbe85588ee9a71c3dd2d9079/Zy/general-image.jpg&quot;,&quot;300&quot;:&quot;/resource/image/1367838/landscape_ratio16x9/300/168/a14bf856bbe85588ee9a71c3dd2d9079/xe/general-image.jpg&quot;,&quot;400&quot;:&quot;/resource/image/1367838/landscape_ratio16x9/400/225/a14bf856bbe85588ee9a71c3dd2d9079/tp/general-image.jpg&quot;,&quot;1160&quot;:&quot;/resource/image/1367838/landscape_ratio16x9/1160/652/a14bf856bbe85588ee9a71c3dd2d9079/BR/general-image.jpg&quot;}}]">
</div> </figure>
<strong>By MARY WAMBUI</strong>
<div><a href="/tea/author-profiles/mary-wambui-1420398"><span class="author-profile">More by this Author</span></a></div>
</section>
<br />
<p>On September 21, 2013, Kenya was thrown into terror after gunmen from the Somali terrorists group al Shabaab launched an attack on a mall in Nairobi, killing 67 people and injuring many others.</p><p>Nine years later, survivors are still reeling from the aftermath of the terror attack.</p><p>A security report only made public this month shows that the planners had for months studied the mall, business activities and the type of people who visit it, all the while planning the attack from the Kakuma Refugee camp.</p><p><strong>Read: </strong><a href="https://www.theeastafrican.co.ke/tea/news/east-africa/the-changing-face-of-terrorism-in-east-africa-the-horn-1410704" target="_blank" rel="noopener">The changing face of terrorism in East Africa, the Horn</a></p><p>The report by the then UN Security Council Monitoring Group on Somalia indicates that planning began two years earlier in 2011, as the Horn of Africa battled drought and a surge of refugees fled to Kenyan camps.</p><p>Shabaabs in Somalia worked with their contacts in Kenya’s capital Nairobi and at the Kakuma refugee camp on the ‘project’, which also involved monetary transactions, the report states.</p> <div id="relatedCoverage" class="article-related-coverage">
<div class="related-coverage-header"><h3>Related</h3></div>
<div class="related-coverage-body">
<ul>
<li><a href="/tea/news/east-africa/westgate-attack-suspects-found-guilty-one-acquitted-2459704">
<span class="relImage">
<figure>
<div class="relatedTeaser">
<img src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mNkYAAAAAYAAjCB0C8AAAAASUVORK5CYII=" alt="suspects" class="cm-media cm-media--loading cm-media--responsive cm-media--loading " title="" data-cm-responsive-media="[{&quot;name&quot;:&quot;landscape_ratio16x9&quot;,&quot;ratioWidth&quot;:16,&quot;ratioHeight&quot;:9,&quot;linksForWidth&quot;:{&quot;200&quot;:&quot;/resource/image/2459702/landscape_ratio16x9/200/112/e7d407be579be2cbd2afec7187f34dd1/ZZ/suspects.jpg&quot;,&quot;300&quot;:&quot;/resource/image/2459702/landscape_ratio16x9/300/168/e7d407be579be2cbd2afec7187f34dd1/mB/suspects.jpg&quot;,&quot;400&quot;:&quot;/resource/image/2459702/landscape_ratio16x9/400/225/e7d407be579be2cbd2afec7187f34dd1/LI/suspects.jpg&quot;,&quot;1160&quot;:&quot;/resource/image/2459702/landscape_ratio16x9/1160/652/e7d407be579be2cbd2afec7187f34dd1/iU/suspects.jpg&quot;}}]">
</div> </figure>
</span>
<span class="relText">
Kenyan court finds two guilty for Westgate attack
</span>
</a></li>
<li><a href="/tea/news/east-africa/icc-ready-to-prosecute-nairobi-mall-attackers-1319490">
<span class="relImage">
<figure>
<div class="relatedTeaser">
<img src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mNkYAAAAAYAAjCB0C8AAAAASUVORK5CYII=" alt="fatou" class="cm-media cm-media--loading cm-media--responsive cm-media--loading " title="" data-cm-responsive-media="[{&quot;name&quot;:&quot;landscape_ratio16x9&quot;,&quot;ratioWidth&quot;:16,&quot;ratioHeight&quot;:9,&quot;linksForWidth&quot;:{&quot;200&quot;:&quot;/resource/image/1319492/landscape_ratio16x9/200/112/e025af0985e52a883583509d0703333f/sf/fatou.jpg&quot;,&quot;300&quot;:&quot;/resource/image/1319492/landscape_ratio16x9/300/168/e025af0985e52a883583509d0703333f/yD/fatou.jpg&quot;,&quot;400&quot;:&quot;/resource/image/1319492/landscape_ratio16x9/400/225/e025af0985e52a883583509d0703333f/Se/fatou.jpg&quot;,&quot;1160&quot;:&quot;/resource/image/1319492/landscape_ratio16x9/1160/652/e025af0985e52a883583509d0703333f/Eu/fatou.jpg&quot;}}]">
</div> </figure>
</span>
<span class="relText">
ICC ready to prosecute Nairobi mall attackers
</span>
</a></li>
<li><a href="/tea/news/east-africa/al-shabaab-displays-dusit-attackers-in-video-3229232">
<span class="relImage">
<figure>
<div class="relatedTeaser">
<img src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mNkYAAAAAYAAjCB0C8AAAAASUVORK5CYII=" alt="Security forces at Dusit." class="cm-media cm-media--loading cm-media--responsive cm-media--loading " title="" data-cm-responsive-media="[{&quot;name&quot;:&quot;landscape_ratio16x9&quot;,&quot;ratioWidth&quot;:16,&quot;ratioHeight&quot;:9,&quot;linksForWidth&quot;:{&quot;200&quot;:&quot;/resource/image/3229346/landscape_ratio16x9/200/112/461a948110fed2526a5bee7587ad380c/eN/security.jpg&quot;,&quot;300&quot;:&quot;/resource/image/3229346/landscape_ratio16x9/300/168/461a948110fed2526a5bee7587ad380c/ap/security.jpg&quot;,&quot;400&quot;:&quot;/resource/image/3229346/landscape_ratio16x9/400/225/461a948110fed2526a5bee7587ad380c/Pw/security.jpg&quot;,&quot;1160&quot;:&quot;/resource/image/3229346/landscape_ratio16x9/1160/652/461a948110fed2526a5bee7587ad380c/ec/security.jpg&quot;}}]">
</div> </figure>
</span>
<span class="relText">
Al-Shabaab displays Dusit attackers in video
</span>
</a></li>
<li><a href="/tea/news/east-africa/ea-security-chiefs-meet-over-common-approach-to-terror-attacks-piracy-1427660">
<span class="relImage">
<figure>
<div class="relatedTeaser">
<img src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mNkYAAAAAYAAjCB0C8AAAAASUVORK5CYII=" alt="west" class="cm-media cm-media--loading cm-media--responsive cm-media--loading " title="" data-cm-responsive-media="[{&quot;name&quot;:&quot;landscape_ratio16x9&quot;,&quot;ratioWidth&quot;:16,&quot;ratioHeight&quot;:9,&quot;linksForWidth&quot;:{&quot;200&quot;:&quot;/resource/image/1427662/landscape_ratio16x9/200/112/2ec715da8038b2a1c53a47d24045f14e/fR/west.jpg&quot;,&quot;300&quot;:&quot;/resource/image/1427662/landscape_ratio16x9/300/168/2ec715da8038b2a1c53a47d24045f14e/qh/west.jpg&quot;,&quot;400&quot;:&quot;/resource/image/1427662/landscape_ratio16x9/400/225/2ec715da8038b2a1c53a47d24045f14e/ec/west.jpg&quot;,&quot;1160&quot;:&quot;/resource/image/1427662/landscape_ratio16x9/1160/652/2ec715da8038b2a1c53a47d24045f14e/lY/west.jpg&quot;}}]">
</div> </figure>
</span>
<span class="relText">
How Westgate attack jolted region police chiefs into action
</span>
</a></li>
</ul>
</div>
</div>
<section class="ad noprint">
<span class="">Advertisement</span>
<div class="ad">
<script>
window.googletag = window.googletag || {cmd: []};
googletag.cmd.push(function() {
var leaderBoard = googletag.sizeMapping().
addSize([1024, 0], [728, 90]).
addSize([600, 0], [300, 250]).
addSize([800, 0], [728, 90]).
addSize([0, 0], [[320, 50], [300, 75], [300, 100], [300, 50], [300, 250]]).
build();
googletag.defineSlot('/1010816/Z-DN-728x90-inArticleRelated', [[300, 50], [320, 480], [300, 100], [320, 50], [300, 250], [300, 75], [728, 90]], 'div-gpt-ad-1592285737951-0').defineSizeMapping(leaderBoard).addService(googletag.pubads());
googletag.pubads().enableSingleRequest();
googletag.pubads().collapseEmptyDivs();
googletag.enableServices();
});
</script>

<div id='div-gpt-ad-1592285737951-0'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1592285737951-0'); });
</script>
</div> </div>
</section>
<p>They managed to avoid detection from security services, partly aided by lax procedures in obtaining mobile phone lines that they used for communication. Detectives later found that eight mobile phone lines directly linked to the attack were registered in Nairobi and switched on days to the attack. These phones numbers were communicating frequently from Nairobi’s Eastleigh area.</p><p>The attack was further aided by social media as the report shows that the attackers used a popular site to communicate during and after the attack.</p><p>The details were put under lid for nearly a decade after officials decided to embargo the report until September 2021. It was shared with the media this week as the country marks nine years of the attack. All the three attackers who used rifles and grenades to gain entry into and lay a siege on the Westgate Mall in Nairobi’s Westlands area were killed in the attack, according to an earlier statement by the Kenya Defence Forces.</p><p>At least 200 people were also injured just weeks after President Uhuru Kenyatta began his term as the then new President.</p><p><strong>Read:</strong> <a href="https://www.theeastafrican.co.ke/tea/news/east-africa/ea-security-chiefs-meet-over-common-approach-to-terror-attacks-piracy-1427660" target="_blank" rel="noopener">EA security chiefs meet over common approach to terror attacks, piracy</a></p><p>Kenya marks nine years since the attack with a new president, William Ruto, who admitted that the country faces the same problem of security threats as before.</p><p>But there have been lessons learnt, including improved surveillance of terror threats, tighter rules on registering mobile phone lines, and a general better collaboration between security agencies as was witnessed during the Dusit attack in Nairobi in January 2019 when security forces ended a similar siege more quickly than the Westgate siege and with fewer casualties.</p><p>The Westgate siege, which lasted for four days, was heavily criticised, prompting President Kenyatta to promise an official inquiry into the attack.</p><p>On September 6, 2013, the attackers purchased a Mitsubishi Lancer KAS 575X from a garage in Nairobi which was used to conduct surveillance, rehearse and identify potential secure routes to the mall from Eastleigh.</p><p>It is the same vehicle that was used to access the mall by four terrorists on the day of the attack.</p><p>The planning never stopped until the last day, as evidence shows that one of the planners in Nairobi even texted his associate in Somalia to confirm that the attack was still ongoing on the second day of the siege.</p><p>“Alhamdulillah, had just left Westgate with my coffee and the shooting started. Alhamdulillah.”</p><p>Seven years later on October 7, 2020, <a href="https://www.theeastafrican.co.ke/tea/news/east-africa/westgate-attack-suspects-found-guilty-one-acquitted-2459704" target="_blank" rel="noopener">Mohammed Ahmed Abdi and Hussein Hassan Mustafa were found guilty of planning and committing acts of terror and helping a terrorist group</a>. They were later sentenced to 33 and 18 years’ imprisonment.</p><p>The third suspect, Liban Abdullahi, a Somali refugee, was acquitted of the charge of being in Kenya illegally and possessing identification documents by false pretences.</p><p>He would later, however, be abducted by unidentified gunmen after leaving the Anti-Terror Police Unit (ATPU) headquarters in Nairobi where he had gone for clearance.</p><p>In his ruling, Chief Magistrate Francis Andayi said he acquitted the suspect over lack of evidence. He explained that although Omar shared his phone with his brother (Ahmed Hassan Abukar who was found guilty), he was not aware that his brother had joined the Shabaab terror group.</p><p>In the aftermath of the Westgate attack, Kenya would suffer another heavy loss in April 2015 after Shabaab gunmen raided Garissa University, killing 144 people, mostly students.</p><p>But security agencies have since then foiled a number of other attack attempts, including a 2014 incident in Mombasa where a vehicle that had been procured and loaded with two TNT explosive cylinders was seized by the police. The cylinders had been remotely connected to a triggering system and police also seized a cache of arms, including AK-47 rifles, 270 rounds of ammunition, six grenades, five magazines and four detonators.</p><p>The report notes that the attack was at some point uncoordinated, an error that brought the country’s security preparedness under sharp scrutiny and sparked transfers of senior security chiefs.</p><p>It also led to the enactment of the Security Laws (Amendment) Act 2014 and the establishment of a Multi-Agency Taskforce (MAT). The laws helped agencies to collaborate better. But critics saw them as an intrusive tool.</p><p>Many more terror attack attempts have been foiled within and along the Kenya-Somali border as Nairobi remains on high alert over possible retaliatory attacks.</p> </section>
</article>
<script type="text/javascript" src="https://theconversation.com/javascripts/lib/content_tracker_hook.js" id="theconversation_tracker_hook" data-counter="https://counter.theconversation.com/content/UNDEFINED/count?distributor=republish-lightbox-advanced" async="async"></script> <section class="ad noprint">
<span class="">Advertisement</span>
<div class="ad">
<script>
window.googletag = window.googletag || {cmd: []};
googletag.cmd.push(function() {
var mobileResize = googletag.sizeMapping().
addSize([1024, 0], [728, 90]).
addSize([600, 0], [300, 250]).
addSize([800, 0], [728, 90]).
addSize([0, 0], [300, 250]).
build();
googletag.defineSlot('/1010816/Z-Dn-728x90-newsarticle', [[300, 250], [728, 90]], 'div-gpt-ad-1591700957341-0').defineSizeMapping(mobileResize).addService(googletag.pubads());
googletag.pubads().enableSingleRequest();
googletag.pubads().collapseEmptyDivs();
googletag.enableServices();
});
</script>

<div id='div-gpt-ad-1591700957341-0'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1591700957341-0'); });
</script>
</div> </div>
</section>
<section class="print-section big-blog noprint" id="headlines">
<header class="clearfix">
<div class="blog-header clearfix">
<h3>In the headlines</h3>
</div>
</header>
<article>
<div class="row">
<div class="five-eight column">
<div class="story-teaser medium-teaser">
<h3> <a href="/tea/news/east-africa/uganda-limits-gatherings-curb-ebola-spread-3959052">Ebola: Uganda closes clubs, limits gatherings </a></h3>
<div class="">
<figure class="">
<a href="/tea/news/east-africa/uganda-limits-gatherings-curb-ebola-spread-3959052">
<div class="mediumTeaserImage">
<img src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mNkYAAAAAYAAjCB0C8AAAAASUVORK5CYII=" alt="Mubende Hospital in Uganda." class="cm-media cm-media--loading cm-media--responsive cm-media--loading " title="" data-cm-responsive-media="[{&quot;name&quot;:&quot;landscape_ratio16x9&quot;,&quot;ratioWidth&quot;:16,&quot;ratioHeight&quot;:9,&quot;linksForWidth&quot;:{&quot;200&quot;:&quot;/resource/image/3959054/landscape_ratio16x9/200/112/4970546ac718e3274056c6a8f86bc6b1/DF/hospital.jpg&quot;,&quot;300&quot;:&quot;/resource/image/3959054/landscape_ratio16x9/300/168/4970546ac718e3274056c6a8f86bc6b1/zh/hospital.jpg&quot;,&quot;400&quot;:&quot;/resource/image/3959054/landscape_ratio16x9/400/225/4970546ac718e3274056c6a8f86bc6b1/YI/hospital.jpg&quot;,&quot;1160&quot;:&quot;/resource/image/3959054/landscape_ratio16x9/1160/652/4970546ac718e3274056c6a8f86bc6b1/Qw/hospital.jpg&quot;}}]">
</div> </a>
</figure>
<p>
Officials impose restrictions on visiting public offices and warns against crowding.</p>
</div>
</div><div class="story-teaser medium-teaser">
<h3> <a href="/tea/news/east-africa/human-trafficking-victims-rescued-laos-3958888">22 Kenyans rescued from traffickers in Laos</a></h3>
<div class="">
<figure class="">
<a href="/tea/news/east-africa/human-trafficking-victims-rescued-laos-3958888">
<div class="mediumTeaserImage">
<img src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mNkYAAAAAYAAjCB0C8AAAAASUVORK5CYII=" alt="Human trafficking." class="cm-media cm-media--loading cm-media--responsive cm-media--loading " title="" data-cm-responsive-media="[{&quot;name&quot;:&quot;landscape_ratio16x9&quot;,&quot;ratioWidth&quot;:16,&quot;ratioHeight&quot;:9,&quot;linksForWidth&quot;:{&quot;200&quot;:&quot;/resource/image/3958890/landscape_ratio16x9/200/112/934fe69f3d6bbff64407ed98e2430b8d/sJ/trafficking.jpg&quot;,&quot;300&quot;:&quot;/resource/image/3958890/landscape_ratio16x9/300/168/934fe69f3d6bbff64407ed98e2430b8d/Pp/trafficking.jpg&quot;,&quot;400&quot;:&quot;/resource/image/3958890/landscape_ratio16x9/400/225/934fe69f3d6bbff64407ed98e2430b8d/sQ/trafficking.jpg&quot;,&quot;1160&quot;:&quot;/resource/image/3958890/landscape_ratio16x9/1160/652/934fe69f3d6bbff64407ed98e2430b8d/Gw/trafficking.jpg&quot;}}]">
</div> </a>
</figure>
<p>
Earlier, another 13 trafficked Kenyans were rescued in Myanmar.</p>
</div>
</div> </div>
<div class="three-eight column">
<div class="small-story-list">
<h5 class="small-story-list"><a href="/tea/business/nigerians-sue-over-cash-frozen-in-safaricom-banks-3959016">Nigerians sue over $11m Flutterwave cash frozen in Kenya</a></h5><h5 class="small-story-list"><a href="/tea/news/east-africa/uganda-increases-surveillance-confirms-six-more-ebola-cases-3958790">Uganda confirms six more cases of Ebola</a></h5><h5 class="small-story-list"><a href="/tea/news/rest-of-africa/african-leaders-at-unga-call-for-end-to-zimbabwe-sanctions-3958266">African leaders at UNGA call for end to Zimbabwe sanctions </a></h5><h5 class="small-story-list"><a href="/tea/news/rest-of-africa/south-africa-signs-three-wind-power-deals-to-ease-outages-3958422">South Africa signs three wind power deals to ease outages</a></h5><h5 class="small-story-list"><a href="/tea/news/east-africa/macron-meets-paul-kagame-and-felix-tshisekedi-over-drc-war-3957834">DRC war: Macron meets Kagame, Tshisekedi </a></h5> </div>
</div>
</div>
</article>
</section>
</article>
<aside class="aside column noprint">
<div class="row">
<div class="sidebar-item">
<script>
window.googletag = window.googletag || {cmd: []};
googletag.cmd.push(function() {
googletag.defineSlot('/1010816/EA-300X250-Article0-1', [300, 250], 'div-gpt-ad-1594211421577-0').addService(googletag.pubads());
googletag.pubads().enableSingleRequest();
googletag.enableServices();
});
</script>

<div id='div-gpt-ad-1594211421577-0' class='ad'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1594211421577-0'); });
</script>
</div> </div>
<div class="sidebar-item">
<div class="tab-header">
<div class="tab">
<span class="icon most-read-icon"></span>Kenya elections</div>
</div>
<div class="tab-body">
<li class="most-popular-item">
<a href="/tea/oped/editorial/on-transfer-of-power-kenya-has-set-the-standard-3951654">
<span class="most-number">1</span>
<span class="most-headline"><span>Editorial</span> EDITORIAL: On transfer of power, Kenya has set the standard</span>
</a>
</li>
<li class="most-popular-item">
<a href="/tea/news/rest-of-africa/sierra-leoneans-unhappy-with-kenya-president-ruto-inauguration-3948186">
<span class="most-number">2</span>
<span class="most-headline"><span>Rest of Africa</span> Sierra Leoneans unhappy with Ruto&#39;s inauguration</span>
</a>
</li>
<li class="most-popular-item">
<a href="/tea/news/east-africa/president-ruto-uhuru-kenyatta-lead-regional-peace-efforts-3947826">
<span class="most-number">3</span>
<span class="most-headline"><span>East Africa</span> Uhuru to lead Kenya regional peace efforts - Ruto</span>
</a>
</li>
<li class="most-popular-item">
<a href="/tea/news/east-africa/read-president-ruto-s-full-speech-after-his-inauguration-3947552">
<span class="most-number">4</span>
<span class="most-headline"><span>East Africa</span> President Ruto&#39;s full speech after his inauguration</span>
</a>
</li>
<li class="most-popular-item">
<a href="/tea/news/east-africa/william-ruto-sworn-in-as-kenya-s-fifth-president--3947134">
<span class="most-number">5</span>
<span class="most-headline"><span>East Africa</span> Ruto sworn in as Kenya&#39;s fifth president </span>
</a>
</li>
</div> </div>
<div class="sidebar-item">
<div class="tab-header">
<div class="tab">
<span class="icon most-read-icon"></span>Latest</div>
</div>
<div class="tab-body">
<li class="most-popular-item">
<a href="/tea/business/saudi-remittances-double-3959522">
<span class="most-number">1</span>
<span class="most-headline"><span>Business</span> Saudi remittances to Kenya double to $187m amid maids abuse</span>
</a>
</li>
<li class="most-popular-item">
<a href="/tea/news/east-africa/lessons-from-the-westgate-terror-attack-3959376">
<span class="most-number">2</span>
<span class="most-headline"><span>East Africa</span> 9 years later: Lessons from the Westgate terror attack </span>
</a>
</li>
<li class="most-popular-item">
<a href="/tea/news/east-africa/uganda-limits-gatherings-curb-ebola-spread-3959052">
<span class="most-number">3</span>
<span class="most-headline"><span>East Africa</span> Ebola: Uganda closes clubs, limits gatherings </span>
</a>
</li>
<li class="most-popular-item">
<a href="/tea/business/nigerians-sue-over-cash-frozen-in-safaricom-banks-3959016">
<span class="most-number">4</span>
<span class="most-headline"><span>Business</span> Nigerians sue over $11m Flutterwave cash frozen in Kenya</span>
</a>
</li>
<li class="most-popular-item">
<a href="/tea/news/east-africa/tanzania-alert-ebola-after-uganda-outbreak-3958868">
<span class="most-number">5</span>
<span class="most-headline"><span>East Africa</span> Tanzania to screen for Ebola after Uganda outbreak</span>
</a>
</li>
<li class="most-popular-item">
<a href="/tea/news/east-africa/human-trafficking-victims-rescued-laos-3958888">
<span class="most-number">6</span>
<span class="most-headline"><span>East Africa</span> 22 Kenyans rescued from traffickers in Laos</span>
</a>
</li>
<li class="most-popular-item">
<a href="/tea/news/east-africa/uganda-increases-surveillance-confirms-six-more-ebola-cases-3958790">
<span class="most-number">7</span>
<span class="most-headline"><span>East Africa</span> Uganda confirms six more cases of Ebola</span>
</a>
</li>
<li class="most-popular-item">
<a href="/tea/news/rest-of-africa/south-africa-signs-three-wind-power-deals-to-ease-outages-3958422">
<span class="most-number">8</span>
<span class="most-headline"><span>Rest of Africa</span> South Africa signs three wind power deals to ease outages</span>
</a>
</li>
<li class="most-popular-item">
<a href="/tea/science-health/campaigners-want-health-funding-cuts-reversed-africa-crises-3958370">
<span class="most-number">9</span>
<span class="most-headline"><span>Science &amp; Health</span> Campaigners want health funding cuts reversed amid Africa crises</span>
</a>
</li>
</div> </div>
<div class="sidebar-item">
<script>
window.googletag = window.googletag || {cmd: []};
googletag.cmd.push(function() {
googletag.defineSlot('/1010816/EA-300X250-Article-2', [300, 250], 'div-gpt-ad-1594211537827-0').addService(googletag.pubads());
googletag.pubads().enableSingleRequest();
googletag.enableServices();
});
</script>

<div id='div-gpt-ad-1594211537827-0' class='ad'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1594211537827-0'); });
</script>
</div> </div>
<div class="sidebar-item">
<section class="ad noprint">
<span class="">Advertisement</span>
<div class="ad">
<ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-0846142691248784" data-ad-slot="7537505707"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script> </div> </section> </div>
</div>
</aside>
</div>
</div>
<script type="text/javascript">
/* CONFIGURATION START */
var _ain = {
id: "1910",
postid: "new-3959376",
maincontent: "h2, #photo_article_caption, section.summary, section.body-copy",
title: "9 years later: Lessons from the Westgate terror attack ",
pubdate: "2022-09-23 02:30:00",
authors: "MARY WAMBUI",
sections: "East Africa",
tags: "Kenya, Africa, westgate attack,terror attack,shabaab,dusit attack,nairobi,kenya,somalia,kakuma refugee camp,eastleigh",
comments: "",
access_level: "free",
reader_type: "anonymous"
};
/* CONFIGURATION END */
(function(d,s){var sf=d.createElement(s);sf.type='text/javascript';sf.async=!0;sf.src=(('https:'==d.location.protocol)?'https://d7d3cf2e81d293050033-3dfc0615b0fd7b49143049256703bfce.ssl.cf1.rackcdn.com':'http://t.contentinsights.com')+'/stf.js';var t=d.getElementsByTagName(s)[0];t.parentNode.insertBefore(sf,t)})(document,'script')
</script>
<script>
dataLayer = [{
'site': 'theeastafrican.co.ke',
'section': 'East Africa',
'pageTitle': '9 years later: Lessons from the Westgate terror attack ',
'author': 'MARY WAMBUI',
'keywords': 'Kenya, Africa, westgate attack,terror attack,shabaab,dusit attack,nairobi,kenya,somalia,kakuma refugee camp,eastleigh'
}];
</script> </section>
</article>
<footer class="wrapper page-footer" id="page-footer">
<div class="menu-holder menu-holder-footer noprint">
<nav class="menu-vertical footer-section" role="navigation">
<header>
<a href="/tea/news" title="News">
<h3 class="footer-section-heading">News</h3>
</a>
</header>
<a href="/tea/news/east-africa" title="East Africa">East Africa</a>
<a href="/tea/news/rest-of-africa" title="Rest of Africa">Rest of Africa</a>
<a href="/tea/news/world" title="World">World</a>
</nav>
<nav class="menu-vertical footer-section" role="navigation">
<header>
<a href="/tea/business" title="Business">
<h3 class="footer-section-heading">Business</h3>
</a>
</header>
</nav>
<nav class="menu-vertical footer-section" role="navigation">
<header>
<a href="/tea/oped" title="Opinion">
<h3 class="footer-section-heading">Opinion</h3>
</a>
</header>
</nav>
<nav class="menu-vertical footer-section" role="navigation">
<header>
<a href="/tea/science-health" title="Science &amp; Health">
<h3 class="footer-section-heading">Science &amp; Health</h3>
</a>
</header>
</nav>
<nav class="menu-vertical footer-section" role="navigation">
<header>
<a href="/tea/magazine" title="Magazine">
<h3 class="footer-section-heading">Magazine</h3>
</a>
</header>
</nav>
<nav class="menu-vertical footer-section" role="navigation">
<header>
<a href="/tea/sports" title="Sports">
<h3 class="footer-section-heading">Sports</h3>
</a>
</header>
</nav>
<nav class="menu-vertical footer-section" role="navigation">
<header>
<a href="/tea/rest-of-africa" title="Rest of Africa">
<h3 class="footer-section-heading">Rest of Africa</h3>
</a>
</header>
</nav>
<nav class="menu-vertical footer-section" role="navigation">
<header>
<a href="/tea/kusi-ideas" title="KUSI IDEAS">
<h3 class="footer-section-heading">KUSI IDEAS</h3>
</a>
</header>
</nav>
</div>
<footer id="dnFooter">
<div class="dnFooter-row noprint">
<div class="dnFooter-col-sm-3">
<h5></h5>
<h5></h5>
<a href="/tea">
<img src="/resource/crblob/1830002/4d4ba1f86b20e22d593b250208bb3581/amp-logo-png-data.png" alt="The East African" class="logo">
</a>
</div>
<div class="dnFooter-col-sm-2">
<h5>Apps</h5>
<ul>
<li><a href="https://play.google.com/store/apps/developer?id=Nation%20Media%20Group&amp;amp;hl=en&amp;amp;pcampaignid=MKT-Other-global-all-co-prtnr-py-PartBadge-Mar2515-1" target="_blank"><img alt="Play Store" src="/resource/crblob/654084/50e4f00026394f5a265aaf340a5d0a57/google-play-badge-png-data.png"></a></li><br>
<li><a href="https://itunes.apple.com/us/developer/nation-media-group-ltd/id771736086" target="_blank"><img src="/resource/crblob/654060/de9cff10d1c98ad9ce9274954e2fbc20/appstoreicon-svg-data.svg" alt="App Store" class="logo"></a></li>
</ul>
</div>
<div class="dnFooter-col-sm-2">
<h5>Information</h5>
<ul>
<li><a href="https://nation.africa/kenya/contact-us-294088" target="_blank" title="Contact Us">Contact Us</a></li>
<li><a href="https://nation.africa/kenya/frequently-asked-questions-303716" target="_blank" title="Frequently asked questions">Frequently asked questions</a></li>
<li><a href="https://nation.africa/kenya/nmg-privacy-policy-303724" target="_blank" title="NMG Privacy Policy">NMG Privacy Policy</a></li>
<li><a href="https://nation.africa/kenya/terms-of-use-303726" target="_blank" title="Terms of use">Terms of use</a></li>
<li><a href="https://nation.africa/kenya/terms-and-conditions" target="_blank" title="Terms and Conditions of Use">Terms and Conditions of Use</a></li>
<li><a href="https://nation.africa/kenya/our-blog-rules-549010" target="_blank" title="Our Blog Rules">Our Blog Rules</a></li>
</ul>
</div>
<div class="dnFooter-col-sm-2">
<h5>NMG Sites</h5>
<ul>
<li><a href="https://epaper.nation.africa" target="_blank" title="Nation ePaper">Nation ePaper</a></li>
<li><a href="http://www.businessdailyafrica.com/" target="_blank" title="Business Daily">Business Daily</a></li>
<li><a href="https://www.ntvkenya.co.ke" target="_blank" title="NTV">NTV</a></li>
<li><a href="http://www.ntv.co.ug/" target="_blank" title="NTV Uganda">NTV Uganda</a></li>
<li><a href="http://www.monitor.co.ug/" target="_blank" title="Daily Monitor">Daily Monitor</a></li>
<li><a href="http://www.thecitizen.co.tz/" target="_blank" title="The Citizen">The Citizen</a></li>
<li><a href="https://www.theeastafrican.co.ke/" target="_blank" title="The Eastafrican">The Eastafrican</a></li>
<li><a href="http://www.nationmedia.com/" target="_blank" title="Nation Media Group">Nation Media Group</a></li>
</ul>
</div>
<div class="dnFooter-col-sm-3">
<h5>Follow us</h5>
<div class="social-networks">
<a href="https://www.facebook.com/TheEastAfrican" target="_blank">
<i class="fa fa-facebook" aria-hidden="true"></i>
</a>
<a href="https://www.instagram.com/The_EastAfrican" target="_blank">
<i class="fa fa-instagram" aria-hidden="true"></i>
</a>
<a href="https://twitter.com/The_EastAfrican" target="_blank">
<i class="fa fa-twitter" aria-hidden="true"></i>
</a>
<a href="https://www.youtube.com/channel/UCjIeyvMe_cmyRrVyNvsyszQ" target="_blank">
<i class="fa fa-youtube" aria-hidden="true"></i>
</a>
<a href="https://t.me/theeastafrican" target="_blank">
<i class="fa fa-telegram" aria-hidden="true"></i>
</a>
<a href="/service/rss/tea/1289208/feed.rss" target="_blank">
<i class="fa fa-rss-square" aria-hidden="true"></i>
</a>
<h1 style="font-size: 0px; margin: 0px;">The East African</h1>
</div>
</div>
</footer>
</footer><noscript class="cm-javascript">
Please enable JavaScript to use this website.
</noscript>
<script type="text/javascript"> function GaAccountData(webPropertyId, domainName) {
this.webPropertyId = webPropertyId;
this.domainName = domainName;
}
function GaPageviewData(contentId, contentType, navigationPath, pageUrl, authors, pubDate, tags, queryParameter, query, userSegments, disableAdFeaturesPlugin) {
this.contentId = contentId;
this.contentType = contentType;
this.navigationPath = navigationPath;
this.pageUrl = pageUrl;
this.authors = authors;
this.pubDate = pubDate;
this.tags = tags;
this.queryParameter = queryParameter;
this.query = query;
this.userSegments = userSegments;
this.disableAdvertisingFeaturesPlugin = typeof disableAdFeaturesPlugin !== 'undefined' ? disableAdFeaturesPlugin : false;
}
function GaEventData(category, action, name, value) {
this.category = category;
this.action = action;
this.name = name;
this.value = value;
}
function gaTrackPageview(ga, gaAccountData, gaPageviewData, trackerName) {
var t = _gaTrackerPrefix(trackerName);
//set Account
if (trackerName && trackerName.length > 0) {
ga('create', gaAccountData.webPropertyId, gaAccountData.domainName, {'name': trackerName});
} else {
ga('create', gaAccountData.webPropertyId, gaAccountData.domainName);
}
ga(t.concat('set'), 'anonymizeIp', true);
if (!gaPageviewData.disableAdvertisingFeaturesPlugin) {
ga(t.concat('require'), 'displayfeatures');
}
//set custom vars
ga(t.concat('set'), 'dimension1', gaPageviewData.contentId);
ga(t.concat('set'), 'dimension2', gaPageviewData.contentType);
ga(t.concat('set'), 'dimension3', gaPageviewData.navigationPath);
ga(t.concat('set'), 'dimension4', gaPageviewData.userSegments);
ga(t.concat('set'), 'dimension5', gaPageviewData.authors);
ga(t.concat('set'), 'dimension6', gaPageviewData.pubDate);
ga(t.concat('set'), 'dimension7', gaPageviewData.tags);
// if a search was performed on the website, retain the search query
var query = "";
if (gaPageviewData.query && gaPageviewData.queryParameter) {
query = "?" + gaPageviewData.queryParameter + "=" + encodeURIComponent(gaPageviewData.query);
}
//send page view
ga(t.concat('send'), 'pageview', gaPageviewData.pageUrl + query);
}
function gaTrackEvent(ga, gaAccountData, gaPageviewData, gaEventData, trackerName) {
var t = _gaTrackerPrefix(trackerName);
//set Account
if (trackerName && trackerName.length > 0) {
ga('create', gaAccountData.webPropertyId, gaAccountData.domainName, {'name': trackerName});
} else {
ga('create', gaAccountData.webPropertyId, gaAccountData.domainName);
}
ga(t.concat('set'), 'anonymizeIp', true);
if (!gaPageviewData.disableAdvertisingFeaturesPlugin) {
ga(t.concat('require'), 'displayfeatures');
}
//set custom vars
ga(t.concat('set'), 'dimension1', gaPageviewData.contentId);
ga(t.concat('set'), 'dimension2', gaPageviewData.contentType);
ga(t.concat('set'), 'dimension3', gaPageviewData.navigationPath);
ga(t.concat('set'), 'dimension4', gaPageviewData.userSegments);
ga(t.concat('set'), 'dimension5', gaPageviewData.authors);
ga(t.concat('set'), 'dimension6', gaPageviewData.pubDate);
ga(t.concat('set'), 'dimension7', gaPageviewData.tags);
//sent event
ga(t.concat('send'), 'event', gaEventData.category, gaEventData.action, gaEventData.name, gaEventData.value);
}
function _gaTrackerPrefix(trackerName) {
return (trackerName && trackerName.length > 0)
? trackerName.concat('.')
: '';
}
(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
})(window,document,'script','//www.google-analytics.com/analytics.js','ga');
var gaAccountData = new GaAccountData("UA-1030601-5", "www.theeastafrican.co.ke");
var gaPageData = new GaPageviewData(
"3959376",
"CMArticle",
"1289142_1289144_1289208",
"/tea/news/east-africa/lessons-from-the-westgate-terror-attack-3959376",
"MARY WAMBUI",
"23-09-2022",
"Africa",
false
);
gaTrackPageview(ga, gaAccountData, gaPageData);
</script><script type='text/javascript' src='//www.youtube.com/iframe_api'></script>
<script type='text/javascript'>
(function() {
var _sf_async_config = window._sf_async_config = (window._sf_async_config || {});
/** CONFIGURATION START **/
_sf_async_config.uid = 63208;
_sf_async_config.domain = 'theeastafrican.co.ke';
_sf_async_config.flickerControl = false;
_sf_async_config.useCanonical = true;
_sf_async_config.useCanonicalDomain = true;
_sf_async_config.sections = 'News,News - East Africa';
_sf_async_config.authors ='MARY WAMBUI';
/** CONFIGURATION END **/
function loadChartbeat() {
var e = document.createElement('script');
var n = document.getElementsByTagName('script')[0];
e.type = 'text/javascript';
e.async = true;
e.src = '//static.chartbeat.com/js/chartbeat_video.js';
n.parentNode.insertBefore(e, n);
}
/** TELL CHARTBEAT TO AUTODETECT YOUTUBE VIDEOS **/
var _cbv = window._cbv || (window._cbv = []);
_cbv.push(['autoDetectYouTubeIframes']);
loadChartbeat();
})();
</script>
<script async src="//static.chartbeat.com/js/chartbeat_mab.js"></script>
<script>window.tentacles = {apiToken: 'duw3gbl8t40rhv3p6xsa5f9xlv3xe161'};</script>
<script async src="https://tentacles.smartocto.com/ten/tentacle.js"></script> <script type="text/javascript">
window._taboola = window._taboola || [];
_taboola.push({flush: true});
</script>
<script src="/resource/themes/east-african/js/commons-654256-2.js"></script><script src="/resource/themes/east-african/js/east-african-654258-7.js"></script>
<script>window.googletag=window.googletag ||{cmd: []}; googletag.cmd.push(function(){googletag.defineSlot('/1010816/TEA-1x1', [1, 1], 'div-gpt-ad-1634797092980-0').addService(googletag.pubads()); googletag.pubads().enableSingleRequest(); googletag.pubads().collapseEmptyDivs(); googletag.enableServices();});</script><div id='div-gpt-ad-1634797092980-0'> <script>googletag.cmd.push(function(){googletag.display('div-gpt-ad-1634797092980-0');}); </script></div><script>(function(){var js = "window['__CF$cv$params']={r:'74f55ff0df7d82f9',m:'j3ZzVqXxjP9mlO9P3wyk4.gwmTehXtbZpCGYYMsulMw-1663958070-0-ASO+1Ee3g2LV58RzVgY5CQK73/tjE6SWfnhbimKijb98Bs4LUof3/XF4IBwWY9rT6nrKMm1OTu8SaBEReXTSqBaz44VyKAkDVbhoygb+F+OGwzY9a0Z9N5dXF2mcYdy6kh57z83TaFxaIvSuv+ReZsreVXeuHqzeB9+eW6y1NGsRbdhCDhIgTXsFrfUvR3LkbfkoFUTJfoQbF/8qxnFx87s=',s:[0x28613afa90,0x22e0e18ab2],u:'/cdn-cgi/challenge-platform/h/g'};var now=Date.now()/1000,offset=14400,ts=''+(Math.floor(now)-Math.floor(now%offset)),_cpo=document.createElement('script');_cpo.nonce='',_cpo.src='/cdn-cgi/challenge-platform/h/g/scripts/alpha/invisible.js?ts='+ts,document.getElementsByTagName('head')[0].appendChild(_cpo);";var _0xh = document.createElement('iframe');_0xh.height = 1;_0xh.width = 1;_0xh.style.position = 'absolute';_0xh.style.top = 0;_0xh.style.left = 0;_0xh.style.border = 'none';_0xh.style.visibility = 'hidden';document.body.appendChild(_0xh);function handler() {var _0xi = _0xh.contentDocument || _0xh.contentWindow.document;if (_0xi) {var _0xj = _0xi.createElement('script');_0xj.nonce = '';_0xj.innerHTML = js;_0xi.getElementsByTagName('head')[0].appendChild(_0xj);}}if (document.readyState !== 'loading') {handler();} else if (window.addEventListener) {document.addEventListener('DOMContentLoaded', handler);} else {var prev = document.onreadystatechange || function () {};document.onreadystatechange = function (e) {prev(e);if (document.readyState !== 'loading') {document.onreadystatechange = prev;handler();}};}})();</script></body></html>
